Matrix Games Forums

To End All Wars: Mountain InfantryPandora: Eclipse of Nashira Announced! Deal of the Week: Command Ops goes half price!New Fronts are opening up for Commander: The Great WarCharacters of World War 1Sign of for the Pike and Shot Beta!More Games are Coming to Steam! Return to the Moon on October 31st! Commander: The Great War iPad Wallpapers Generals of the Great War
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

My theme is FIXED!

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> My theme is FIXED! Page: [1]
Login
Message << Older Topic   Newer Topic >>
My theme is FIXED! - 7/31/2012 3:00:24 PM   
DracoRedux


Posts: 13
Joined: 11/17/2010
Status: offline
Hello All,

I haven't been active on the forums in a very long time. I am back as I learned about the latest expansion. I stumbled upon the customization guide and decided I wanted to make my own race. I followed the guide verbatim and my theme loads, but I am unable to start a game. The problem is not specifically with my custom race. I cannot start a game with any race once the theme is active. Switching back to default theme fixes the issue with starting games, but obviously removes my custom race as well. The specific message is "Could not start game" and I have rechecked everything against the guide about 50 times. Any help is appreciated.

-Draco

< Message edited by DracoRedux -- 8/20/2012 8:12:14 AM >
Post #: 1
RE: My theme is broken? - 7/31/2012 3:06:51 PM   
tjhkkr


Posts: 1828
Joined: 6/3/2010
Status: offline
Howdy.

I am not sure we have enough data to know; it could be you are missing a critical file...
Can you tell us a little more about what is contained in your mod?

_____________________________

Remember that the evil which is now in the world will become yet more powerful, and that it is not evil which conquers evil, but only love -- Olga Romanov.

(in reply to DracoRedux)
Post #: 2
RE: My theme is broken? - 7/31/2012 3:49:28 PM   
Quadro7F


Posts: 23
Joined: 7/25/2012
Status: offline
I had the same error not long time ago.

Here is main things what could help you to solve this:

1) Make sure what you have all races txt files in "races" folder (yours and vanilla ones).
2) Make sure what you have all policy txt files in "policy" folder (yours and vanilla ones).
3) Make sure what you have your races images in "raceImages" folder (only for races you added).
4) Make sure what you have your troop images in "troopImages" folder (only for races you added).
5) You need to have at least one character for any race in "characters" folder.
6) You need to have all family's files in "shipImages" folder (yours and vanilla ones)

And the most important - check you biases.txt, there should be:
- proper number of races
- races names should match the names from races.txt files (this is important)

All other folders and files such as flagShapes are not nesessary and not critical for mod to proper launch.

(in reply to tjhkkr)
Post #: 3
RE: My theme is broken? - 7/31/2012 4:50:49 PM   
DracoRedux


Posts: 13
Joined: 11/17/2010
Status: offline
quote:

ORIGINAL: Quadro7F

I had the same error not long time ago.

Here is main things what could help you to solve this:

1) Make sure what you have all races txt files in "races" folder (yours and vanilla ones).
2) Make sure what you have all policy txt files in "policy" folder (yours and vanilla ones).
3) Make sure what you have your races images in "raceImages" folder (only for races you added).
4) Make sure what you have your troop images in "troopImages" folder (only for races you added).
5) You need to have at least one character for any race in "characters" folder.
6) You need to have all family's files in "shipImages" folder (yours and vanilla ones)

And the most important - check you biases.txt, there should be:
- proper number of races
- races names should match the names from races.txt files (this is important)

All other folders and files such as flagShapes are not nesessary and not critical for mod to proper launch.


The only thing I didn't have out of everything you listed was #6, Quadro. I fixed it and reloaded the theme, but I still get the same error. I am obviously missing something big, because it breaks all of the races being played and not just the custom.

quote:

ORIGINAL: tjhkkr

Howdy.

I am not sure we have enough data to know; it could be you are missing a critical file...
Can you tell us a little more about what is contained in your mod?


1. New Race file
2. New policy file
3. Custom ship images
4. Custom troop Image
5. Custom character for the race
6. Custom character image
7. Custom Ship Names
8. Custom System Names
9. Updated biases.txt

Any further information would be helpful.

-Draco


< Message edited by DracoRedux -- 7/31/2012 5:21:43 PM >

(in reply to Quadro7F)
Post #: 4
RE: My theme is broken? - 7/31/2012 5:36:26 PM   
Quadro7F


Posts: 23
Joined: 7/25/2012
Status: offline
1)How many races do you have?
2)How many family folders do you have?
3)Are you using custom shipsets or default ones for new races?

Oh, and check you characters txt files - there should be correct name of their race as well.

< Message edited by Quadro7F -- 7/31/2012 5:39:40 PM >

(in reply to DracoRedux)
Post #: 5
RE: My theme is broken? - 7/31/2012 6:49:27 PM   
ehsumrell1


Posts: 2026
Joined: 8/17/2010
From: The Briar Patch Nebula
Status: offline
quote:

ORIGINAL: DracoRedux

Hello All,

I haven't been active on the forums in a very long time. I am back as I learned about the latest expansion. I stumbled upon the customization guide and decided I wanted to make my own race. I followed the guide verbatim and my theme loads, but I am unable to start a game. The problem is not specifically with my custom race. I cannot start a game with any race once the theme is active. Switching back to default theme fixes the issue with starting games, but obviously removes my custom race as well. The specific message is "Could not start game" and I have rechecked everything against the guide about 50 times. Any help is appreciated.

-Draco

Hello Draco;

In testing modding in DW, one thing I've found out is that the "Could not start game" errors when
adding mods 80% of the time is some form of syntax error. I suggest the following in addition to the
other excellent and valid points previously made.

1. (I found THIS the most) Make sure the ship classes in the added shipsets are spelled correctly
(explorership...not xplorership)
2. If using Return of the Shakturi or Legends expansions, make sure all the ship classes are there,
Carrier especially.
3. If character files are used (Legends version), your character.png files must be spelled EXACTLY as
stated inside the character.txt file pertaining to it.

I've found that in testing other mods for people, these forms of items are what usually cause the
"Could not start game" error box. Normally, if it is a biases.txt file problem, the game will load
to a point, then give you a "Could not read Bias Value X at Line Y of file (Filepath & name).

I noticed you stated you have added/edited the following:

1. New Race file <-- Shouldn't be a problem if you started with a copy of a original DW file.
2. New policy file <-- Shouldn't be a problem if you started with a copy of a original DW file.
3. Custom ship images <-- Could be a problem in this file as I mentioned above.
4. Custom troop Image <-- Long as its a .png image, won't be a problem.
5. Custom character for the race <-- Could be a problem in this file as mentioned above. MOST LIKELY, IMO
6. Custom character image <-- Could be a problem in this file as I mentioned above.
7. Custom Ship Names <-- Could be a problem in this file. IMO.
8. Custom System Names <-- Shouldn't be a problem if you started with a copy of a original DW file.
9. Updated biases.txt <-- Shouldn't be a problem if you started with a copy of a original DW file.

Hope this helps! If not, post back again after checking things out and let us know! Good luck in
finding the error!

< Message edited by ehsumrell1 -- 7/31/2012 6:56:34 PM >


_____________________________

Shields are useless in "The Briar Patch"...

(in reply to DracoRedux)
Post #: 6
RE: My theme is broken? - 7/31/2012 6:51:41 PM   
Haree78


Posts: 1252
Joined: 5/18/2010
Status: offline
Sometimes I add in tons of stuff in a mod and it will crash on start up and I get a headache. Best way is to strip the mod back to bare bones, move folders to somewhere else and add stuff in bit by bit. It's the only advice I can give, there is a fair few things that can cause the issue.

One quick thing I can think is switch to default theme and start a game with only 1 enemy race, then come back out and try your mod. I know it used to cause a problem on starting a game if you switched to a theme where that number was saved as higher than the races you have in a theme. Haven't checked if that is fixed yet.

_____________________________

Distant Worlds Extended
Battlestar Galactica Legends Mod

(in reply to Quadro7F)
Post #: 7
RE: My theme is broken? - 7/31/2012 9:03:04 PM   
tjhkkr


Posts: 1828
Joined: 6/3/2010
Status: offline
quote:

ORIGINAL: Haree78
Sometimes I add in tons of stuff in a mod and it will crash on start up and I get a headache. Best way is to strip the mod back to bare bones, move folders to somewhere else and add stuff in bit by bit. It's the only advice I can give, there is a fair few things that can cause the issue.


Yes spoken like a true programmer... that is how I would approach it...

_____________________________

Remember that the evil which is now in the world will become yet more powerful, and that it is not evil which conquers evil, but only love -- Olga Romanov.

(in reply to Haree78)
Post #: 8
RE: My theme is broken? - 8/2/2012 3:14:03 PM   
DracoRedux


Posts: 13
Joined: 11/17/2010
Status: offline

quote:

ORIGINAL: ehsumrell1

quote:

ORIGINAL: DracoRedux

Hello All,

I haven't been active on the forums in a very long time. I am back as I learned about the latest expansion. I stumbled upon the customization guide and decided I wanted to make my own race. I followed the guide verbatim and my theme loads, but I am unable to start a game. The problem is not specifically with my custom race. I cannot start a game with any race once the theme is active. Switching back to default theme fixes the issue with starting games, but obviously removes my custom race as well. The specific message is "Could not start game" and I have rechecked everything against the guide about 50 times. Any help is appreciated.

-Draco

Hello Draco;

In testing modding in DW, one thing I've found out is that the "Could not start game" errors when
adding mods 80% of the time is some form of syntax error. I suggest the following in addition to the
other excellent and valid points previously made.

1. (I found THIS the most) Make sure the ship classes in the added shipsets are spelled correctly
(explorership...not xplorership)
2. If using Return of the Shakturi or Legends expansions, make sure all the ship classes are there,
Carrier especially.
3. If character files are used (Legends version), your character.png files must be spelled EXACTLY as
stated inside the character.txt file pertaining to it.

I've found that in testing other mods for people, these forms of items are what usually cause the
"Could not start game" error box. Normally, if it is a biases.txt file problem, the game will load
to a point, then give you a "Could not read Bias Value X at Line Y of file (Filepath & name).

I noticed you stated you have added/edited the following:

1. New Race file <-- Shouldn't be a problem if you started with a copy of a original DW file.
2. New policy file <-- Shouldn't be a problem if you started with a copy of a original DW file.
3. Custom ship images <-- Could be a problem in this file as I mentioned above.
4. Custom troop Image <-- Long as its a .png image, won't be a problem.
5. Custom character for the race <-- Could be a problem in this file as mentioned above. MOST LIKELY, IMO
6. Custom character image <-- Could be a problem in this file as I mentioned above.
7. Custom Ship Names <-- Could be a problem in this file. IMO.
8. Custom System Names <-- Shouldn't be a problem if you started with a copy of a original DW file.
9. Updated biases.txt <-- Shouldn't be a problem if you started with a copy of a original DW file.

Hope this helps! If not, post back again after checking things out and let us know! Good luck in
finding the error!


Well, I stripped it down piece by piece as mentioned. It was the character.txt file causing the error. I still haven't figured out why, though. Thanks for pointing that out.

On a separate note, is there a way to have different images for each type of character? I'd like Darth Vader to be all the fleet admirals and Grand Moff Tarkin to be all the governors.

-Draco

(in reply to ehsumrell1)
Post #: 9
RE: My theme is broken? - 8/2/2012 7:23:09 PM   
tjhkkr


Posts: 1828
Joined: 6/3/2010
Status: offline
quote:

ORIGINAL: DracoRedux
On a separate note, is there a way to have different images for each type of character? I'd like Darth Vader to be all the fleet admirals and Grand Moff Tarkin to be all the governors.
-Draco


Personally, for my Anakin and other characters, I use several group shots so I can use the same image for multiple characters, but it does alllow me to designate other pictures for Anakin the general over Anakin the Admiral versus Anakin the commando/agent... And of course Obi wan for admiral... you get the idea...
You could use a picture of Anakin/Darth Vader with Tarken on the Death Star for one, and then maybe another with an Imperial officer with Tarkin and so on...

< Message edited by tjhkkr -- 8/2/2012 7:31:27 PM >


_____________________________

Remember that the evil which is now in the world will become yet more powerful, and that it is not evil which conquers evil, but only love -- Olga Romanov.

(in reply to DracoRedux)
Post #: 10
RE: My theme is broken? - 8/2/2012 8:53:09 PM   
Haree78


Posts: 1252
Joined: 5/18/2010
Status: offline

quote:

ORIGINAL: DracoRedux

Well, I stripped it down piece by piece as mentioned. It was the character.txt file causing the error. I still haven't figured out why, though. Thanks for pointing that out.

On a separate note, is there a way to have different images for each type of character? I'd like Darth Vader to be all the fleet admirals and Grand Moff Tarkin to be all the governors.

-Draco


There is a part of the character files that claims it is optional in the modding guide that isn't, I believe it is the characters race? Make sure you set the race specifically and test it again.

_____________________________

Distant Worlds Extended
Battlestar Galactica Legends Mod

(in reply to DracoRedux)
Post #: 11
RE: My theme is broken? - 8/2/2012 9:38:57 PM   
ehsumrell1


Posts: 2026
Joined: 8/17/2010
From: The Briar Patch Nebula
Status: offline
quote:

ORIGINAL: DracoRedux

Well, I stripped it down piece by piece as mentioned. It was the character.txt file causing the error. I still haven't figured out why, though. Thanks for pointing that out.
-Draco


Draco;

Each character line needs the following: (Example below)



1, William Riker, 4, Will Riker_Fed_Admiral.png, Human, ------ then Stats Numbers-->

quote:

ORIGINAL: DracoRedux

On a separate note, is there a way to have different images for each type of character? I'd like Darth Vader to be all the fleet admirals and Grand Moff Tarkin to be all the governors.


To do that just make the Character Image file name the same for each class. Hope this helps!




< Message edited by ehsumrell1 -- 8/2/2012 10:03:07 PM >


_____________________________

Shields are useless in "The Briar Patch"...

(in reply to DracoRedux)
Post #: 12
RE: My theme is broken? - 8/3/2012 5:25:43 AM   
DracoRedux


Posts: 13
Joined: 11/17/2010
Status: offline

quote:

ORIGINAL: Quadro7F

I had the same error not long time ago.

Here is main things what could help you to solve this:

1) Make sure what you have all races txt files in "races" folder (yours and vanilla ones).
2) Make sure what you have all policy txt files in "policy" folder (yours and vanilla ones).
3) Make sure what you have your races images in "raceImages" folder (only for races you added).
4) Make sure what you have your troop images in "troopImages" folder (only for races you added).
5) You need to have at least one character for any race in "characters" folder.
6) You need to have all family's files in "shipImages" folder (yours and vanilla ones)

And the most important - check you biases.txt, there should be:
- proper number of races
- races names should match the names from races.txt files (this is important)

All other folders and files such as flagShapes are not nesessary and not critical for mod to proper launch.

I removed the characters folder completely from my theme, so I don't believe number 5 is correct. Although the other races have one in the original directory, my race doesn't have its own character file. I was surprised to see it work without it.

-Draco

(in reply to Quadro7F)
Post #: 13
RE: My theme is broken? - 8/3/2012 5:59:03 AM   
Quadro7F


Posts: 23
Joined: 7/25/2012
Status: offline
quote:

ORIGINAL: DracoRedux

I removed the characters folder completely from my theme, so I don't believe number 5 is correct. Although the other races have one in the original directory, my race doesn't have its own character file. I was surprised to see it work without it.

-Draco


Aye, Characters are optional, its just manual recommendations. I noted this just in case, because it helped some other modmaker before.

But anyway, its good to know - less work to do.

(in reply to DracoRedux)
Post #: 14
RE: My theme is broken? - 8/19/2012 11:02:46 PM   
DracoRedux


Posts: 13
Joined: 11/17/2010
Status: offline
I am still not getting exactly how to use the custom character creation. This is an example from the human character file.

"0, Than Bendu, 2, , Human,(forum doesn't recognize spaces)1, 25, 0, 0, 0, 0, 0, 0,(have to separate the two sets of numbers with this apparently)37, 39, 0"

I opened it with notepad++ to make it easier to read. I love that program. Anyway, would someone care to break down the numbers? For example, the "1, 25" part. Is 1 a trait and 25 it's percentage? Lol, I don't get it.

-Draco

< Message edited by DracoRedux -- 8/19/2012 11:35:13 PM >

(in reply to Quadro7F)
Post #: 15
RE: My theme is broken? - 8/20/2012 12:13:51 AM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline
The '1' is the skill (in this case it's diplomacy) and the 25 is the percentage bonus. Those last 3 fields are used for traits for example, paranoid, pacifist etc. So each custom character can have up to 4 skills and up to 3 traits.

I'd recommend printing the customization guide for a quick reference. Certain skills and traits only apply to certain character types.

If you haven't already downloaded the customization guide, here it is:- http://www.matrixgames.com/forums/forceddownload.asp?file=0;2972691.

_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to DracoRedux)
Post #: 16
RE: My theme is broken? - 8/20/2012 8:10:09 AM   
DracoRedux


Posts: 13
Joined: 11/17/2010
Status: offline
quote:

ORIGINAL: DracoRedux


quote:

ORIGINAL: Quadro7F

5) You need to have at least one character for any race in "characters" folder.


I removed the characters folder completely from my theme, so I don't believe number 5 is correct. Although the other races have one in the original directory, my race doesn't have its own character file. I was surprised to see it work without it.

-Draco

In fact, I believe that is what broke the game when I tried before. I now have a fully modified set of Star Wars agents and a custom race. Everything works as intended. I am still looking for a few custom images, but I'll find them soon enough. Now, if we could get modding support for components Yes, yes. I know it is already in the Master wishlist thread.

I chose Sith because Empire isn't a race. I realize that most of the Empire is composed of humans in leadership roles, but I guess I'll pretend that Palpatine found some Sith refugess in stasis and built a new empire around them? Lol. I can't release it, though. I used too many other sources and would feel bad if I didn't credit everyone. It wasn't exactly hard, anyway. I'm sure anyone else could do it if they already haven't. Thanks for all the help, guys.

-Draco

< Message edited by DracoRedux -- 8/20/2012 8:11:31 AM >

(in reply to DracoRedux)
Post #: 17
RE: My theme is broken? - 8/27/2012 3:56:21 PM   
tjhkkr


Posts: 1828
Joined: 6/3/2010
Status: offline
quote:

ORIGINAL: DracoRedux
I used too many other sources and would feel bad if I didn't credit everyone. It wasn't exactly hard, anyway. I'm sure anyone else could do it if they already haven't. Thanks for all the help, guys.
-Draco


That is my biggest concern too... not even the mods here on this site, because everyone is low key and to say, I took this and that from this person and that person is enough.
But I got a lot of stuff from EAW, Rebellion, and the like.


_____________________________

Remember that the evil which is now in the world will become yet more powerful, and that it is not evil which conquers evil, but only love -- Olga Romanov.

(in reply to DracoRedux)
Post #: 18
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> My theme is FIXED! Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.105