Matrix Games Forums

War in the West gets its first update!Flashpoint Campaigns: Red Storm version 2.08 is now available!Command gets huge update!Order of Battle: Pacific Featured on Weekly Streaming SessionA new fight for Battle Academy!Buzz Aldrin's Space Program Manager is out for Mac!The definitive wargame of the Western Front is out now! War in the West gets teaser trailer and Twitch Stream!New Preview AAR for War in the West!War in the West Manual preview
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

NEVERENDING Crash at startup

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> NEVERENDING Crash at startup Page: [1]
Login
Message << Older Topic   Newer Topic >>
NEVERENDING Crash at startup - 7/11/2012 1:29:40 PM   
Lumarra

 

Posts: 4
Joined: 4/7/2010
Status: offline
Seriously, I've had it! I've lurked here on this board since DW first came out and I've put more hours into it than I'd like to admit. If you like 4x games, how could you not? But I've been beat not by the games AI opponent, oh no, but by one simple, maddening, hair-pulling error. That error is 'CLR20r3'! This error has made me go from singing this games praises to cursing it's very name! I have tried EVERYTHING I could come up with to get around this error and nothing has worked. Nothing. I scoured this board, 14 pages of Google links, anything. I re-installed everything short of Windows itself. And before you even dare make that a consideration, I will not re-install Windows just to play one game! That's absolutely absurd! I know my way around a PC, I build them for a living and hobby and can do it blindfolded if it came to that. I've been playing games on the PC for nearly 30 years and there has rarely been a game that gave me such a hassle! I got Battlecruiser 3000AD to run in it's first release! (*hushed silence!*) I've paid my dues.

But this...*shakes head*...this I can't fix. I run Windows7SP1/x64, and only because I have 6gb of RAM, otherwise I would go back to 32-bit in a heartbeat! This 64-bit crap is too much trouble for it's worth! This error proves that! DW worked flawlessly on Win7SP1/x86, but when I installed x64 two months ago because I upgraded from 2gb to 6gb of RAM, it hasn't worked since. I've have done everything recommended in prior threads with regards to dotNET 4, DirectX, all files are accounted for. My error, as similar as it is to previous ones, is not going away with the fixes that have helped others. It doesn't matter where I install it, whether it be in it's default directory or in my usual 'Games' directory, when I install RotS and beyond, it ceases to load. The first, original game works fine. In fact, I kept the .exe from the first version and copied it into a Legends install and it ran without any problems whatsoever! So what is it that was changed with RotS and Legends that totally screws it up on x64?! I have everything that needs to be installed. Media Player, IE9, Media Center was reinstalled, my video drivers are up to date, DirectX is up to date, dotNET4 is in and updated. I can try it under 'Run as Admin' with no change, under compatibility with both XP and Vista with no change. ALL CRASH AT STARTUP!

I seriously hope that someone can figure this out because I'm going nuts! I want to play this game in the worst way but all I get is a crash! I humbly beg you, on my knees, HELP ME PLEASE!

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: distantworlds.exe
Problem Signature 02: 1.7.0.14
Problem Signature 03: 4fa154df
Problem Signature 04: DistantWorlds
Problem Signature 05: 1.7.0.14
Problem Signature 06: 4fa154df
Problem Signature 07: 1d0c
Problem Signature 08: c
Problem Signature 09: System.TypeLoadException
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033




-Lumarra

< Message edited by Lumarra -- 7/12/2012 10:42:50 AM >
Post #: 1
RE: NEVERENDING Crash at startup - 7/11/2012 8:11:52 PM   
Bebop Cola

 

Posts: 236
Joined: 5/9/2012
Status: offline
I notice you're running version 1.7.0.14. Have you tried release 1.7.0.6? Have you tried release 1.7.0.15?

(in reply to Lumarra)
Post #: 2
RE: NEVERENDING Crash at startup - 7/11/2012 8:48:21 PM   
Sovereign108

 

Posts: 4
Joined: 7/11/2012
Status: offline
I have the same problem - I just bought this game and its expansions. I have been in touch with support but they have no clue as to what to do! If I get no response, I'm gonna have to get my full refunds!

(in reply to Bebop Cola)
Post #: 3
RE: NEVERENDING Crash at startup - 7/12/2012 1:42:42 AM   
Dracus

 

Posts: 162
Joined: 11/29/2011
Status: offline
are you adding in mods after you install?

(in reply to Sovereign108)
Post #: 4
RE: NEVERENDING Crash at startup - 7/12/2012 2:33:23 AM   
Lumarra

 

Posts: 4
Joined: 4/7/2010
Status: offline
No, no mods are added after install. It says 1.7.0.14 because I had tried the upgrade right before making my post just to see if it would fix the crash, but it didn't. The error does not change with any version. The only time it runs is with the first, original game. After I install RotS, it crashes. That's why I want to know what was changed between the original and the two expansions that might be causing this. As I said in my OP, I even kept the 1.0.1.0 distantworlds.exe file separate and put it into a brand new Legends install and it ran without any problems, no crash. I have tried every conceivable thing (short of re-installing 32-bit Windows7) and everything that was asked in previous posts here about this problem I have done, with no progress. I'm just so disgusted by it all, really! To try each new thing I came across and then try to run it and see that stupid error each and every time, 'Distant Worlds has stopped working'...it's maddening!

EDIT 07-12-12, 540am: I'll also list my system specs but I doubt they have anything to do with the problem. I very rarely have a problem with other games that I can't track down a cause for. Just to be thorough, I want to find a fix for this! Where are the devs and mods? This place looks abandoned!

Gigabyte P55M-UD2
Intel Core i5-750/2.8ghz
6gb DDR3 RAM
HIS AMD/ATI Radeon HD5770/1gb (12.6 Catalyst drivers)
2tb Western Digital Caviar Black, 500gb Matrox, 200gb Seagate, 160gb Seagate, 40gb Intel X-25V SSD, 24x Lite-On iHAS324 DVD-RW
Onboard RealTek HDAudio
Antec EarthWatts 650w PSU in a ThermalTake LanboxLite w/4 60mm case fans and 2 80mm case fans
Logitech G510 keyboard, G700 mouse, X530 5.1's subwoofer/speakers, G25 wheel/pedals (modded)/shifter, Rumblepad2 gamepad
Samsung SyncMaster 2253BW 22" widescreen LCD (16:10, 1680x1050)
Windows 7SP1/x64

All drivers, firmware, and BIOS are updated and current. No other operating problems experienced. I know what I'm doing and I know it's not my system causing the problem (hardware-wise). I'm sure there are plenty other gamers with this same issue that haven't posted, for whatever reason. It needs to be fixed!

-Lumarra


< Message edited by Lumarra -- 7/12/2012 8:07:20 PM >

(in reply to Dracus)
Post #: 5
RE: NEVERENDING Crash at startup - 7/12/2012 2:22:23 PM   
michaelm


Posts: 9492
Joined: 5/5/2001
From: Sydney, Australia
Status: online
I have Win 7 64-bit running DW/RotS/Legends without any issues.


_____________________________

Michael

(in reply to Lumarra)
Post #: 6
RE: NEVERENDING Crash at startup - 7/12/2012 5:25:53 PM   
Bebop Cola

 

Posts: 236
Joined: 5/9/2012
Status: offline
Same here. Not much help to say so, and I apologize for that, but I'm not really sure where to point you on this.

(in reply to michaelm)
Post #: 7
RE: NEVERENDING Crash at startup - 7/12/2012 5:40:52 PM   
BTJ


Posts: 42
Joined: 1/6/2012
Status: offline
I also run Win 7 64 bit with 8Gb of RAM. No problems.

You should not only send a support ticket, but maybe send a PM to Erik? The guys here are generally very helpful.

(in reply to Bebop Cola)
Post #: 8
RE: NEVERENDING Crash at startup - 7/12/2012 7:56:13 PM   
Lumarra

 

Posts: 4
Joined: 4/7/2010
Status: offline
Yeah, I'm sure there are those out there that are having no problem whatsoever with it on x64 and I do appreciate you guys chiming in, at least I know that people are taking the time to look the thread over anyway. I'm trying not to sound like a whiny little kid who can't get his favorite toy to work but...I also know I'm not the only one with the problem and because of that I think the devs or mods or whoever handles this stuff officially should take a serious look into it. I'd be willing to provide whatever info they need or do any steps they might want done to get this fixed once and for all. I might just PM Erik, if he hasn't already seen the OP. I haven't been able to play DW: Legends in months, I went from playing hours nearly every day (and looking forward to it when I wasn't) to not playing at all, and it sucks! I'm half tempted to re-install WinXP or Win7/x32 on a separate partition but I don't feel that's right in this case. I feel like I'm not only trying to get this fixed for me alone but all those out there that are having the same problem and haven't spoken up for whatever reason. I don't just want to throw my hands up and say, 'oh well' and install an x32 version. I hope I've explained my motivations clear enough. I'm just frustrated, annoyed and every time I see that error, disgusted. I'm not ready to give up just yet...but, again, thanks guys for at least listening even if you don't really have an answer. I appreciate it anyway...


-Lumarra

(in reply to BTJ)
Post #: 9
RE: NEVERENDING Crash at startup - 7/12/2012 11:59:09 PM   
Dracus

 

Posts: 162
Joined: 11/29/2011
Status: offline
try this:

Set the the game folders to have rights full control. I set the group everyone to full control on my system for the game files an that got rid of some issues I was having.

Oh and 14 had a wierd error that looked like the game was crashed but if you clicked ok, it went on and loaded. see my bug report on the issue which appears to have been corrected in 15.

also when you do the updates, do not use the auto updater from the game. It grabs the wong patch.

< Message edited by Dracus -- 7/13/2012 12:14:45 AM >

(in reply to Lumarra)
Post #: 10
RE: NEVERENDING Crash at startup - 7/13/2012 3:14:35 AM   
elliotg


Posts: 3185
Joined: 9/10/2007
Status: offline
Sorry to hear about your problem Lumarra.

The "System.TypeLoadException" part of your error message indicates that DW is unable to load a required third-party component. The likely candidates here are one of the following:
1. Windows Media Player
2. Internet Explorer
3. the DirectX .Net assemblies

Make sure that your system has the above components installed and enabled. On 64-bit Windows you will likely also need the 32-bit versions of these apps installed. Thus for WMP you should see the folder "C:\Program Files (x86)\Windows Media Player\" and for IE you should see the folder "C:\Program Files (x86)\Internet Explorer\"

For the DirectX .Net assemblies check that the folder "C:\Windows\assembly\" has entries for "Microsoft.DirectX" and "Microsoft.DirectX.DirectSound"


If the above does not help, are you please able to post the contents of the following crash dump file to this thread?:

C:\Users\[YOURUSERNAME]\AppData\Roaming\Code Force Limited\Distant Worlds\1.7.0.14\DW_CrashDump.txt

Thanks
Elliot

(in reply to Lumarra)
Post #: 11
RE: NEVERENDING Crash at startup - 7/18/2012 5:51:20 PM   
conservus

 

Posts: 1
Joined: 7/18/2012
Status: offline
Hi Lumarra,
I also had the same problems like you, with update to 1.7.0.13 and 1.7.0.14 -> crash at first start....
You must clean you registry FIRST, after uninstalling the game. Use CCleaner or similar free programs for cleaning. Successful solution was manually deleting from registry any key with words "Distant Worlds" , key and folder (use run/regedit) and proceed carefully (do a back-up first at registry...).

Give it a try... here version 1.7.0.15 beta (moore stable and better).

(in reply to elliotg)
Post #: 12
RE: NEVERENDING Crash at startup - 8/1/2012 9:45:30 PM   
davelogan69

 

Posts: 2
Joined: 9/19/2010
Status: offline
Hi. I am having the Distant Worlds has stopped working error every time I try and start the game. I am running Windows 7 x64. This is my crash error report:
Distant Worlds - Crash Dump - 1.7.0.16

22:43:29 den 1 augusti 2012


System.ArgumentException: Font 'Arial' does not support style 'Regular'.
at System.Drawing.Font.CreateNativeFont()
at System.Drawing.Font.Initialize(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
at System.Drawing.Font..ctor(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit)
at DistantWorlds.Controls.GlassButton.SetFont()
at DistantWorlds.Controls.GlassButton..ctor()
at DistantWorlds.Start.S6yl31Vpln()
at DistantWorlds.Start..ctor()
at QukXpC1BE3xoeTuXDY.oN3gf1JGSWkDKW2j5R.wSBey0MGf()


--- COMPLETE ---
Update:
I fixed the problem European computers are lacking a few fonts which can be fixed with the European Union Expansion Font Update from Microsoft.

< Message edited by davelogan69 -- 8/1/2012 9:57:35 PM >

(in reply to conservus)
Post #: 13
RE: NEVERENDING Crash at startup - 8/3/2012 9:51:09 AM   
Lumarra

 

Posts: 4
Joined: 4/7/2010
Status: offline
First, my apologies for jumping in here, causing somewhat of a ruckus and then up and disappearing, I was extremely busy the last few weeks and not able to work on getting 'Legends' running. It was always on my mind though, thinking of alternative ways to fix the error but I couldn't dedicate the time to it lately. However, today was the first day I was able to actually have some time to spend on it. As I had stated in my OP, I had tried nearly everything to get Legends working under Win7/x64 with absolutely no luck whatsoever and it had become just a disgusting frustration. I even grabbed some relatives and friends who weren't even gamers or all that familiar with how games work under Windows (except for Solitaire and Angry Birds...lol) but I figured it might help to have a different perspective on it. Still, nothing worked. I came about >this< close to installing WinXP on a separate partition and dual-booting JUST to be able to play Legends (and some other apps that have failed to load under x64).

Today I didn't even know where I should start, so rather casually, I read the thread again and ran RegEdit and erased any and all references to DW or Legends in the registry. That done, I then remembered I had pulled Windows Media Player, Media Center and IE9 out before stepping away from it the last time I was here a few weeks ago. I use Firefox and GOM player anyway, so having those removed didn't make much difference. I didn't even realize they were gone at first until I saw my IE9 desktop shortcut was showing a 'broken' icon. I went into 'Windows Features On/Off' in the Control Panel and rechecked Media Center, Media Player and IE9 and reboot...

Upon getting to my desktop again, my IE9 icon was back to normal and functional. WMP 12 was in and running fine, as was Media Center. I crossed my fingers and began reinstalling DW, letting it install dotNet 3.5 on it's own even though I have 4.0 installed already. I figured it wouldn't hurt. I knew DX9 was up-to-date, so I left that one alone. My vid drivers were brand new, Catalyst 12.7 betas. I installed RotS next and without updating it, went right into Legends after. Once Legends was in, I patched it to 1.7.0.6 (since that was the latest publicly released patch). After everything was done, I sat there and took a deep breath. The voice in the back of my head was say it wasn't going to work and I was just asking for a slap in the face, but I ran it anyway, and this is what I got...



It didn't appear right away and I was getting ready for that error to pop up and start screaming bloody murder, but the splash screen popped up instead and I truly had my stomach in my throat for a second, I just couldn't believe what I was seeing! I mean, could it be?! That's ALL it took to get running again?! After everything I had tried and failed and it was just like that?! I was considering screaming bloody murder anyway after realizing all of this but then I was just overjoyed to finally be able to play my beloved game once again!

So, to conclude my story (and hopefully the whole ordeal), the thing that I believe fixed the dreaded 'CLR20r3' error was to completely wipe the registry of all traces of DW and Legends, if they were there, and then pull out WMP12, WMC, and IE9 via 'Programs and Features' in the Control Panel, under Windows Features On/Off on the left panel. Uncheck them, reboot after it's finished, recheck them all and reboot again, thus re-installing the originals. Make sure your dotNET is updated (also have DW install dotNET3.5 at the end of it's setup even if you have 4.0 already. It doesn't seem to interfere at all, much like the vcredistx86/x64 C runtime's don't conflict with each other (indeed, I must have at least 6 in my system, all different versions - 2005, 2008, and 2010) and DirectX9. Don't forget your video card drivers either!

Thank you, to everyone that pitched in and tried to help. Hopefully anyone else coming in with the same problem will see this post, along with the others and work out a way to fix their particular error without losing their minds in the process! Now, if you'll excuse me, I have a few months worth of turns to catch up on...

-Lumarra

< Message edited by Lumarra -- 8/3/2012 1:48:14 PM >

(in reply to davelogan69)
Post #: 14
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> NEVERENDING Crash at startup Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.084