Matrix Games Forums

Happy Easter!Battle Academy is now available on SteamPlayers compare Ageods Civil War to Civil War IIDeal of the week - An updated War in the East goes half Price!Sign up for the Qvadriga beta for iPad and Android!Come and say hi at Pax and SaluteLegends of War goes on sale!Piercing Fortress Europa Gets UpdatedBattle Academy Mega Pack is now availableClose Combat: Gateway to Caen Teaser Trailer
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Help with beta patches

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Help with beta patches Page: [1]
Login
Message << Older Topic   Newer Topic >>
Help with beta patches - 6/13/2012 12:09:26 AM   
Warspite3

 

Posts: 209
Joined: 3/31/2005
Status: offline
I have DW and both expansions installed. I am wanting to try out those latest beta patches. My question is do I need to install Shakturi beta first and then install Legends beta or can I just install Legends beta alone?

_____________________________

-Warspite3-
Post #: 1
RE: Help with beta patches - 6/13/2012 1:31:26 AM   
ehsumrell1


Posts: 1804
Joined: 8/17/2010
From: The Briar Patch Nebula
Status: offline
Hello Warspite3;

If you want to play the Legends version, install the latest Legends beta patch
which currently is version 1.7.0.15.

_____________________________

Shields are useless in "The Briar Patch"...

(in reply to Warspite3)
Post #: 2
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Help with beta patches Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.109