Matrix Games Forums

War in the West Manual previewThe fight for Armageddon begins! The Matrix Holiday sales are starting today! Warhammer - Weapons of WarFlashpoint Campaigns: Red Storm gets huge update and a Steam release!Battle Academy 2 opens up a new front!Flashpoint Campaigns Featured on weekly Streaming SessionFrontline: The Longest Day - New Screenshots!Deal of the Week: Hannibal Rome and CarthageFlashpoint Campaigns: Red Storm gets Players Edition!
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Is there any way I can fix this?

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Is there any way I can fix this? Page: [1]
Login
Message << Older Topic   Newer Topic >>
Is there any way I can fix this? - 2/25/2012 8:11:00 PM   
witp1951


Posts: 118
Joined: 12/2/2009
From: Tennessee
Status: offline
A fragment of the 144th IJA RGMT did not recombine after units assembled when transports were attacked and some lost. Now its recognized as a Brit. PBEM Scenario 1. The troops are uneasy following Major Hicks. And there is the language barrier.






Attachment (1)

< Message edited by witp1951 -- 2/25/2012 8:12:09 PM >


_____________________________

Baka wa shinanakya naoranai

Dog
Post #: 1
RE: Is there any way I can fix this? - 2/25/2012 8:48:43 PM   
Crackaces


Posts: 2625
Joined: 7/9/2011
Status: offline
You are assuming that Maj Hicks might not have graduated with a degree in Japaneese

Wow .. what a corrupton of reality ...

(in reply to witp1951)
Post #: 2
RE: Is there any way I can fix this? - 2/25/2012 10:27:50 PM   
Capt Cliff


Posts: 1668
Joined: 5/22/2002
From: Northwest, USA
Status: offline
Wow!! That is nuts!! What you need is a saved file editor.

_____________________________

Capt. Cliff

(in reply to Crackaces)
Post #: 3
RE: Is there any way I can fix this? - 2/25/2012 11:27:03 PM   
michaelm


Posts: 9386
Joined: 5/5/2001
From: Sydney, Australia
Status: online
quote:

ORIGINAL: witp1951

A fragment of the 144th IJA RGMT did not recombine after units assembled when transports were attacked and some lost. Now its recognized as a Brit. PBEM Scenario 1. The troops are uneasy following Major Hicks. And there is the language barrier.






What game version are you playing?
If current patch, do you have a save of the turn when this happened so I can replay it?

_____________________________

Michael

(in reply to witp1951)
Post #: 4
RE: Is there any way I can fix this? - 2/25/2012 11:45:04 PM   
witp1951


Posts: 118
Joined: 12/2/2009
From: Tennessee
Status: offline
Saved game prior to Rabaul invasion attached with file extension changed to zip. We were using r6 at the time fragments were unloaded in two different locations. We changed to r9 when patch 6 was final. Transports from two locations with 144th were combined and invaded Rabaul and the fragment originally located elsewhere went over to the enemy.

Attachment (1)

_____________________________

Baka wa shinanakya naoranai

Dog

(in reply to michaelm)
Post #: 5
RE: Is there any way I can fix this? - 2/26/2012 12:22:27 AM   
witp1951


Posts: 118
Joined: 12/2/2009
From: Tennessee
Status: offline
Here is the following game turn with the fragment identified as a Brit.

Attachment (1)

_____________________________

Baka wa shinanakya naoranai

Dog

(in reply to witp1951)
Post #: 6
RE: Is there any way I can fix this? - 2/26/2012 12:50:49 AM   
michaelm


Posts: 9386
Joined: 5/5/2001
From: Sydney, Australia
Status: online
Bad fragment still shows if run turn on latest build.
Will investigate where this happens.


_____________________________

Michael

(in reply to witp1951)
Post #: 7
RE: Is there any way I can fix this? - 2/26/2012 1:34:35 AM   
michaelm


Posts: 9386
Joined: 5/5/2001
From: Sydney, Australia
Status: online
The problem seems to that one of 144th fragments is pointing to another fragment as its parent. Something that shouldn't happen. This fragment is the 224 RAF unit. Can see this if you look in TF 93. There are 3 fragments to 144th, but only 2 actually show up if the click on the Unit Org for 144th.
This data mishandling occurred presumably during the TF 93 load process. Do suppose you have that save?


_____________________________

Michael

(in reply to michaelm)
Post #: 8
RE: Is there any way I can fix this? - 2/26/2012 1:50:43 AM   
witp1951


Posts: 118
Joined: 12/2/2009
From: Tennessee
Status: offline
OK. Here is turn with 144th on its way to Truk

Attachment (1)

_____________________________

Baka wa shinanakya naoranai

Dog

(in reply to michaelm)
Post #: 9
RE: Is there any way I can fix this? - 2/26/2012 1:53:23 AM   
witp1951


Posts: 118
Joined: 12/2/2009
From: Tennessee
Status: offline
Here is next turn after Allied carriers had their way with the transports. 144th split into different escort TF. I think the fragment in question is in TF109

Attachment (1)

_____________________________

Baka wa shinanakya naoranai

Dog

(in reply to witp1951)
Post #: 10
RE: Is there any way I can fix this? - 2/26/2012 1:55:54 AM   
witp1951


Posts: 118
Joined: 12/2/2009
From: Tennessee
Status: offline
Here is the following turn after TF109 transport sinks and troops rescued by PB. No wonder they changed sides!

I have more turns if needed.

Attachment (1)

_____________________________

Baka wa shinanakya naoranai

Dog

(in reply to witp1951)
Post #: 11
RE: Is there any way I can fix this? - 2/26/2012 2:18:08 AM   
witp1951


Posts: 118
Joined: 12/2/2009
From: Tennessee
Status: offline
Here is the turn where TF93 loads for Rabaul.

Attachment (1)

_____________________________

Baka wa shinanakya naoranai

Dog

(in reply to witp1951)
Post #: 12
RE: Is there any way I can fix this? - 2/26/2012 2:26:18 AM   
michaelm


Posts: 9386
Joined: 5/5/2001
From: Sydney, Australia
Status: online
There is a big gap between the latest saves (early Dec 41 - turn 10) and the ones with the problem (late Jan 42 - turn 52)
The fragments are fine in the last saves.
Any chance for the saves from turn say turn 48 to turn 51 - use my email (michaelm75 @ hotmail.com) to save time.

I'll backtrack till the fragment comes good and then see why it goes bad.


_____________________________

Michael

(in reply to witp1951)
Post #: 13
RE: Is there any way I can fix this? - 2/26/2012 2:43:03 AM   
witp1951


Posts: 118
Joined: 12/2/2009
From: Tennessee
Status: offline
Backtracking through the saves here are the turns where the 144th fails to combine at Truk. In this turn a fragment is at Truk and the rest of the Rgmt about to dock.

Attachment (1)

_____________________________

Baka wa shinanakya naoranai

Dog

(in reply to michaelm)
Post #: 14
RE: Is there any way I can fix this? - 2/26/2012 2:44:09 AM   
witp1951


Posts: 118
Joined: 12/2/2009
From: Tennessee
Status: offline
Now we have two separate fragments at Truk.

Attachment (1)

_____________________________

Baka wa shinanakya naoranai

Dog

(in reply to witp1951)
Post #: 15
RE: Is there any way I can fix this? - 2/26/2012 2:53:38 AM   
michaelm


Posts: 9386
Joined: 5/5/2001
From: Sydney, Australia
Status: online

quote:

ORIGINAL: witp1951

Backtracking through the saves here are the turns where the 144th fails to combine at Truk. In this turn a fragment is at Truk and the rest of the Rgmt about to dock.

Can I have the one before this. The rest of 144 has already unloaded. And no TF seems to be there.

_____________________________

Michael

(in reply to witp1951)
Post #: 16
RE: Is there any way I can fix this? - 2/26/2012 3:00:24 AM   
witp1951


Posts: 118
Joined: 12/2/2009
From: Tennessee
Status: offline

quote:

ORIGINAL: michaelm


quote:

ORIGINAL: witp1951

Backtracking through the saves here are the turns where the 144th fails to combine at Truk. In this turn a fragment is at Truk and the rest of the Rgmt about to dock.

Can I have the one before this. The rest of 144 has already unloaded. And no TF seems to be there.


I think this is the one you've requested.



Attachment (1)

_____________________________

Baka wa shinanakya naoranai

Dog

(in reply to michaelm)
Post #: 17
RE: Is there any way I can fix this? - 2/26/2012 3:07:00 AM   
michaelm


Posts: 9386
Joined: 5/5/2001
From: Sydney, Australia
Status: online
I tried loading the 2 parts of  the 144th at Truk with the other save, and I can see that when the orphaned fragment loads on ship is treats the old fragment as its parent. But then that fragment goes away and is used by something else (in your game the 224 RAF). Thus the chain back is ending at the wrong unit.
I have added logic to cause a fragment to drop its parent if it is another fragment. This would fix problems where this has already happened and allow the fragment to be disbanded (add devices back to pool).
In the meantime, I'll look at the saves to see WHY this happens in the first place.


_____________________________

Michael

(in reply to witp1951)
Post #: 18
RE: Is there any way I can fix this? - 2/26/2012 3:09:25 AM   
michaelm


Posts: 9386
Joined: 5/5/2001
From: Sydney, Australia
Status: online
Sorry, could I have one before. Looks like the bad fragment is the one already unloaded.

_____________________________

Michael

(in reply to michaelm)
Post #: 19
RE: Is there any way I can fix this? - 2/26/2012 3:23:14 AM   
witp1951


Posts: 118
Joined: 12/2/2009
From: Tennessee
Status: offline

quote:

ORIGINAL: michaelm

Sorry, could I have one before. Looks like the bad fragment is the one already unloaded.



Is this the turn you need?

Attachment (1)

_____________________________

Baka wa shinanakya naoranai

Dog

(in reply to michaelm)
Post #: 20
RE: Is there any way I can fix this? - 2/26/2012 3:34:27 AM   
michaelm


Posts: 9386
Joined: 5/5/2001
From: Sydney, Australia
Status: online
That fragment is already is in Truk before TF arrives.
Don't bother trying to look at every save.

I'll see if there is anyway that the code could use the wrong id.

Actually your save from turn 10 has a couple of fragments going to Truk from damaged ships. These might be the guys. I'll play a few turns till they land.

Yep. That became the orphaned fragment. I'll look back thru those saves, but it might be as you said when the fragment was picked up. Funny thing is that the parent was in the TF when it landed but not there no -- so could be another instance of parent-fragment swapping that misses an attribute/element.

It is trying to swap the frag/parent as part of the unloading sequence. This seems to be causing confusion somehow and the original unloading fragment loses it's parent connection. Removing the swap at this time seems to correct the problem and the parent (which was on the TF) is swapped at the end of the turn as expected.

< Message edited by michaelm -- 2/26/2012 4:22:58 AM >


_____________________________

Michael

(in reply to witp1951)
Post #: 21
RE: Is there any way I can fix this? - 2/26/2012 3:54:12 AM   
witp1951


Posts: 118
Joined: 12/2/2009
From: Tennessee
Status: offline
Thanks, Michael.

I'll disband the fragment. (After I use it to help take Rabaul of course.)

_____________________________

Baka wa shinanakya naoranai

Dog

(in reply to michaelm)
Post #: 22
RE: Is there any way I can fix this? - 2/26/2012 7:09:59 AM   
Barb


Posts: 1632
Joined: 2/27/2007
From: Slovakia
Status: offline
Trying to copy 100th(Purple Hearth) Infantry battalion for service in the Pacific?

_____________________________


"Hello IT. Have you tried turning it off and on again?"

(in reply to witp1951)
Post #: 23
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Is there any way I can fix this? Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

1.172