Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Modding Assistance - Problem Fixed

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> Modding Assistance - Problem Fixed Page: [1]
Login
Message << Older Topic   Newer Topic >>
Modding Assistance - Problem Fixed - 2/1/2012 10:43:55 PM   
TomFrame

 

Posts: 34
Joined: 1/30/2012
Status: offline
This problem is now fixed - a summary of what problems occured and how to fix is at bottomn

Introduction
Intro is here, skip below for problem

Hi there guys, thanks for making such a sweet game - i really enjoy it. Anyways since i enjoy this game so much I have decided to make my own modification using sounds, pictures and data from a game called: Master of Orion 2.

Having already extracted the race pictures from my Moo2 root folder and edited them in photoshop I've made some reasonable pictures




Also having replaced sounds like music, alarms, torpedoes, lasers and events it makes the game very different. This all works great as planned as I am only replacing!

The problem however comes when I attempt to add a new race to the game:

The actual problem!
The problem is when I attempt to add these races. Whatever I do, no matter how many times I recheck the text files, the forums and the folders I still get the "more bias values than races at line 12" or something similar. That is it, no more nothing less.

EDIT: Right now I cant even enter the game (DW stopped working), probably because it exited with the theme on since I pressed continue, but this means I can test the game faster!

Here is what I can setup, In reality I only have Bias file, races folder with a text file named alkari, a Policy folder with a text file named Alkari and a raceImage in Theme\raceImages that is named Race_22 and Race_22a. All the text files are originally copy-pasted from core game root and only edited in what you see in these Images. The music folder is also there, but does not affect anything that includes mentioned problems.



(I renamed race to races - no effect)

As far as I understand I only need to get the Policy, Bias and Race file of the race I'm adding correct. All else is loaded as default if missing - is this correct? If not I still need to get past the Bias at line 12 message...

Basically I am gonna upload stuff of Bias and race file - I will not upload images of policy.

BIAS


RACE TEXT FILE


I have altered two things in this race file (copied from Ackdarian): Home System Name (Altair) and troop name (Alkari Infantry)(100strength).

Would someone be so kind to explain how I would approach and deal with the problem?

I have some questions that may be important:

1. Do I need only race, bias, policy (+raceimage if specified)?
2. How does the game know in the bias that I have added a race? Is there an index value I forgot to enter somewhere?
3. Am I missing a file(Policy folder, races folder, raceImages folder, biases.txt, alkari.txt, Alkari.txt (Policy), Race_22.png, Race_22a.png)
4. When the race.txt states that it should load shipImages from either core\sImages or theme\sImages, does it really mean

-if you are reading this race.txt file in the core game folders, you need ships in core\sImages.
-if you are reading this race.txt file in the theme game folders, you need to get the core\sImages into the theme\sImages!

< Message edited by TomFrame -- 2/2/2012 10:20:27 PM >
Post #: 1
RE: Modding Assistance - 2/2/2012 6:00:11 AM   
dastuma

 

Posts: 9
Joined: 1/30/2012
Status: offline

quote:

ORIGINAL: TomFrame

As far as I understand I only need to get the Policy, Bias and Race file of the race I'm adding correct. All else is loaded as default if missing - is this correct? If not I still need to get past the Bias at line 12 message...



You need to have all the races you want to use in your race folder inside your theme. Looking at your bias.txt that means you need 23 race-files. That will also solve the line 12 message, which basically means, that you don't have enough races in your theme.

(in reply to TomFrame)
Post #: 2
RE: Modding Assistance - 2/2/2012 8:23:19 AM   
TomFrame

 

Posts: 34
Joined: 1/30/2012
Status: offline
Thank you!
Does this mean I need all the corresponding Policy and Picture files IN the theme?

Tested it, got an error saying could not read bias value 24 at line 12 in bias - assuming there are too many race txt files.
Which is weird... I have 23 elements in the race folder (all races) and 0-22 bias values - why is it asking for a 24th value?




< Message edited by TomFrame -- 2/2/2012 10:39:35 AM >

(in reply to dastuma)
Post #: 3
RE: Modding Assistance - 2/2/2012 1:43:39 PM   
Theluin


Posts: 188
Joined: 5/13/2011
From: Europe, Terra
Status: offline
I don't think it's connected to your current problem, but from what the other modders here said you also have to add the character files for the races to your theme, and create a new one for the new race. (Idk if it can be empty but all the vanilla character files have 1 character in them)

Oh and I have an idea. Did you format the bias file in any way (like adding more tabs or spaces)? I did that once to make it more readable and it also resulted in errors.

(in reply to TomFrame)
Post #: 4
RE: Modding Assistance - 2/2/2012 9:38:44 PM   
TomFrame

 

Posts: 34
Joined: 1/30/2012
Status: offline
Hmm, I shall test this further by recreating the bias file (copy pasting again) and copy pasting the character stuff.

Thank you for the time taken to help me - I will upload the files for everyone once they're done!

(in reply to Theluin)
Post #: 5
RE: Modding Assistance - 2/2/2012 10:07:46 PM   
TomFrame

 

Posts: 34
Joined: 1/30/2012
Status: offline
If you notice the bias file up, you can see that i have added a "," behind every value, linking to an upcoming race that does not exist!

(in reply to TomFrame)
Post #: 6
RE: Modding Assistance - 2/2/2012 10:19:41 PM   
TomFrame

 

Posts: 34
Joined: 1/30/2012
Status: offline
PROBLEM FIXED - ALL IS WELL THAAAAAAANK YOU SOOO MUCH ^^ HAPPYYYYYYYYYYYYY

(in reply to TomFrame)
Post #: 7
RE: Modding Assistance - 2/2/2012 10:28:14 PM   
TomFrame

 

Posts: 34
Joined: 1/30/2012
Status: offline
The first problem I had was:

More bias values than races at line 12 (this means that the game can't find enough races)
The actual problem was caused by me only having the ADDED race in the races folder.
Fixing the problem was easy - copy&paste all the original races to the races folder then it is fixed.

The second problem:

Could not read bias value 24 at line 12 in bias(caused the game to look for a 24th race)
This was caused by me putting a "," behind each number (THE FINAL RACE SHOULD NOT HAVE A ",")
Fixing it was a mere deletion of those symbols.

So- hope me finding out the problem with some help will help others even faster.

(in reply to TomFrame)
Post #: 8
RE: Modding Assistance - 4/24/2012 4:55:39 PM   
telriche

 

Posts: 3
Joined: 4/24/2012
Status: offline
I'm having a different problem with my bias file. When loading any theme except default, I get an error at line 33. It does not expand upon what the error is.

(in reply to TomFrame)
Post #: 9
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> Modding Assistance - Problem Fixed Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.102