Matrix Games Forums

To End All Wars: Video, AAR and Interview!Ageod's To End All Wars: Video, AAR and Interview!To End All Wars: Artillery Battle Academy 2: Eastern Front - End of Early Access Space Program Manager unveils its multiplayer modes Another update for Commander: The Great War!Distant Worlds: Universe gets a new updateDeal of the Week: Eagle Day to Bombing the Reich Advanced Tactics Gold is coming to SteamMatrix Games now speaks German!
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

1.7.0.13 - explorer behaviour

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> 1.7.0.13 - explorer behaviour Page: [1]
Login
Message << Older Topic   Newer Topic >>
1.7.0.13 - explorer behaviour - 1/22/2012 2:02:05 AM   
Kayoz


Posts: 1394
Joined: 12/20/2010
From: Timbuktu
Status: offline
This is an old bug which has never been addressed -

Explorers will sometimes fail to explore ruins when exploring a planet, despite it being an automated task (eg: explore all, report all).

Aside from the obvious fix of the explorer not leaving the planet till any present ruins are explored - it shouldn't be too hard to kludge in behaviour to have explorers, when having finished their tasks, seek out the nearest unexplored world (ie: unknown resources) OR the nearest unexplored ruins.

As it stands, you have to manually target ruins which have been missed by explorers, or those revealed by map trades/theft. That's a silly amount of micromanagement.

< Message edited by Kayoz -- 4/12/2012 6:34:22 AM >
Post #: 1
RE: explorer behaviour - 1/22/2012 11:13:39 PM   
elliotg


Posts: 3182
Joined: 9/10/2007
Status: offline
Hi Kayoz

Do you have a savegame showing this problem? This issue was specifically addressed in an earlier Legends patch, so this was fixed as far as I knew.

Thanks
Elliot

(in reply to Kayoz)
Post #: 2
RE: explorer behaviour - 4/8/2012 10:33:28 AM   
Kayoz


Posts: 1394
Joined: 12/20/2010
From: Timbuktu
Status: offline

quote:

ORIGINAL: elliotg

Hi Kayoz

Do you have a savegame showing this problem? This issue was specifically addressed in an earlier Legends patch, so this was fixed as far as I knew.

Thanks
Elliot



Issue still occurring in 1.7.0.13 -

Savegame file: RuinsUnexplored-20120407.dwg

Example:
Sector: J1
System: Tynna Minor
Planet: Plozeysi

Explanation:
Explorers on auto seem to have passed over this area. Planet resources were identified, but ruin not explored.
I did not get any system maps or such from pirates or AI empires.

Related issue:
Purchasing/stealing system maps does not expose the ruin characteristics. For example, if the ruins have been explored already by an empire that the maps were traded for - shouldn't the ruins be exposed? If not, then shouldn't explorers target the now known ruins for exploration? Explorers in this (purchase/steal) case (from what I have seen, not demonstrated in this file) ignore those systems.

(in reply to elliotg)
Post #: 3
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> 1.7.0.13 - explorer behaviour Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.070