Matrix Games Forums

Space Program Manager Launch Contest Announced!Battle Academy 2 is out now on iPad!A closer look at rockets in Space Program ManagerDeal of the Week - Pride of NationsA new update for Piercing Fortress EuropaNew screenshots for War in the West!Pike & Shot is now available!Server Maintenance Battle Academy 2 gets updated!Deal of the Week: Advanced Tactics Gold
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Problem with Multiplayer

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command Ops Series >> Tech Support >> Problem with Multiplayer Page: [1]
Login
Message << Older Topic   Newer Topic >>
Problem with Multiplayer - 1/1/2012 8:46:12 PM   
dougb

 

Posts: 140
Joined: 4/5/2009
Status: offline
Hi,

We were having an online game so that we could post an aar with some screenshots (well, mainly for the fun of it really!) We had a problem restarting from a saved game.

Miquel and I were trying to play a multiplayer game over the internet and were having a great time but then had to save the game. A few hours later when we tried to load we were unable to get the begin game button to come up (it remained blank). This was despite the fact that I had emailed Miquel the file and he had no problem connecting onto me as the host (I had not been able to connect to him as the host).

Playing Battle of the Roadblocks (save file attached).
connecting via hamachi version 1.3.0.0
we were using skype during our live session
my pc has windows 7 32 bit, Miquel's win 7 64 bit




Attachment (1)
Post #: 1
RE: Problem with Multiplayer - 1/1/2012 9:06:00 PM   
Bletchley_Geek


Posts: 3065
Joined: 11/26/2009
From: Living in the fair city of Melbourne, Australia
Status: offline
Miquel = Bletchley_Geek :)

(in reply to dougb)
Post #: 2
RE: Problem with Multiplayer - 6/21/2012 3:04:35 AM   
Arjuna


Posts: 17790
Joined: 3/31/2003
From: Canberra, Australia
Status: offline
Doug,

Thanks for drawing this to my attention on war-historical NG. It had slipped through the net I'm afraid. I just tried to run this saved game between my dev machine and laptop. First attempt failed. I tracked down the cause of this to a lock that wasn't being turned off if you cancelled out of the Game Setup dialog. The lock prevents another game from being loaded if you are already in the process of loading or have one loaded. I have ensured now that it unlocks when you Cancel the dialog either as host or client.

I then tried again and could not get it to run with my Dev machine as the host but could get it to run with the laptop as the host. The reason is that the laptop as the client supposedly could not find the scenario or was reporting the wrong scenario ID for some reason. Trouble is I don't have the dev environment installed on my laptop to step through what is happening.

Can you please confirm for me if Miquel ( ie Bletchley_Geek ) was the host when you guys originally played. I'm trying to work out if there is anything going on between who is the host and who saves the game.

I don't have each of your passwords to actually play the game but I'm pretty positive that I can get it to run if I did have them. However, the issue really is why it works one way between the machines but not the other. Networking is not really my forte. I will need to wait for Paul to get back from Europe and ask him to investigate further.

< Message edited by Arjuna -- 6/21/2012 3:12:18 AM >


_____________________________

Dave "Arjuna" O'Connor
www.panthergames.com

(in reply to Bletchley_Geek)
Post #: 3
RE: Problem with Multiplayer - 6/21/2012 5:55:25 AM   
Bletchley_Geek


Posts: 3065
Joined: 11/26/2009
From: Living in the fair city of Melbourne, Australia
Status: offline
Hi,

it's been months since this but I think I recall that Doug was the host. Regarding the password, I'll be PM'ing to you Dave.

OOT: If somebody was wondering what had happened to me, I'm glad to announce you guys I already got my PhD (I defended the Thesis back in May) and now I've just landed in that fair land that people in the WitP forums know by the acronym "OZ" (could somebody care to explain to me the reasons for Australia becoming OZ?).

(in reply to Arjuna)
Post #: 4
RE: Problem with Multiplayer - 6/21/2012 7:06:59 AM   
BofH


Posts: 57
Joined: 2/12/2009
From: Australia
Status: offline

Congratulations on your Post Hole Digger, Miquel!

Regarding OZ, it's merely that OZ is the first syllable of the country if you pronounce it the way many here do
( OZ - TRAY - YA )

Hope you have a great time here, cheers

(in reply to Bletchley_Geek)
Post #: 5
RE: Problem with Multiplayer - 6/21/2012 12:06:10 PM   
Bletchley_Geek


Posts: 3065
Joined: 11/26/2009
From: Living in the fair city of Melbourne, Australia
Status: offline
quote:

ORIGINAL: BofH
Congratulations on your Post Hole Digger, Miquel!


Yeah, the glint of gold ore just caught my eye, mate :)

quote:

ORIGINAL: BofH
Regarding OZ, it's merely that OZ is the first syllable of the country if you pronounce it the way many here do
( OZ - TRAY - YA )


Hahaha. Got it. I thought it was some sort of WW2 code only grognards used to refer to this - as far as I can gather - beautiful country.

quote:

ORIGINAL: BofH
Hope you have a great time here, cheers


Thank you. Today the weather was terrible in Melbourne, but you're not supposed to be living on the streets either :)

(in reply to BofH)
Post #: 6
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command Ops Series >> Tech Support >> Problem with Multiplayer Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.066