Matrix Games Forums

Command gets huge update!Order of Battle: Pacific Featured on Weekly Streaming SessionA new fight for Battle Academy!Buzz Aldrin's Space Program Manager is out for Mac!The definitive wargame of the Western Front is out now! War in the West gets teaser trailer and Twitch Stream!New Preview AAR for War in the West!War in the West Manual previewThe fight for Armageddon begins! The Matrix Holiday sales are starting today!
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Loading resources at limited resources port

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Loading resources at limited resources port Page: [1]
Login
Message << Older Topic   Newer Topic >>
Loading resources at limited resources port - 12/29/2011 2:09:59 AM   
Disco Duck

 

Posts: 314
Joined: 11/16/2004
From: San Antonio
Status: offline
This concerns a "trick" that I have used on previous betas but doesn't work now.

I would create a CS cargo convoy, say at Christmas Island, and set it to load resources and return with supplies. The computer used to realize there were no resources to load and send it on it's way to say Los Angeles to pickup supplies.

This made it very easy to use the "show task forces based here" button on the port screen to keep track of my supply convoys for individual bases. I could easily tell how many supplies were heading to Christmas Island and how many empty ships were headed to the West coast to pickup supplies. It also massively cut down the number of ships on the west coast and hence on the resulting confusion as to which base was being supplied by what base.

It would also work with Tankers loading non-existent oil and returning with fuel.

Now if I try to use this trick the ships just stay at the port trying to load non-existent resources or oil.

Is it possible to have the computer again realize that there is nothing or little to load and go on its merry way? Or is it possible to have an option to load nothing on the outgoing leg but supplies or fuel on the return trip?
Post #: 1
RE: Loading resources at limited resources port - 12/29/2011 8:31:31 AM   
michaelm


Posts: 9464
Joined: 5/5/2001
From: Sydney, Australia
Status: offline
I have done anything to 'break' your trick as far as I know.
If you can post a save where this will happen, and tell me which beta it worked and which one it doesn't, I can see what has changed.

I did a quick test on the current beta and the CS TF waited in port for day not loading anything, and then returned to the other port.



< Message edited by michaelm -- 12/29/2011 10:57:32 AM >


_____________________________

Michael

(in reply to Disco Duck)
Post #: 2
RE: Loading resources at limited resources port - 12/30/2011 4:58:05 PM   
Disco Duck

 

Posts: 314
Joined: 11/16/2004
From: San Antonio
Status: offline
Michael,
Doing a little testing between versions it seems it works in the newest version just not all of the time. It also seems to require a base force to be present. Please see the task force at San Clemente island on the save. In this save there are also two task forces that aren't working right. I will post screen shots of the issues.

Attachment (1)

(in reply to michaelm)
Post #: 3
RE: Loading resources at limited resources port - 12/30/2011 5:06:57 PM   
Disco Duck

 

Posts: 314
Joined: 11/16/2004
From: San Antonio
Status: offline
Here is a screen shot of a task force moving from Perth to Cape town. It has changed back to human control but the loading options have remained the same.






I tried to upload a screen shot of TF 62 just east of Brisbane. For some reason my computer hangs while trying to upload.
Anyway TF 62 appears to be going to a waypoint and then returning to Sydney rather than going to San Diego.

I apologize that my save is a little convoluted. As I was trying to document issues I kept coming up with other Scenarios to try.

Thanks


Attachment (1)

< Message edited by Disco Duck -- 12/30/2011 8:26:06 PM >

(in reply to michaelm)
Post #: 4
RE: Loading resources at limited resources port - 12/30/2011 9:45:22 PM   
michaelm


Posts: 9464
Joined: 5/5/2001
From: Sydney, Australia
Status: offline
There seems to two things that were bug fixes that have indirectly caused this.
When a CS does not load something, then it seems to be confused as to what it should load.

In the case of the San Clemente TF, it actually was moving between San Clemente and LA, but not transporting anything! It made the trip there and back in one turn.

Have fixed it so that a CS TF will always be treated as if it contains cargo for un/load purposes.


_____________________________

Michael

(in reply to Disco Duck)
Post #: 5
RE: Loading resources at limited resources port - 12/30/2011 9:47:41 PM   
michaelm


Posts: 9464
Joined: 5/5/2001
From: Sydney, Australia
Status: offline
quote:

I tried to upload a screen shot of TF 62 just east of Brisbane. For some reason my computer hangs while trying to upload.
Anyway TF 62 appears to be going to a waypoint and then returning to Sydney rather than going to San Diego.


This has already been fixed in new build as the CS with way-points got confused as to if it was out-bound or in-bound to its home port.


_____________________________

Michael

(in reply to michaelm)
Post #: 6
RE: Loading resources at limited resources port - 12/30/2011 11:33:50 PM   
Disco Duck

 

Posts: 314
Joined: 11/16/2004
From: San Antonio
Status: offline

quote:

ORIGINAL: michaelm

There seems to two things that were bug fixes that have indirectly caused this.
When a CS does not load something, then it seems to be confused as to what it should load.

In the case of the San Clemente TF, it actually was moving between San Clemente and LA, but not transporting anything! It made the trip there and back in one turn.

Have fixed it so that a CS TF will always be treated as if it contains cargo for un/load purposes.


That is funny about the San Clemente Task force I missed that.
Thanks

(in reply to michaelm)
Post #: 7
RE: Loading resources at limited resources port - 12/31/2011 9:43:03 AM   
michaelm


Posts: 9464
Joined: 5/5/2001
From: Sydney, Australia
Status: offline

quote:

ORIGINAL: Disco Duck


quote:

ORIGINAL: michaelm

There seems to two things that were bug fixes that have indirectly caused this.
When a CS does not load something, then it seems to be confused as to what it should load.

In the case of the San Clemente TF, it actually was moving between San Clemente and LA, but not transporting anything! It made the trip there and back in one turn.

Have fixed it so that a CS TF will always be treated as if it contains cargo for un/load purposes.


That is funny about the San Clemente Task force I missed that.
Thanks

Took me half an hour of checking why it wasn't moving, but I realized that it WAS!

_____________________________

Michael

(in reply to Disco Duck)
Post #: 8
RE: Loading resources at limited resources port - 12/31/2011 1:55:19 PM   
PaxMondo


Posts: 5925
Joined: 6/6/2008
Status: offline
Thanks for the great support Michael!!!



_____________________________

Pax

(in reply to michaelm)
Post #: 9
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Loading resources at limited resources port Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.076