Matrix Games Forums

Warhammer - Weapons of WarFlashpoint Campaigns: Red Storm gets huge update and a Steam release!Battle Academy 2 opens up a new front!Flashpoint Campaigns Featured on weekly Streaming SessionFrontline: The Longest Day - New Screenshots!Deal of the Week: Hannibal Rome and CarthageFlashpoint Campaigns: Red Storm gets Players Edition!To End All Wars gets its first major patch! Hell is now available!War in the West Wacht am Rhein AAR
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Special Component Hassle

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> Special Component Hassle Page: [1]
Login
Message << Older Topic   Newer Topic >>
Special Component Hassle - 12/13/2011 5:03:14 PM   
InaB77


Posts: 25
Joined: 12/5/2011
Status: offline
Hi there,

as the curious person i am i dove into Modding and created myself some SuperQuameno's ;)

I ran across the following problem: Tried to add the Megatron Shields the Zenox's have as a starting Tech to my race by modifying this:

'Special Component: 0=None, 1=Death Ray, 2=Devastator Pulse, 3=Super Laser, 4=StarBurner, 5=TurboThruster, 6=Swift Vector, 7=Megatron, 8=NovaCore, 9=VelocityDrive, 10=ShadowGhost ECM, 11=Shaktur FireStorm, 12=High Density Fuel Cell, 13=S2F7 RepairBot, 14=PulseWave Cannon, 15=Raptor Targetting System
SpecialComponent		;7
But for some reason i cant seem to get this to work. Does anybody know whats wrong there ?

Regards,
Ina

_____________________________

Fenster fährt mich Nüsse
Post #: 1
RE: Special Component Hassle - 12/13/2011 5:07:17 PM   
Theluin


Posts: 186
Joined: 5/13/2011
From: Europe, Terra
Status: offline
The 7 needs to be before the semi-colon

(in reply to InaB77)
Post #: 2
RE: Special Component Hassle - 12/13/2011 5:28:59 PM   
InaB77


Posts: 25
Joined: 12/5/2011
Status: offline
I disagree, in the races\zenox.txt file it looks exactly like posted above. All the values seem to be after the colons.

_____________________________

Fenster fährt mich Nüsse

(in reply to Theluin)
Post #: 3
RE: Special Component Hassle - 12/13/2011 6:23:33 PM   
Theluin


Posts: 186
Joined: 5/13/2011
From: Europe, Terra
Status: offline
Oh sorry my bad. I don't know why it doesn't work for you then. I compared the race file fragment you posted to the race file of the zenox with winmerge and it's exactly the same. Perhaps you pressed tab or enter right before or right after and that's why the game can't read it.

(in reply to InaB77)
Post #: 4
RE: Special Component Hassle - 12/13/2011 6:51:20 PM   
InaB77


Posts: 25
Joined: 12/5/2011
Status: offline
Just made verified, everything looks correct but still doesnt seem to work. Also i just found another quirk:

'Special Government: 0=None, 1=Technocracy, 2=HiveMind, 3=MercantileGuild, 4=UtopianParadise, 5=Way of the Ancients, 6=Way of Darkness, 7=Corporate Nationalism
SpecialGovernment		;5

'Preferred Starting Government: 0=No preference, 1=Technocracy, 2=HiveMind, 3=MercantileGuild, 4=UtopianParadise, 5=Way of the Ancients, 6=Way of Darkness, 7=Despotism, 8=Feudalism, 9=Monarchy, 10=Republic, 11=Democracy, 12=Military Dictatorship, 13=Corporate Nationalism
PreferredStartingGovernment		;5
... giving the SuperFrogs the WotA from the start doesnt work neither. Am i doing something wrong ?

_____________________________

Fenster fährt mich Nüsse

(in reply to Theluin)
Post #: 5
RE: Special Component Hassle - 12/13/2011 7:18:28 PM   
ehsumrell1


Posts: 2152
Joined: 8/17/2010
From: The Briar Patch Nebula
Status: offline
Hello InaB77;
PM upload your races.txt file to me and I'll take a look and see what's
wrong! Hopefully I'll find and correct the problem!


_____________________________

Shields are useless in "The Briar Patch"...

(in reply to InaB77)
Post #: 6
RE: Special Component Hassle - 12/13/2011 7:27:40 PM   
Caesar_Augustus


Posts: 182
Joined: 3/29/2005
From: Henneth Anûn
Status: offline
Greeetings... in Legends, the races.txt that needs to be modified is not the general one installed in the game directory,
but rather the one that appears for each one of any given race, in the races folder, that is installed in the game directory.

(in reply to ehsumrell1)
Post #: 7
RE: Special Component Hassle - 12/13/2011 8:29:53 PM   
InaB77


Posts: 25
Joined: 12/5/2011
Status: offline
Yep it's Legends. I modified the quameno.txt in the races folder at the posted points still, for some reasons those changes dont show up in the game.

_____________________________

Fenster fährt mich Nüsse

(in reply to Caesar_Augustus)
Post #: 8
RE: Special Component Hassle - 12/13/2011 8:43:09 PM   
tjhkkr


Posts: 1856
Joined: 6/3/2010
Status: offline
Welcome to the forums Ina!

Could it be that it is in the wrong directory -- not trying to be rude here, just something we all do periodically.

Hello InaB77;
PM upload your races.txt file to me and I'll take a look and see what's
wrong! Hopefully I'll find and correct the problem!


It could be something as simple as a misplaced Apostrophe or semi-colon!

< Message edited by tjhkkr -- 12/13/2011 8:45:34 PM >


_____________________________

Remember that the evil which is now in the world will become yet more powerful, and that it is not evil which conquers evil, but only love -- Olga Romanov.

(in reply to InaB77)
Post #: 9
RE: Special Component Hassle - 12/13/2011 9:12:37 PM   
Igard


Posts: 2282
Joined: 3/29/2010
From: Scotland
Status: offline
Are you altering the Distant Worlds/races/quameno.txt file?

Or, are you creating a folder 'yourmod' in the customization folder? Distant Worlds/customization/'yourmod'/races/quameno.txt.

It should work either way, but perhaps there's some piece of hard-coding at work here preventing the vanilla files from making the desired changes.


_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to tjhkkr)
Post #: 10
RE: Special Component Hassle - 12/13/2011 9:58:09 PM   
elliotg


Posts: 3184
Joined: 9/10/2007
Status: offline
quote:

ORIGINAL: InaB77
Just made verified, everything looks correct but still doesnt seem to work. Also i just found another quirk:

'Special Government: 0=None, 1=Technocracy, 2=HiveMind, 3=MercantileGuild, 4=UtopianParadise, 5=Way of the Ancients, 6=Way of Darkness, 7=Corporate Nationalism
SpecialGovernment		;5

'Preferred Starting Government: 0=No preference, 1=Technocracy, 2=HiveMind, 3=MercantileGuild, 4=UtopianParadise, 5=Way of the Ancients, 6=Way of Darkness, 7=Despotism, 8=Feudalism, 9=Monarchy, 10=Republic, 11=Democracy, 12=Military Dictatorship, 13=Corporate Nationalism
PreferredStartingGovernment		;5
... giving the SuperFrogs the WotA from the start doesnt work neither. Am i doing something wrong ?

Note that Way of the Ancients govt type (along with Way of Darkness) is a slightly special case: while you can set these as special govt types and preferred starting govt for a race, you cannot directly select them in the Start New Game screen (Your Empire step). However you can switch to them when in the game. You will also start the game with WotA if it is your preferred starting govt and you select "Random" govt in game setup.

(in reply to InaB77)
Post #: 11
RE: Special Component Hassle - 12/14/2011 1:44:54 PM   
InaB77


Posts: 25
Joined: 12/5/2011
Status: offline
As i dont know how to attach a text file here so any of You could look over it i'd just like to thank elliotg for the tip on how to get WotA to work. Still i cant the special tech to work but i just triple checked that it is exactly matching the zenox.txt file.

What i did is created an Mod in the Customization folder according to the Modding Guide. The folder structure contains characterImages (with my nice special SuperFrog pictures utilized by characters), characters, Policy, races and shipImages.

Reason for creating this was more of a proof of concept than something really playable. It'd be nice to get those few things to work tho.

_____________________________

Fenster fährt mich Nüsse

(in reply to elliotg)
Post #: 12
RE: Special Component Hassle - 12/14/2011 3:34:28 PM   
feelotraveller


Posts: 1040
Joined: 9/12/2011
Status: offline
I don't have much modding experience. That said, you could try copy and pasting the text from the Zenox file. Perhaps there is some invisible formatting causing a problem?

(in reply to InaB77)
Post #: 13
RE: Special Component Hassle - 12/14/2011 5:16:57 PM   
InaB77


Posts: 25
Joined: 12/5/2011
Status: offline
so.. i just found out that even tho the special tech doesnt show up in the race description in the enyclopedia it does show up in game. still saying "zenox only" but definitely there ;)

Problem solved...

_____________________________

Fenster fährt mich Nüsse

(in reply to feelotraveller)
Post #: 14
RE: Special Component Hassle - 12/15/2011 1:11:21 PM   
InaB77


Posts: 25
Joined: 12/5/2011
Status: offline
now that my "fun" mod is working - it's really hilarious having 5 different SuperFrog race communities and some standard races mixed in having a go at each other and just watching it on full auto in a small map - i'd like to get at a more serious mod:

i was thinking of creating a machine race. would it be possible to create this by copying some stuff from the existing machine race ? would it be possible to implement f.e. a always content flag (a planet is always content or happy as machines dont really care about happiness) ? enable a low colony count civilization to still be very competitive ? i'd really like to get some input.

Also: it's not currently possible to modify the research tree, correct ?

_____________________________

Fenster fährt mich Nüsse

(in reply to InaB77)
Post #: 15
RE: Special Component Hassle - 12/15/2011 4:16:39 PM   
Data


Posts: 3897
Joined: 1/3/2011
Status: offline
Correct

_____________________________

...Igniting stellar cores....Recharging reactors...Recalibrating hyperdrives....

(in reply to InaB77)
Post #: 16
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> Special Component Hassle Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.086