Matrix Games Forums

New screenshots for War in the West!Pike & Shot is now available!Server Maintenance Battle Academy 2 gets updated!Deal of the Week: Advanced Tactics Gold Ask Buzz Aldrin!Pike & Shot gets Release Date and Twitch Session!Deal of the Week Espana 1936War in the West coming in December!Space Program Manager will be launching on Steam
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Very long start-up times

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> Very long start-up times Page: [1]
Login
Message << Older Topic   Newer Topic >>
Very long start-up times - 12/11/2011 6:36:37 PM   
Sarkus

 

Posts: 42
Joined: 7/5/2004
Status: offline
Even since the previous expansion, the game takes a very long time to load from the desktop. As in 2-3 minutes. I was hoping Legends might help, but it does not. To be clear, the game runs fine when it finally does start-up, but 2-3 minutes is a very long time compared to just about every other game I own.

Is anyone else experiencing this or have any ideas of how to fix it? Or is this just normal?
Post #: 1
RE: Very long start-up times - 12/11/2011 6:51:51 PM   
Erik Rutins

 

Posts: 32941
Joined: 3/28/2000
From: Vermont, USA
Status: offline
Long load times are normal, fortunately you only have to go through that once per play session.

Regards,

- Erik


_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to Sarkus)
Post #: 2
RE: Very long start-up times - 12/12/2011 5:26:20 AM   
elliotg


Posts: 3184
Joined: 9/10/2007
Status: offline
2-3 minutes does sound excessively slow. On a mid-range machine here the game reaches the intro movies in 35-40 seconds.

Maybe you have some other process on your machine that is consuming CPU or slowing Hard Drive access? Possibly some anti-virus/security software is getting in the way?

(in reply to Sarkus)
Post #: 3
RE: Very long start-up times - 12/12/2011 9:52:44 AM   
Sarkus

 

Posts: 42
Joined: 7/5/2004
Status: offline
MSE is the only anti-virus running in the background on my machine. Unless Steam is causing a problem, I can't think of anything else that would be causing a conflict, but I guess I can turn those off and see if it impacts anything.

Edit: Not much of an improvement. Most of the time is spent looking at the menu telling me its loading the game, then I get a black screen for 15-20 seconds before the splash screens start firing up. At that point a mouse click puts me to the menu.

So there is something that is causing the game to load pretty slowly, and I have at least a mid-range (or more) equivalent system.

< Message edited by Sarkus -- 12/12/2011 10:00:14 AM >

(in reply to elliotg)
Post #: 4
RE: Very long start-up times - 12/12/2011 10:15:06 AM   
elliotg


Posts: 3184
Joined: 9/10/2007
Status: offline
quote:

ORIGINAL: Sarkus
Edit: Not much of an improvement. Most of the time is spent looking at the menu telling me its loading the game, then I get a black screen for 15-20 seconds before the splash screens start firing up. At that point a mouse click puts me to the menu.

Which menu do you mean when you say "Most of the time is spent looking at the menu telling me its loading the game"?

Is it the screen shown below? Or is it the Launcher screen that comes before this one?

You could also try starting DistantWorlds.exe directly in the root game folder. Navigate to C:\Matrix Games\Distant Worlds\ on your hard drive (assuming a default install) and double-click the file DistantWorlds.exe






Attachment (1)

(in reply to Sarkus)
Post #: 5
RE: Very long start-up times - 12/12/2011 1:34:43 PM   
feelotraveller


Posts: 1038
Joined: 9/12/2011
Status: offline
Just as reference I too have a startup time of 2:50 from the distantworlds.exe to the first sound of the intro movies. I run it on a Core2 Duo at 2.00 Ghz with 2GB RAM. Maybe that is below mid-range machine these days? I turn most things off before starting; only thing I can see using CPU apart from DW is explorer and it barely uses anything (at least while DW is loading).

For me this length of startup time is not a big thing - I think it more important that once started I have a fun game and that it runs (pretty much) trouble free. Faster load times are really just the icing on the cake.

p.s. There are some games that take way longer to load (notably Shogun 2). I haven't timed it but it would be in the region of 15 minutes and I make no exaggeration.

(in reply to elliotg)
Post #: 6
RE: Very long start-up times - 12/12/2011 3:25:50 PM   
Padraig Tseng

 

Posts: 5
Joined: 2/16/2011
Status: offline
I generally have a long load time as well. I think it might be due to me having a lower end machine. Doesn't faze me though, I take the time to make a sandwich or grab a frosty adult beverage for my gaming session.

(in reply to feelotraveller)
Post #: 7
RE: Very long start-up times - 12/12/2011 4:38:15 PM   
cookie monster


Posts: 1695
Joined: 5/22/2005
From: Birmingham,England
Status: offline
The load time is ok on my beast of a machine,

but if you have an old machine, just launch the game and do something else while it's loading

you can then focus back on the game as the intro movie is playing no problem

(in reply to Padraig Tseng)
Post #: 8
RE: Very long start-up times - 12/12/2011 6:36:07 PM   
ASHBERY76


Posts: 1978
Joined: 10/10/2001
From: England
Status: offline

(in reply to cookie monster)
Post #: 9
RE: Very long start-up times - 12/12/2011 7:15:11 PM   
Whydmer


Posts: 102
Joined: 6/5/2009
Status: online
2 minutes 15 seconds on my dual core 4 mg ram laptop this morning, with 45 more seconds to load a save game. not complaining just givinganother point of reference.

(in reply to ASHBERY76)
Post #: 10
RE: Very long start-up times - 12/12/2011 9:24:05 PM   
Sarkus

 

Posts: 42
Joined: 7/5/2004
Status: offline
quote:

ORIGINAL: elliotg

quote:

ORIGINAL: Sarkus
Edit: Not much of an improvement. Most of the time is spent looking at the menu telling me its loading the game, then I get a black screen for 15-20 seconds before the splash screens start firing up. At that point a mouse click puts me to the menu.

Which menu do you mean when you say "Most of the time is spent looking at the menu telling me its loading the game"?

Is it the screen shown below? Or is it the Launcher screen that comes before this one?

You could also try starting DistantWorlds.exe directly in the root game folder. Navigate to C:\Matrix Games\Distant Worlds\ on your hard drive (assuming a default install) and double-click the file DistantWorlds.exe







Yes, that screen is where it sits for most of the time. And as a point of reference, my PC is more powerful then some others mentioned - quad 2.6 core, 4GB Ram, 1 GB Video card (not that I expect that matters here).

Running straight from the exe the time was a bit faster - about 1:45 from clicking on the exe to when the screen went black. Then 23 seconds of a black screen before the Matrix splash fired up.





< Message edited by Sarkus -- 12/12/2011 9:32:17 PM >

(in reply to elliotg)
Post #: 11
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> Very long start-up times Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.078