Matrix Games Forums

Hannibal: Terror of Rome goes into BetaBattle Academy Mega Pack releases on SteamDeal of the Week Da Vinci's Art of WarCivil War II Patch 1.4 public BetaHappy Easter!Battle Academy is now available on SteamPlayers compare Ageods Civil War to Civil War IIDeal of the week - An updated War in the East goes half Price!Sign up for the Qvadriga beta for iPad and Android!Come and say hi at Pax and Salute
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Can't run game at all!

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Classic (Free) Games] >> Titans of Steel - Warring Suns >> Tech Support >> Can't run game at all! Page: [1]
Login
Message << Older Topic   Newer Topic >>
Can't run game at all! - 4/19/2011 3:08:00 AM   
AceHunter71

 

Posts: 4
Joined: 4/19/2011
Status: offline
I downloaded V1.2.1 and installed it. After clicking "play game" from the menu, it will run the "developer intro" (with the 1's and 0's) then crashes to desktop.
I would love to try this game. Can someone help? I also downloaded the V1.2.2 patch but haven't done anything with it yet. (Upon a previous installment attempt, I put the files into the ToS directory folder and tried to run the game with the 1.2.2 patch exe but it loaded with a "couldn't find mouse-pointer" error and crashed to desktop as well)
Post #: 1
RE: Can't run game at all! - 4/19/2011 4:22:26 PM   
jureidinim


Posts: 90
Joined: 6/8/2004
Status: offline
Hi,
what system you running?
there was another post where it seemed the problem (similar to yours) was resolved by tweaking the config file to force the game to load in windowed mode. Dunno if that will help you. Here's the forum link:

http://www.matrixgames.com/forums/tm.asp?m=2713492

Hope it helps.

EDIT: also - make sure you grab the latest version of the 1.2.2 patch. Larkin has been updating it incrementally but kept the same version number. download here:
http://www.matrixgames.com/forums/tm.asp?m=2053107

< Message edited by jureidinim -- 4/19/2011 4:26:07 PM >

(in reply to AceHunter71)
Post #: 2
RE: Can't run game at all! - 4/20/2011 5:52:54 AM   
AceHunter71

 

Posts: 4
Joined: 4/19/2011
Status: offline
I tried the alt-w and alt-enter stuff to force to windowed mode and it crashes immediately. I don't know how to updateit to 1.2.2

(in reply to jureidinim)
Post #: 3
RE: Can't run game at all! - 4/20/2011 1:54:30 PM   
jureidinim


Posts: 90
Joined: 6/8/2004
Status: offline
Its been awhile .. but if you havethe 1.2.2 EXE file, just run the program (double click on it) and it will update the game. The incremental releases in that other thread i showed you is just to be unzipped and overwrite the existing files.


For the windowed mode - since you cannot get the game started fully - go to your data\configs directory (in the folder you installed the game to) and open the tcc.cfg file (notepad works).

Look for [TOS_WS_GRAPHICS] and the line below should be Screen_Mode. Make sure Screen_Mode = 0 is there. (0 = windowed mode... its probably = 1 now which is full screen).

Hope this helps.

(in reply to AceHunter71)
Post #: 4
RE: Can't run game at all! - 4/20/2011 3:14:51 PM   
AceHunter71

 

Posts: 4
Joined: 4/19/2011
Status: offline
Jureidinim, your advice was incredibly helpful and I got the patch installed and the windowed view set as default. Unfortunately, same problem. After "Matrix Games" info, CRAAAAAASH. Sux but Thanks once again!

(in reply to jureidinim)
Post #: 5
RE: Can't run game at all! - 4/20/2011 8:59:46 PM   
jureidinim


Posts: 90
Joined: 6/8/2004
Status: offline
Glad to help - sorry it ddnt get the game working though.

So lets try some random things:
1) Try disabling the intro video... from Larkin:
"Set intro_at_all = no in data\configs\tcc.cfg at the bottom of the file."

2) Disable sound - I believe thats the "sound_at_all" and "music_at_all" values also at bottom of tcc.cfg file. Just set them to "no" (without quotes)

3) Do you have multiple cores on your machine? I had an issue where it would crash as well and Larkin helped me realize it was a core issue. Just follow this thread for details of how to force it to run in one core:
http://www.matrixgames.com/forums/tm.asp?m=1729557

That may be my final three bullets for this problem.. lol.. Hope it helps.

(in reply to AceHunter71)
Post #: 6
RE: Can't run game at all! - 5/23/2011 6:27:12 AM   
LarkinVB

 

Posts: 1851
Joined: 10/9/2001
From: Germany
Status: offline
If the game crashes at startup you have to disable or remove the intro videos.

To disable just edit the file data\configs\tcc.cfg and set intro_at_all = no at the bottom of the file.
To remove the intro videos just delete or rename two files in the images folder called Matrixgames.avi and TOS_Intro.avi

(in reply to jureidinim)
Post #: 7
RE: Can't run game at all! - 8/18/2011 6:39:54 AM   
LACK OF SUBTLETY

 

Posts: 3
Joined: 8/18/2011
Status: offline
I have had both of these problems.

Following the advice in this thread, i deactivated the opening animations and the game will now run.

However, the 1.2.2 patch brings up the same "mousepointer" error descirbed earlier every time i try to install it. I have gone to the link provided in this thread to download the latest version, but continue to get the same message.

Also, in the game menu, how do I access mission and campaigns? The only battles i can find are random battles.

(in reply to AceHunter71)
Post #: 8
RE: Can't run game at all! - 8/19/2011 7:22:50 AM   
LarkinVB

 

Posts: 1851
Joined: 10/9/2001
From: Germany
Status: offline
You have to unzip the 1.2.2 archive into your TOS game folder, overwriting the old files. If you do not get a windows message to overwrite you can be sure you have installed into the wrong folder.

To play a campaign you have to first load a team from file in solitary game mode.


battle -> solitary game -> start new game -> load team1 from file -> select map -> select campaign or mission


< Message edited by LarkinVB -- 8/19/2011 7:23:49 AM >

(in reply to LACK OF SUBTLETY)
Post #: 9
RE: Can't run game at all! - 8/24/2011 6:59:07 PM   
LACK OF SUBTLETY

 

Posts: 3
Joined: 8/18/2011
Status: offline
Thanks for the help. I'm up and running with 1.2.2 and found the missions and campaigns.

(in reply to LarkinVB)
Post #: 10
Page:   [1]
All Forums >> [Classic (Free) Games] >> Titans of Steel - Warring Suns >> Tech Support >> Can't run game at all! Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.076