Matrix Games Forums

New Screenshots for Pike & ShotDeal of the Week Command: Modern Air/Naval Operations WOTYCommand: Modern Air/Naval Operations WOTY is now available!Frontline : The Longest Day Announced and in Beta!Command gets Wargame of the Year EditionDeal of the Week: Pandora SeriesPandora: Eclipse of Nashira is now availableDistant Worlds Gets another updateHell is Approaching Deal of the Week Battle Academy
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Mouse issues

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Classic (Free) Games] >> Titans of Steel - Warring Suns >> Tech Support >> Mouse issues Page: [1]
Login
Message << Older Topic   Newer Topic >>
Mouse issues - 2/2/2011 4:42:23 PM   
Jacu

 

Posts: 7
Joined: 2/2/2011
Status: offline
Hello,
I bought this game some years ago, and lately wanted to play again so I downloaded the frre version.
I am trying to make it run on a Win 7 x64 computer but the game can't find any mouse.
I am on a Acer 5750G laptop, and I patched to version 1.2.2

I tried also to start it as admin, and in xp or 98 compatibility mode but with no luck.
I think The game runs with no troubles since I can regularly exit from the menu module by alt-X.

Any hints?

Thanks
Post #: 1
RE: Mouse issues - 2/2/2011 8:39:22 PM   
LarkinVB

 

Posts: 1857
Joined: 10/9/2001
From: Germany
Status: offline
Hmm, no idea yet. Will test on Win7 x64.

(in reply to Jacu)
Post #: 2
RE: Mouse issues - 2/3/2011 10:36:43 AM   
Jacu

 

Posts: 7
Joined: 2/2/2011
Status: offline
Thanks

(in reply to LarkinVB)
Post #: 3
RE: Mouse issues - 2/3/2011 12:04:01 PM   
LarkinVB

 

Posts: 1857
Joined: 10/9/2001
From: Germany
Status: offline
Sorry, I could find a problem. Can you try with an USB mouse ?

(in reply to Jacu)
Post #: 4
RE: Mouse issues - 2/3/2011 2:01:53 PM   
Jacu

 

Posts: 7
Joined: 2/2/2011
Status: offline
Yep, it is already with a usb mouse.
I tried connecting the mouse and disabling touchpad, or removing mouse and using touchpad.
Nothing worked...

(in reply to LarkinVB)
Post #: 5
RE: Mouse issues - 2/3/2011 3:00:44 PM   
LarkinVB

 

Posts: 1857
Joined: 10/9/2001
From: Germany
Status: offline
Since I use a premade library for graphics/sound/input there isn't much I can do. I will ask the devs. 

(in reply to Jacu)
Post #: 6
RE: Mouse issues - 2/4/2011 10:19:40 AM   
Jacu

 

Posts: 7
Joined: 2/2/2011
Status: offline
If i remember correctly weren't the modules (HQ, factory, Battle) also loadable without going through the menu program? I think to remember it was separate programs but now I can only find the .dll
There is no way to make the hq module start without going through menu?

Thanks

BTW the Map editor works with no problems...

(in reply to LarkinVB)
Post #: 7
RE: Mouse issues - 2/4/2011 10:35:05 AM   
LarkinVB

 

Posts: 1857
Joined: 10/9/2001
From: Germany
Status: offline
Only the obsolete freeware from 1998 or so had seperate executables. I'm sorry but as it seems I can offer no help. I just can't reproduce the problem on all available platforms including Win7 x64.

(in reply to Jacu)
Post #: 8
RE: Mouse issues - 2/4/2011 10:50:01 AM   
Jacu

 

Posts: 7
Joined: 2/2/2011
Status: offline
Thanks for your help.
I spent so many nights with friends on the Amiga to play Mechforce that it feels like urgent to make this work :)

I did some extra testing:
running it as emulation win xp Service pack 2, Aero interface disabled, Admin powers, I am able to see this error prompt:
TCC: Error loading Mouse pointer

Actully the mouse seems to work, I dont see the pointer move or screen updated but if i click randomly, then alt+tab to desktop and then alt+tab back to the game I find it moved to HQ screen. So it might more be a visual update issue.

Don't know if you have suggestions regarding this.

Thanks again for your help

kind regards

(in reply to LarkinVB)
Post #: 9
RE: Mouse issues - 2/4/2011 2:20:24 PM   
LarkinVB

 

Posts: 1857
Joined: 10/9/2001
From: Germany
Status: offline
Can you copy this file into your TOS main folder and execute. It should start a small window with mouse position displayed but without a cursor. After pressing space it should display a simple cursor and after pressing space again it should display another cursor.

I fear it will just say "No mouse detected, but you need one!"

(in reply to Jacu)
Post #: 10
RE: Mouse issues - 2/4/2011 2:43:20 PM   
Jacu

 

Posts: 7
Joined: 2/2/2011
Status: offline
It worked perfectly fine with no errors.
I still think it is a videocard issue now, I installed on another pc at work and I noticed on the laptop i don't even see introductory video, it gets stuck at the very beginning with some 11 and 000.

(in reply to LarkinVB)
Post #: 11
RE: Mouse issues - 2/4/2011 5:40:29 PM   
LarkinVB

 

Posts: 1857
Joined: 10/9/2001
From: Germany
Status: offline
Set intro_at_all = no in data\configs\tcc.cfg at the bottom of the file.

(in reply to Jacu)
Post #: 12
RE: Mouse issues - 2/7/2011 1:46:07 PM   
Jacu

 

Posts: 7
Joined: 2/2/2011
Status: offline
Hello Larkin,
thanks for the suggestion.
It didn't solve, but tweaking the onfig ile I forced the game to start in windowed mode and now it seems to work perfectly.

I always tried to force widnow mode with Alt+Enter but never worked.

now it does.

I AM HAPPY!

Thanks again

(in reply to LarkinVB)
Post #: 13
RE: Mouse issues - 2/7/2011 4:43:11 PM   
LarkinVB

 

Posts: 1857
Joined: 10/9/2001
From: Germany
Status: offline
You can switch between window and fullscreen with ALT-w !

Great that you found a solution.

(in reply to Jacu)
Post #: 14
RE: Mouse issues - 4/20/2011 5:50:41 AM   
AceHunter71

 

Posts: 4
Joined: 4/19/2011
Status: offline
Same problem but none of the above worked. Still running V.1.2.1, though. I don't know how to update it.

(in reply to Jacu)
Post #: 15
RE: Mouse issues - 2/3/2013 1:30:12 AM   
HitBDCman

 

Posts: 1
Joined: 2/3/2013
Status: offline
I am having the exact same issue. Remembered TOS and wanted to play to feel nostalgic.

However, I do not see a way to change TOS to windowed mode in any of the config files. If there's anybody still out there on the forum any help would be appreciated.

Also, I did try doing alt-w while in the menu and it wont go to windowed mode. When I alt tab it the mouse does move around, and when I alt-x it the game closes for me.

(in reply to AceHunter71)
Post #: 16
RE: Mouse issues - 2/7/2013 5:49:58 PM   
Thorgrim

 

Posts: 2367
Joined: 10/11/2001
From: Portugal
Status: offline
Did you try editing tcc.cfg? I can't check the game right now, but IIRC it's there that you can set it to windowed mode.

_____________________________

Iceman

(in reply to HitBDCman)
Post #: 17
RE: Mouse issues - 3/16/2013 2:52:32 PM   
LarkinVB

 

Posts: 1857
Joined: 10/9/2001
From: Germany
Status: offline
Locate screen_mode in data\configs\tcc.cfg and set it to 0 for window mode.



< Message edited by LarkinVB -- 3/16/2013 2:54:27 PM >

(in reply to Thorgrim)
Post #: 18
Page:   [1]
All Forums >> [Classic (Free) Games] >> Titans of Steel - Warring Suns >> Tech Support >> Mouse issues Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.094