Matrix Games Forums

Happy Easter!Battle Academy is now available on SteamPlayers compare Ageods Civil War to Civil War IIDeal of the week - An updated War in the East goes half Price!Sign up for the Qvadriga beta for iPad and Android!Come and say hi at Pax and SaluteLegends of War goes on sale!Piercing Fortress Europa Gets UpdatedBattle Academy Mega Pack is now availableClose Combat: Gateway to Caen Teaser Trailer
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

RE: [REL] TRSE Star Trek Mod v1.4a

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> RE: [REL] TRSE Star Trek Mod v1.4a Page: <<   < prev  4 5 [6] 7 8   next >   >>
Login
Message << Older Topic   Newer Topic >>
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 7:18:37 PM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline
Ok, I'm getting this too, but only after switching back to the Star Trek theme. It seems that I can load the game, switch to the theme no problem, but can't change back to another theme without restarting the game. The error gives me the option of continuing, but doesn't seem to load the mod properly and the cursor is stuck on the rotating load icon until I start a game and it fixes itself.

I tried removing the extra shipset familly11, but that had no effect. I must have made a mistake somewhere in the races.txt file. I'm going to start going over it now.

Sorry that this causing you so much inconvenience, solops. The error I get is not game stopping, but is a nuisance. It shouldn't require you to reinstall the game and it certainly shouldn't make any changes to the registry!

Thanks for reporting it. Obviously don't try the mod again until I've found what's causing this.



_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to Igard)
Post #: 151
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 8:40:34 PM   
WoodMan


Posts: 1343
Joined: 6/2/2010
From: Ol' Blighty
Status: offline
Igard and Solops, did you already have a custom theme, including a previous version of the same mod activated when you got the crash?  I've had crashes before when changing a theme I already have activated.  Maybe this isn't the cause of the crash but as a caution always switch to the default theme before you install a new theme, especially if its an update to the same theme (you can change the name of your themes per version to prevent modification of an already installed/activated theme Igard). 

Also, the new game menu remembers your previous settings, so if you change to a theme with different races then press new game it gives a load of error messages because the races already selected in the new game screen are missing. So before activating a theme with different races (including default theme, if you already had ST/SW or something selected), go into the new game screen and clear out any manually setup AI empires in there.





< Message edited by WoodMan -- 12/30/2010 8:43:10 PM >


_____________________________

"My body may be confined to this chair, but my mind is free to explore the universe" - Stephen Hawking

(in reply to Igard)
Post #: 152
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 8:41:26 PM   
tjhkkr


Posts: 1679
Joined: 6/3/2010
Status: offline
It's important to mention that this mod doesn't use the Mechanoid or Shakturi race, so always remember to uncheck the story option for RotS at the games victory conditions screen.

No, no, no...

Use them and just use Lexlorn's Imperial ships and let DV and his boys come in and kick the tail out of the Romulans. That is when the Romulan ale will start flowing.
But then, because of the prime directive, there will be a big peace conference ... and I do not know what I am talking about, talking trash as usual.

_____________________________

Remember that the evil which is now in the world will become yet more powerful, and that it is not evil which conquers evil, but only love -- Olga Romanov.

(in reply to Igard)
Post #: 153
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 8:49:34 PM   
tjhkkr


Posts: 1679
Joined: 6/3/2010
Status: offline
Wood man, I remember getting errors from exactly what you say, but I do not remember unhandled exceptions...

_____________________________

Remember that the evil which is now in the world will become yet more powerful, and that it is not evil which conquers evil, but only love -- Olga Romanov.

(in reply to tjhkkr)
Post #: 154
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 8:53:02 PM   
ehsumrell1


Posts: 1802
Joined: 8/17/2010
From: The Briar Patch Nebula
Status: offline

quote:

ORIGINAL: Igard

Ok, I'm getting this too, but only after switching back to the Star Trek theme. It seems that I can load the game, switch to the theme no problem, but can't change back to another theme without restarting the game. The error gives me the option of continuing, but doesn't seem to load the mod properly and the cursor is stuck on the rotating load icon until I start a game and it fixes itself.

I tried removing the extra shipset familly11, but that had no effect. I must have made a mistake somewhere in the races.txt file. I'm going to start going over it now.

Sorry that this causing you so much inconvenience, solops. The error I get is not game stopping, but is a nuisance. It shouldn't require you to reinstall the game and it certainly shouldn't make any changes to the registry!

Thanks for reporting it. Obviously don't try the mod again until I've found what's causing this.


Igard... could the problem be that there is an older "DefaultOptions" file
lurking that is causing the errors at theme change? I remember that there
was a post somewhere before about erasing that file and it solved the problem.
Just a thought! I'm at work away from my home computer so I can't test it
at the moment.

_____________________________

Shields are useless in "The Briar Patch"...

(in reply to Igard)
Post #: 155
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 8:56:56 PM   
tjhkkr


Posts: 1679
Joined: 6/3/2010
Status: offline
I like your ship classes as usual...
Would it not be cool to actually be able to use some of the extra classes...

Oh, and a couple of fog of war ideas for you people:
Make all your frieghters, tankers the same model... this way you have to be careful who you order your ships to attack... You have to make sure whose empire's ships you are blasting... :)
Works great in the SW galaxy when the Empire and the Rebellion and some of the minor powers all use the same ships like frieghters and some of the more common starfightes... :)
I also do that with the Romulans and Klingons in the Kirk Era...

_____________________________

Remember that the evil which is now in the world will become yet more powerful, and that it is not evil which conquers evil, but only love -- Olga Romanov.

(in reply to tjhkkr)
Post #: 156
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 9:00:01 PM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline
quote:

ORIGINAL: WoodMan

Igard and Solops, did you already have a custom theme, including a previous version of the same mod activated when you got the crash?  I've had crashes before when changing a theme I already have activated.  Maybe this isn't the cause of the crash but as a caution always switch to the default theme before you install a new theme, especially if its an update to the same theme (you can change the name of your themes per version to prevent modification of an already installed/activated theme Igard). 


No nothing like that, WoodMan.

quote:

Also, the new game menu remembers your previous settings, so if you change to a theme with different races then press new game it gives a load of error messages because the races already selected in the new game screen are missing. So before activating a theme with different races (including default theme, if you already had ST/SW or something selected), go into the new game screen and clear out any manually setup AI empires in there.


As soon as I read I thought 'Bingo, that's got to be it', but no. Still get the exception.


quote:

Igard... could the problem be that there is an older "DefaultOptions" file
lurking that is causing the errors at theme change? I remember that there
was a post somewhere before about erasing that file and it solved the problem.
Just a thought! I'm at work away from my home computer so I can't test it
at the moment.


Trying that now, Ed....

EDIT: Can't find one.

I'm taking all my mods off and starting DW with the most basic mod I can make, with a couple of shipsets a race.txt and a bias.txt. See what happens.

< Message edited by Igard -- 12/30/2010 9:15:01 PM >


_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to WoodMan)
Post #: 157
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 9:37:21 PM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline
My Kirk era mod works fine. I can switch back and forth between the default.

This must be something wrong with TRSE. Maybe I put a wrong figure somewhere.

It's strange because the mod works fine. Very puzzling.

Ed, I just tried also with the mod you emailed me the other day. It's got the same problem.

I wonder if the game just doesn't like all the race names being changed.

I also tried putting the Mechanoids and Shakturi back in and moving the Remans and Tholians. Still the same.

I'll now try removing all the shipsets. This is getting tiring.


_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to Igard)
Post #: 158
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 9:44:19 PM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline
It's definately a shipset issue. The problem has gone now that my mod has no shipsets. 

EDIT: I think the problem is caused when changing theme from a mod with more than the default shipsets. I'm testing this now..

EDIT2: That's what it is. As soon as I add family11 shipset. I can no longer switch between the default and Star Trek themes.

I don't know if this is the same error as solops. It certainly doesn't cause a CTD or change the registry. I can ignore the error, but the mod doesn't load properly.

So, if I want to use more than the default number of shipsets, I have to restart the game.

< Message edited by Igard -- 12/30/2010 10:02:07 PM >


_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to Igard)
Post #: 159
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 10:11:13 PM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline

quote:

ORIGINAL: tjhkkr

I like your ship classes as usual...
Would it not be cool to actually be able to use some of the extra classes...


You can, TJ. Look at my screen shot from a few posts earler. Here are the instructions for using the extra ship set folder included in the mod.

How to use the 'Extra' Shipset :-

This shipset is not used by any one race in the game. It's purpose is simply to provide extra ship images for any additional ship designs the player may need. So the player can now have 2 frigate designs etc.

- From the Design Screen, select 'Show non-obsolete designs' from the drop-down menu.
- Select the design of the ship role you want to create another variant of. Click 'Copy as new'
- Click on the ship image combo box. Scroll to the bottom and look for a suitable ship image. There are several images here from different races. There are more ship images for Federation designs than any other race.
- Now design your new ship with it's unique features. I find that naming my ship designs according to what role they have helps. For example, I could have an Escort Frigate that is fast and lightly armed, as well as an Assault Frigate, which is a bit slower and heavily armed.

_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to tjhkkr)
Post #: 160
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 10:56:33 PM   
ehsumrell1


Posts: 1802
Joined: 8/17/2010
From: The Briar Patch Nebula
Status: offline

quote:

ORIGINAL: Igard

It's definately a shipset issue. The problem has gone now that my mod has no shipsets. 

EDIT: I think the problem is caused when changing theme from a mod with more than the default shipsets. I'm testing this now..

EDIT2: That's what it is. As soon as I add family11 shipset. I can no longer switch between the default and Star Trek themes.

I don't know if this is the same error as solops. It certainly doesn't cause a CTD or change the registry. I can ignore the error, but the mod doesn't load properly.

So, if I want to use more than the default number of shipsets, I have to restart the game.


Igard, thanks for the info. I'm believing that there is a problem with one
of the option files in the Documentsandsettings/Application Info area that
gets created. I'll be home from work soon and look into it, then I'll PM
you when I have some response. Weird! I'm gonna try and reproduce this, I
haven't had this problem at all. But it must be something, especially if
you got it with the info I gave you. Will get back to you later.

_____________________________

Shields are useless in "The Briar Patch"...

(in reply to Igard)
Post #: 161
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 11:27:14 PM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline
Ok, Ed. I've found the defaultOptions file, but deleting it doesn't fix the problem. It just resets everything. I can switch to the mod fine, but not back again to the default theme.

I think my real concern right now is solops problem. I don't understand how installing a few shipsets and txt files could result in having to reinstall the game and clean the registry. It shouldn't happen.


_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to ehsumrell1)
Post #: 162
RE: [REL] TRSE Star Trek Mod v1.4a - 12/30/2010 11:58:12 PM   
solops

 

Posts: 498
Joined: 1/31/2002
From: Central Texas
Status: offline
Let me add some detail to my observations. First of all, the change theme process took a looooong time. Then when starting a new game, I got the error. I could click my way through it and get back to the game, but I never tried playing it from there after getting the error message. At that point I found that I could not get back to any other theme. I tried re-downloading the ST 1.5 theme and reinstalling. No joy. I tried reinstalling the patch....then the patch and ROTS. No joy. Same problem. The I uninstalled ALL all of DW, including the folders left over after the uninstall process, then reinstalled all of DW & ROTS and still had a problem. Now it was personal. I next uninstalled, cleared out, cleaned up and then cleaned the registry. Only now could I reinstall and play vanilla ROTS or the Diverse Worlds mod. I am on Win XP. I have played several ROTS games with no problems before adding the ST mod.

_____________________________

All that is necessary for the triumph of evil is that good men do nothing. - Edmund Burke
Liberty lies in the hearts of men and women; if it dies there, no constitution, no law, no court can save it. - Judge Learned Hand

(in reply to Igard)
Post #: 163
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 12:37:30 AM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline
That's very strange. Do you recall if the error mentioned something about a combo-box? That's a common problem with DW. On the 'Other Empires' start up screen, if you have a list of empires there from  another theme, then the game will kick up alot of errors which you can close if you try repeatedly. Deleting the other empires from this screen stops this error from occuring.

The only thing that's different about this mod, is that it replaces every race and every ship set and adds a couple more. I thought it was working perfectly, but my small problem is a bit of a nuisance and your problem is just unacceptable really.

We'll see if we can figure out exactly what this is. Like I say, my tests have brought me to the conclusion that it's the extra shipsets that are the cause. If ehsumrell1 can confirm this or find another cause, then at least we've got something to take to Elliot when he comes back from his break.

I can't rule out the possibilty that I've made an error somewhere, though I've been over the races.txt file and the biases.txt and found nothing.


_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to solops)
Post #: 164
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 2:34:31 AM   
ehsumrell1


Posts: 1802
Joined: 8/17/2010
From: The Briar Patch Nebula
Status: offline

quote:

ORIGINAL: Igard

That's very strange. Do you recall if the error mentioned something about a combo-box? That's a common problem with DW. On the 'Other Empires' start up screen, if you have a list of empires there from  another theme, then the game will kick up alot of errors which you can close if you try repeatedly. Deleting the other empires from this screen stops this error from occuring.

The only thing that's different about this mod, is that it replaces every race and every ship set and adds a couple more. I thought it was working perfectly, but my small problem is a bit of a nuisance and your problem is just unacceptable really.

We'll see if we can figure out exactly what this is. Like I say, my tests have brought me to the conclusion that it's the extra shipsets that are the cause. If ehsumrell1 can confirm this or find another cause, then at least we've got something to take to Elliot when he comes back from his break.

I can't rule out the possibilty that I've made an error somewhere, though I've been over the races.txt file and the biases.txt and found nothing.


Igard, can you please send me the races, biases, dialog and design.txt files you have for the mod
that is problematic. I have an idea but I need to look at what has changed. Also, if Solops can
post his DXDiag file, I might can get a better picture of what's up. I'm running WIN XP SP3 and
I'm not having this problem with the TRSE mod at all.

_____________________________

Shields are useless in "The Briar Patch"...

(in reply to Igard)
Post #: 165
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 4:38:49 AM   
tjhkkr


Posts: 1679
Joined: 6/3/2010
Status: offline
IGARD. There is only one way to nail this down. It is NO FUN, but this was how I determined the design.txt file was corrupt.

Take your mod, add one or two things at most, and see if the game dumps all over itself. Since the game chokes almost immediately, it should not take too long to determine the cause. Start with the text files, then the image files.
One of the few thoughts I have about the image files is to double check and make sure that something is not misspelled in a file name in sets 11 onward that have nothing to fall back on from the main game. One of my very stupid mistakes was to miss a part of capital.png.

If I can help you, let me know...

_____________________________

Remember that the evil which is now in the world will become yet more powerful, and that it is not evil which conquers evil, but only love -- Olga Romanov.

(in reply to ehsumrell1)
Post #: 166
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 11:19:13 AM   
WoodMan


Posts: 1343
Joined: 6/2/2010
From: Ol' Blighty
Status: offline
Igard, sorry to sidetrack a little, but is that gamefront/filefront website you are hosting the mod on good?  Is there a limit to filesize/number of files, do you have to pay, is there a limited number of DL per file?  I might use it myself, just wondering what its like, I'm using fileden at the moment, which is fine, but I have to click through about 5 ads that try to fool me into clicking on submit before I upload, also, it doesn't count the files downloads.  Also, can you remove files from filefront?

_____________________________

"My body may be confined to this chair, but my mind is free to explore the universe" - Stephen Hawking

(in reply to tjhkkr)
Post #: 167
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 11:44:43 AM   
solops

 

Posts: 498
Joined: 1/31/2002
From: Central Texas
Status: offline
DXdiag attached, I hope.

Attachment (1)

_____________________________

All that is necessary for the triumph of evil is that good men do nothing. - Edmund Burke
Liberty lies in the hearts of men and women; if it dies there, no constitution, no law, no court can save it. - Judge Learned Hand

(in reply to ehsumrell1)
Post #: 168
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 2:01:45 PM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline
quote:

ORIGINAL: WoodMan

Igard, sorry to sidetrack a little, but is that gamefront/filefront website you are hosting the mod on good?  Is there a limit to filesize/number of files, do you have to pay, is there a limited number of DL per file?  I might use it myself, just wondering what its like, I'm using fileden at the moment, which is fine, but I have to click through about 5 ads that try to fool me into clicking on submit before I upload, also, it doesn't count the files downloads.  Also, can you remove files from filefront?


It seems like an excellent service to me. I haven't read any rules or regs, but it seems you can just start downloading/uploading. I'm not sure if there's a limit to what you can upload. There's no limit on the number of downloads.

There doesn't seem to be a way of removing a file. All you have to do is go to this link and upload. No login or anything -

http://www.filefront.com/upload.php

< Message edited by Igard -- 12/31/2010 2:07:40 PM >


_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to WoodMan)
Post #: 169
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 2:59:58 PM   
WoodMan


Posts: 1343
Joined: 6/2/2010
From: Ol' Blighty
Status: offline
Cool thanks, I think I will try it too 

_____________________________

"My body may be confined to this chair, but my mind is free to explore the universe" - Stephen Hawking

(in reply to Igard)
Post #: 170
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 3:09:30 PM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline
Ok. The problem I get is caused by the family11 shipset. I also get this exception error just the same using WoodMan's Diverse Worlds mods or any mod with a family11 shipset. So it's something caused by my computer configuration.

As for solops, I'm afraid I don't know. You could try again and remove family11 from the shipImages folder. I'm not sure if it is the same thing that's causing our problems, the symptoms are quite different. I'll get a report done on the tech support page once I know more.




_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to Igard)
Post #: 171
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 3:39:57 PM   
tjhkkr


Posts: 1679
Joined: 6/3/2010
Status: offline
So do I understand correctly that if one attempts to use the number 11 shipset or higher, the game ABENDS?

_____________________________

Remember that the evil which is now in the world will become yet more powerful, and that it is not evil which conquers evil, but only love -- Olga Romanov.

(in reply to Igard)
Post #: 172
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 3:40:33 PM   
solops

 

Posts: 498
Joined: 1/31/2002
From: Central Texas
Status: offline
I tried re-installing and running ST 1.5. I got this error at the first game setup screen. I was unable to get through the setup process, being presented with an apparently infinite number of the errors.
----------------------------------------------------------------------------------------
“The following error occurred in DatGridView
System.ArgumentException: DataGridViewComboBoxCell value is not valid”
------------------------------------------------------------------------------------------------
Then, when I tried to switch themes back to the default shipset, I got this excepton error:
-----------------------------------------------------------------------------------------
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at DistantWorlds.Controls.InfoPanel.CopyBitmap(Bitmap image)
at DistantWorlds.Controls.InfoPanel.InitializeImages(Bitmap[] characterImages, Bitmap[] troopImages, Bitmap[] resourceImages, Bitmap[] raceImages, Bitmap[] builtObjectImages, Bitmap[] fighterImages, Bitmap[] ruinImages, Bitmap[] habitatImages, Bitmap[] facilityImages, Bitmap approvalSmileImage, Bitmap approvalNeutralImage, Bitmap approvalSadImage, Bitmap approvalAngryImage, Bitmap developmentImage, Bitmap colonyImage, Bitmap firepowerImage, Bitmap shipGroupLeadShipImage, Bitmap capitalColonyImage, Bitmap regionalCapitalColonyImage, Bitmap automateImage, Bitmap blockadeImage)
at DistantWorlds.Main.cujM7ouqFL()
at DistantWorlds.Start.Q0sJnSm7f(String , Boolean , Boolean )
at DistantWorlds.Start.lC170NXGe8(Object , EventArgs )
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at DistantWorlds.Controls.GlassButton.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at DistantWorlds.Controls.GlassButton.OnMouseUp(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3615 (GDR.050727-3600)
CodeBase: file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
DistantWorlds
Assembly Version: 1.5.0.1
Win32 Version: 1.5.0.1
CodeBase: file:///C:/Matrix%20Games/Distant%20Worlds/DistantWorlds.exe
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3614 (GDR.050727-3600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
DistantWorlds.Controls
Assembly Version: 1.5.0.1
Win32 Version: 1.5.0.1
CodeBase: file:///C:/Matrix%20Games/Distant%20Worlds/DistantWorlds.exe
----------------------------------------
DistantWorlds.Types
Assembly Version: 1.5.0.1
Win32 Version: 1.5.0.1
CodeBase: file:///C:/Matrix%20Games/Distant%20Worlds/DistantWorlds.exe
----------------------------------------
Microsoft.DirectX.DirectSound
Assembly Version: 1.0.2902.0
Win32 Version: 5.04.00.2904
CodeBase: file:///C:/WINDOWS/assembly/GAC/Microsoft.DirectX.DirectSound/1.0.2902.0__31bf3856ad364e35/Microsoft.DirectX.DirectSound.dll
----------------------------------------
AxInterop.WMPLib
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Matrix%20Games/Distant%20Worlds/AxInterop.WMPLib.DLL
----------------------------------------
Interop.WMPLib
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Matrix%20Games/Distant%20Worlds/Interop.WMPLib.DLL
----------------------------------------
System.Deployment
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Deployment/2.0.0.0__b03f5f7f11d50a3a/System.Deployment.dll
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
PresentationCore
Assembly Version: 3.0.0.0
Win32 Version: 3.0.6920.4016 built by: GDR
CodeBase: file:///C:/WINDOWS/assembly/GAC_32/PresentationCore/3.0.0.0__31bf3856ad364e35/PresentationCore.dll
----------------------------------------
WindowsBase
Assembly Version: 3.0.0.0
Win32 Version: 3.0.6920.4016 built by: GDR
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/WindowsBase/3.0.0.0__31bf3856ad364e35/WindowsBase.dll
----------------------------------------
Microsoft.DirectX
Assembly Version: 1.0.2902.0
Win32 Version: 5.04.00.2904
CodeBase: file:///C:/WINDOWS/assembly/GAC/Microsoft.DirectX/1.0.2902.0__31bf3856ad364e35/Microsoft.DirectX.dll
----------------------------------------
Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
----------------------------------------------------------------

I also get the second error (the exception) when changing from the Diverse Worlds theme, though it does not cause the first error or the game setup problems. I hope this helps.




< Message edited by solops -- 12/31/2010 3:42:38 PM >


_____________________________

All that is necessary for the triumph of evil is that good men do nothing. - Edmund Burke
Liberty lies in the hearts of men and women; if it dies there, no constitution, no law, no court can save it. - Judge Learned Hand

(in reply to Igard)
Post #: 173
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 3:50:30 PM   
WoodMan


Posts: 1343
Joined: 6/2/2010
From: Ol' Blighty
Status: offline
quote:

So do I understand correctly that if one attempts to use the number 11 shipset or higher, the game ABENDS?


Just to confirm Diverse Worlds uses shipset11 and the game runs fine on my computer with no problems at all running the theme.  I haven't played it for that long though, but so far, no problems.

Anyone else getting problems with mods using shipset 11?

Igard do a quick scan of all your shipsets 11 and above to make sure they all have 25 ships. Actually, I have the mod on my comp, I'll count them too

< Message edited by WoodMan -- 12/31/2010 3:52:37 PM >


_____________________________

"My body may be confined to this chair, but my mind is free to explore the universe" - Stephen Hawking

(in reply to solops)
Post #: 174
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 3:58:51 PM   
WoodMan


Posts: 1343
Joined: 6/2/2010
From: Ol' Blighty
Status: offline
Okay, there is the correct amount of ships and all spelt correctly.

I would recommend Igard reinstall the game and the expansion, because having problems with shipset 11 for all mods is weird.  For the mod, start by removing all the extra stuff and just try the race file and *ship*images, then add everything else in one by one until you get the problem.  I have to admit, stuff like troop images and flagshapes I've never toyed with myself, so I don't know if they would be causing a problem for anyone.


< Message edited by WoodMan -- 12/31/2010 4:08:22 PM >


_____________________________

"My body may be confined to this chair, but my mind is free to explore the universe" - Stephen Hawking

(in reply to WoodMan)
Post #: 175
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 4:09:50 PM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline
Solops. The error messages you get with the, “The following error occurred in DatGridView  System.ArgumentException: DataGridViewComboBoxCell value is not valid” is almost certainly being caused by a list of empires on your set up screen. Can you check somehow that the list is completely clear of all other empires before changing theme?

Then next exception error looks just the same as mine.

WoodMan, thank you for checking this for me. That sounds like a reasonable next step. Re-installing now....


_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to WoodMan)
Post #: 176
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 4:31:48 PM   
WoodMan


Posts: 1343
Joined: 6/2/2010
From: Ol' Blighty
Status: offline
Cool, if when you have reinstalled and tried the ST mod again you are able to use shipset11 without problems (test it with Diverse Worlds we know it works on others computers) but the ST mod still has problems let me know, I'll see if I can find anything wrong with it.  At the moment I'm too scared to test it incase I lose shipset11 for all mods 

_____________________________

"My body may be confined to this chair, but my mind is free to explore the universe" - Stephen Hawking

(in reply to Igard)
Post #: 177
RE: [REL] TRSE Star Trek Mod v1.4a - 12/31/2010 5:20:56 PM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline
The problem still persists after re-install. 

It was switching between themes fine until I finally added the family11 shipset (I left this till last), then the exception error popped up again. I tried it with your mod too WoodMan and the same thing happened. It's not a problem with the mods, this is a game problem. There's nothing I can do about it.

I think the problems solops was having was related to empires on the other empires screen. He also seems to be having the same problem I am when switching FROM a theme with more than the default 11 shipsets. I can switch to the theme but not away from it.

The way I'm getting around this now is, rather than go to the theme and switch it from another theme. I go to the theme menu and change to the default theme. Then I exit the game and restart it. Then I can change to my desired theme.

I'll post a report on the tech support forum after Elliot returns.


< Message edited by Igard -- 12/31/2010 5:21:02 PM >


_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to WoodMan)
Post #: 178
RE: [REL] TRSE Star Trek Mod v1.4a - 1/1/2011 10:03:39 PM   
WoodMan


Posts: 1343
Joined: 6/2/2010
From: Ol' Blighty
Status: offline
Igard, I'm now getting exactly the same problem as you.  Not just for Trek, but for any theme that uses the newly allocated shipset slots.

Edit: Actually maybe slightly different to you. I'll explain whats happening.

If the Default Theme is active, I can switch to any mod of my choice. If another mod is active trying to switch themes causes a unhandled exception, even when switching to the default. To get back to the default I have to remove the currently selected mod from the customization folder, start the game and Default Theme will now be selected.

On another note, trying to load a save game started with another theme causes an unhandled exception for me too. For example, I started a game with Diverse Worlds 3, it won't load under Diverse Worlds 6, but starting a new game works fine.

2nd Edit: Okay I think I know why the save game won't work, its because there are changes to the race file (only the shipset number column, but its a change nontheless).

< Message edited by WoodMan -- 1/1/2011 10:34:32 PM >


_____________________________

"My body may be confined to this chair, but my mind is free to explore the universe" - Stephen Hawking

(in reply to Igard)
Post #: 179
RE: [REL] TRSE Star Trek Mod v1.4a - 1/1/2011 11:30:35 PM   
Igard


Posts: 2281
Joined: 3/29/2010
From: Scotland
Status: offline
Ok, WoodMan. Looks like Elliot has some work for the new year!

Do get the option to continue at the exception error? If I select continue instead of quit, then I can actually cancel the theme switching, which leaves the cursor with the little loading circle, but I can then exit the game normally (the cursor still works even though it looks like it's loading) and when I restart the game, the theme I was trying to change to has been loaded.

I don't know which is quicker or if you can do this if it's the same problem.


< Message edited by Igard -- 1/1/2011 11:31:37 PM >


_____________________________

The Picard Era for Distant Worlds

Igard's Romulan Stormbird

(in reply to WoodMan)
Post #: 180
Page:   <<   < prev  4 5 [6] 7 8   next >   >>
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> RE: [REL] TRSE Star Trek Mod v1.4a Page: <<   < prev  4 5 [6] 7 8   next >   >>
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.113