Matrix Games Forums

Happy Easter!Battle Academy is now available on SteamPlayers compare Ageods Civil War to Civil War IIDeal of the week - An updated War in the East goes half Price!Sign up for the Qvadriga beta for iPad and Android!Come and say hi at Pax and SaluteLegends of War goes on sale!Piercing Fortress Europa Gets UpdatedBattle Academy Mega Pack is now availableClose Combat: Gateway to Caen Teaser Trailer
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Tech Support FAQ (Updated for Distant Worlds: Shadows)

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> Tech Support FAQ (Updated for Distant Worlds: Shadows) Page: [1]
Login
Message << Older Topic   Newer Topic >>
Tech Support FAQ (Updated for Distant Worlds: Shadows) - 3/25/2010 9:39:36 PM   
Erik Rutins

 

Posts: 32556
Joined: 3/28/2000
From: Vermont, USA
Status: offline
Please download and apply the latest update using the "Check for Updates" option in your game menu.

1. If you have installed Distant Worlds: Shadows but nothing happens when you click on the Play button this is likely due to a dependency installation problem.

Please reboot and immediately reinstall Shadows, making sure that the check boxes to install .NET and XNA are both checked and that you allow both installers to complete. If you are prompted to reboot, do not reboot until the Shadows installer is fully complete.

If that fails, please go to the /redist sub-folder of your Shadows installation folder and manually run the following files in this order:

1. DotNetFx40_Full_x86_x64.exe
2. xnafx40_redist.msi

You can also try making sure you are "Running as Administrator".

Please also check issue #4 below.



< Message edited by Erik Rutins -- 11/26/2013 10:13:18 PM >


_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.
Post #: 1
RE: Tech Support FAQ - 3/25/2010 10:24:09 PM   
Erik Rutins

 

Posts: 32556
Joined: 3/28/2000
From: Vermont, USA
Status: offline
2. If you are experiencing slow performance:

First, update your video and audio drivers and make sure they are at their default settings. See if that resolves the issue.

Second, turn off any background programs (such as anti-virus or security software that may be using up CPU or trying to scan the game files while it plays)

Third, go into the Options menu and do this: Star density: set this to the far left, minimum

Now go into the Advanced Settings: Maximum framerate: Uncheck Unlimited box Set to 25, even 20 for now if need be Uncheck Display nebulae clouds in systems System nebulae detail = Low

Try that and see if it helps. If it does, you can increase these slowly to find what works for your system. I would start with increasing the Maximum framerate first, as that will greatly help your screen choppiness. Increase it by maybe 2 at a time.

Another suggestion:

Try these settings, Turn off nebulae clouds, Star density all the way left, zoom speed all the way right.

< Message edited by Erik Rutins -- 3/26/2010 4:09:11 PM >


_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to Erik Rutins)
Post #: 2
RE: Tech Support FAQ - 3/30/2010 6:51:50 PM   
Erik Rutins

 

Posts: 32556
Joined: 3/28/2000
From: Vermont, USA
Status: offline
3. If you are still experiencing a crash at startup with v1.0.2 installed, and you allowed the .NET and DirectX that came with the game installer to install fully (you did not uncheck them), then your .NET installation may be corrupted.

In some cases, there can be a problem with installing .NET because of a corrupted or damaged file in an older version on your system.

Microsoft recommended this tool to remove the damaged components:

This may be a corrupted .NET installation. Please try the .NET cleanup tool here:

http://blogs.msdn.com/b/astebner/archive/2012/08/04/10336934.aspx

After running that and re-installing .NET 3.5 and the 3.5 service pack, or .NET 4.0 for Shadows and later, the issue should be resolved.

< Message edited by Erik Rutins -- 5/23/2013 6:51:02 PM >


_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to Erik Rutins)
Post #: 3
RE: Tech Support FAQ - 3/31/2010 2:29:25 AM   
Erik Rutins

 

Posts: 32556
Joined: 3/28/2000
From: Vermont, USA
Status: offline
4. Start-up Crash or Not hearing any of the in-game music?

Assuming you've updated your audio drivers and that your speakers are connected and turned on...

This is actually a known issue when using Windows Media Player from another application (e.g. DW) to play music files (only for Media Player version 10 or older on Windows XP). It has nothing to do with normal playing of files through Windows Media Player by itself.

Microsoft has not fixed this issue. The only solution is to upgrade Media Player to version 11 or later. Take a look here if you want the nasty technical details: http://connect.microsoft.com/VisualStudio/feedback/details/374363/system-windows-media-mediaplayer-only-plays-sounds-once-in-windows-xp

< Message edited by Erik Rutins -- 5/23/2013 6:51:21 PM >


_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to Erik Rutins)
Post #: 4
RE: Tech Support FAQ - 5/23/2013 6:55:25 PM   
Erik Rutins

 

Posts: 32556
Joined: 3/28/2000
From: Vermont, USA
Status: offline
5. If you experience an "error at line 35 reading file races.txt" when trying to launch the game, this is because of an apparent incompatibility with some regional language settings. This is resolved in Update v1.0.2. Distant Worlds Shadows installed but not Starting?

_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to Erik Rutins)
Post #: 5
RE: Tech Support FAQ - 5/23/2013 6:58:34 PM   
Erik Rutins

 

Posts: 32556
Joined: 3/28/2000
From: Vermont, USA
Status: offline
6. If you are experiencing a crash in Distant Worlds: Shadows when trying to create a galaxy

Please check whether you have Windows Management Instrumentation service running on your machine.

To check this open Control Panel > Administrative Tools > Services. In the list of services you should look for one named "Windows Management Instrumentation". The status column should say "Started".

If this is present in the list but not started, please click the "Start" link to the left of the services list.

If Shadows still will not start and you receive the same error, then you may have a broken installation of WMI. You can use the tool at this link to fix it: http://windowsxp.mvps.org/repairwmi.htm

If "Windows Management Instrumentation" does not exist in the services list then you will need to enable it in Windows.

< Message edited by Erik Rutins -- 5/23/2013 11:33:48 PM >


_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to Erik Rutins)
Post #: 6
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> Tech Support FAQ (Updated for Distant Worlds: Shadows) Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.066