Matrix Games Forums

Battle Academy is now available on SteamPlayers compare Ageods Civil War to Civil War IIDeal of the week - An updated War in the East goes half Price!Sign up for the Qvadriga beta for iPad and Android!Come and say hi at Pax and SaluteLegends of War goes on sale!Piercing Fortress Europa Gets UpdatedBattle Academy Mega Pack is now availableClose Combat: Gateway to Caen Teaser TrailerDeal of the Week Alea Jacta Est
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Problem with both 1.3x updates

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Current Games From Matrix.] >> [World War I] >> Guns of August 1914 - 1918 >> Guns of August Support >> Problem with both 1.3x updates Page: [1]
Login
Message << Older Topic   Newer Topic >>
Problem with both 1.3x updates - 1/30/2010 12:41:39 PM   
ron the cabbie

 

Posts: 6
Joined: 1/30/2010
Status: offline
I recently purchased and registered the CD of this game and successfully loaded it. I then updated to v1.34 but could not launch the game. The 'trench.exe' caused an error and would not load. I then uninstalled and reinstalled the original (v1.0) and updated successfully each and every patch up to v1.23. I then updated to v1.32 and encountered the same error again. I am hoping some one out there has some advice as I am becoming frustrated at not being able to play the most up-to-date version of the game.
Post #: 1
RE: Problem with both 1.3x updates - 2/3/2010 8:26:00 PM   
ron the cabbie

 

Posts: 6
Joined: 1/30/2010
Status: offline
Problem solved. Error created by XP's Data Execution Protection. Just turned it off for GoA and 'Hey Presto' I can now use update 1.34.

(in reply to ron the cabbie)
Post #: 2
RE: Problem with both 1.3x updates - 2/9/2010 10:00:40 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
are they going to fix this error or do we have to do the fix on our own? i for one do not like toying with XP Configurations and i should not have to. this game is unplayable now until they fix their mistake!!!!

< Message edited by lion_of_judah -- 2/9/2010 10:46:26 PM >

(in reply to ron the cabbie)
Post #: 3
RE: Problem with both 1.3x updates - 2/11/2010 6:19:17 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
what is the point of posting issues on here when no one from Matrix will respond and fix the issue! what happened to " the customer is always right" or do they just want my money and screw the customer because that is what i'm feeling right now!
I'm not able to play this game because of this error and would like to know if they are working on a fix for this or are they just going to leave it as is and then i would be out the money for this game!

(in reply to ron the cabbie)
Post #: 4
RE: Problem with both 1.3x updates - 2/13/2010 9:04:55 PM   
ron the cabbie

 

Posts: 6
Joined: 1/30/2010
Status: offline
I quite agree, however in order to play the game (having spent good money on it) I considered it a calculated risk. I had to puzzle the answer out for myself as the solution I got from Matrix Games was for Windows 7 and not XP!

(in reply to lion_of_judah)
Post #: 5
RE: Problem with both 1.3x updates - 2/14/2010 6:11:40 PM   
von Schmidt


Posts: 63
Joined: 8/18/2003
Status: offline
It seems that this support forum is not that closely monitored by Matrix these days. Possibly because the title is a bit older; possibly because there is now a central Matrix helpdesk.

Have you guys tried to log a call with that helpdesk on your patch 1.34 issues?
I suspect that that will get you proper support a bit faster or at least get Matrix to contact the developer:

http://www.matrixgames.com/helpdesk/step_login.asp

Hope this helps,

-von Schmidt

(in reply to ron the cabbie)
Post #: 6
RE: Problem with both 1.3x updates - 2/14/2010 8:59:54 PM   
ron the cabbie

 

Posts: 6
Joined: 1/30/2010
Status: offline
Yes I posted the problem through the helpdesk and on this forum. The helpdesk gave me an answer for Windows 7 when I was on XP at the time. It was a magazine article which pointed out the possible DEP problem.
However, I am now on Windows 7, so the helpdesk advice came in handy after all.

ron the cabbie

(in reply to von Schmidt)
Post #: 7
RE: Problem with both 1.3x updates - 2/15/2010 6:32:36 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
I have posted the problem through their help desk, so now i'm waiting on a response. I hope they fix this because otherwise I'm screwed because I only bought the download and not the CD as well. Amazing though how other download sites will allow you to download the game you bought forever.

(in reply to von Schmidt)
Post #: 8
RE: Problem with both 1.3x updates - 2/15/2010 7:50:15 PM   
von Schmidt


Posts: 63
Joined: 8/18/2003
Status: offline
I 've just run a turn (strategic/ activation/ orders/ combat) in v1.34 and did not encounter any issues. Win XP Pro, SP3.
Installed under C:\Games\Guns of August
Fresh install with only final patch 1.34 applied.
Of course, if the error only happens when a country surrenders then my quick test does not mean a thing...

Lion, you can just burn the install file that you've downloaded to a CD, or -like me- back up installers to an external harddrive for safekeeping. That will avoid the need for re-downloads.

I do hope that someone knowledgeable on the helpdesk will get back to the both of you. If that happens, would you mind updating this thread with the solution for posterity?

Regards,
-von Schmidt

(in reply to lion_of_judah)
Post #: 9
RE: Problem with both 1.3x updates - 2/16/2010 9:55:20 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
I hope they answer this post as well, so we will see. I'm still screwed though because i accidentally deleted the install file off my hard drive and and now i cannot find my backup that i made. Oh how screwed am i!!!

(in reply to von Schmidt)
Post #: 10
RE: Problem with both 1.3x updates - 2/17/2010 12:26:34 PM   
ron the cabbie

 

Posts: 6
Joined: 1/30/2010
Status: offline
Dear von Scmidt,

The problem I had with both v1.32 & v1.34 was with Win XP's 'Data Execution Protection'. I simply 'turned it off' for trench.exe and now the game loads and runs fine. I posted my problem here and on helpdesk before I realised what was happening. Incidentally, this error did not occur with earler versions (up to v1.23).

However, I now have a problem during gameplay, playing as CP. Whenever France surrenders the German forces return to their 1914 setup, British forces disappear, France becomes neutral and after clicking arrow button to advance, I get an access violation. I have posted this new in-game problem as a new message on this forum, but have not had any replies yet. Do you have any suggestions as to what might be happening?

Regards, ron the cabbie

(in reply to von Schmidt)
Post #: 11
RE: Problem with both 1.3x updates - 2/17/2010 11:22:43 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
Hello tech support are you out there!!!!!!!!!!

(in reply to ron the cabbie)
Post #: 12
RE: Problem with both 1.3x updates - 2/17/2010 11:23:57 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
I have emailed both David Heath and Eric regarding this issue and have yet to hear back from them. I would like to know if they are going to support this game or just leave it broken as is? I for one am not happy about this whole thing!!!!!!!!!

(in reply to ron the cabbie)
Post #: 13
RE: Problem with both 1.3x updates - 2/18/2010 11:30:44 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
how many days now has this been that i have not been able to play this damn game because of this companies screw up? this is quickly becoming not funny any longer and i for one want these people to do something or is it that they just take our money and move on to the next game! I guess if they do respond by Monday I will have no choice but to contact the BBB ( Better Business Bureau )

< Message edited by lion_of_judah -- 2/18/2010 11:34:58 PM >

(in reply to lion_of_judah)
Post #: 14
RE: Problem with both 1.3x updates - 2/24/2010 6:23:11 PM   
von Schmidt


Posts: 63
Joined: 8/18/2003
Status: offline
Hi Ron,

No idea what might be happening with the French surrender issue - it sounds like the type of situation which might have been missed in testing the patch...
Unfortunately I've stopped playing last year, with the idea of picking GOA up again after this new patch. But I'll wait a while, I think!

Sorry I can't be of more help...

(One suggestion: "access violation" sounds like a system issue - have you tried the last savegame before the error on a different machine from your usual gaming PC?)

Regards,

-von Schmidt

(in reply to ron the cabbie)
Post #: 15
RE: Problem with both 1.3x updates - 2/24/2010 6:30:10 PM   
von Schmidt


Posts: 63
Joined: 8/18/2003
Status: offline
Lion,

Have you got the same issue as Ron's initial one? I.e. the game simply does not load at all?
Or is it something else?
Does an older patch version work at all?
Have you tried to start the game by clicking Trench.exe directly rather than using a desktop start icon?

The Matrix helpdesk should really have contacted you to confirm they are looking at the problem, even if there is no immediate solution. They are usually better than this, and I understand your frustration.

As a very last resort, you could try to contact the actual developer Frank Hunter: fhunter@telus.net

Regards,
-von Schmidt

(in reply to lion_of_judah)
Post #: 16
RE: Problem with both 1.3x updates - 2/24/2010 7:12:16 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
Von, the game loads but when i choose a scenario to play that is when i get the trench error. You are right they should have responded by now and they have not. I actually posted the complaint on armada 2526 beta patch thread and told them that once they tell me that this is the wrong forum area could they check into this error. Eric responded imagine that. So now i have to post a link for this thread so he can check into it i guess. Nope I have tried the trench exe icon, maybe i will give that a try, thanks.

(in reply to von Schmidt)
Post #: 17
RE: Problem with both 1.3x updates - 2/24/2010 7:16:14 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
Von, just tried running game with the trench icon and same thing happens, get a access violation trench error.

(in reply to lion_of_judah)
Post #: 18
RE: Problem with both 1.3x updates - 2/24/2010 7:27:10 PM   
Erik Rutins

 

Posts: 32550
Joined: 3/28/2000
From: Vermont, USA
Status: offline
Regarding some of the points above...

First, we do not check every forum every day, we don't have the staff for that. I apologize that your request waited as long as it did and that this caused frustration. The forums are for unofficial and non-guaranteed support. We try to be present and we do respond very often, as do our developers, but there is no guarantee. As a game gets older and has been through its support life cycle, its forum typically becomes less active.

The Help Desk is our official guaranteed support method and anytime you absolutely need an answer, that's where you should go.

GOA is not a broken game, it's been working for years now, though it has certainly had its share of bugs. However, Windows can be a moving target with many updates and many different configurations. Adding an exception for DEP for your Windows system if it is preventing GOA from running properly does not mean the game is broken, it means that Windows is being overly cautious about allowing the game to run. We typically advise customers with such problems to turn off or add exceptions to their security/anti-virus software which can often go very far overboard, preventing software from accessing its own files or registry settings and thus creating the appearance of a serious bug in the software itself. 99% of the time, adjustments to these security type settings resolve the issue.

Regarding your specific issue, which does appear to be specific to your installation, have you tried an older version than 1.34 to see if that works well for you? Have you tried adjusting your DEP/Security settings to let the game run to see if that helps?

Regards,

- Erik


_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to lion_of_judah)
Post #: 19
RE: Problem with both 1.3x updates - 2/24/2010 9:52:34 PM   
von Schmidt


Posts: 63
Joined: 8/18/2003
Status: offline
Lion,


1. I know that Vista/Win7 are quite picky on what programs are allowed to do. If you are on either OS(rather than XP), could you try to install the game to a different folder than the default "C:\program files\...."?
For example, I've got GOA installed to C:\Games\Guns of August
And maybe run it when you are logged in as Administrator rather than a regular user account?

2. If the game itself actually starts, then maybe some other options are to blame and you quite likely do not have the DEP issue that Ron had at first.
Have you tried with all 4 scenarios - and do all of them end in that "Trench" error?
I think earlier versions of the game had some sound issues. Could you try with the option "No Sound"?
Have you tried "Solitaire" as well as "Hotseat"?

3. This sounds weird, but could you make sure that all the files in the "Guns of August" folder are *not* write protected?

4. Lastly: my file "Trench.exe" is 9.05Mb (9.269kb). Yours as well?

Cheers,

-von Schmidt



< Message edited by von Schmidt -- 2/24/2010 9:59:46 PM >

(in reply to lion_of_judah)
Post #: 20
RE: Problem with both 1.3x updates - 2/28/2010 6:53:52 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
Von
I'm always logged on as administrator and the operating system I currently have is windows xp pro. The game itself loads fine, the problem is that when i begin to play a scenario that is when i get the trench error. Reinstalling will not do because I no longer have the install program, burned it on a CD but then I have misplaced it and so I'm screwed, unless Matrix lets me re-download this game again. I have yet to receive an email from tech support and so I'm still not getting the customer service i as a paying customer deserves. I'm beginning to become not so impressed with matrix games here as of late!

(in reply to von Schmidt)
Post #: 21
RE: Problem with both 1.3x updates - 2/28/2010 6:55:08 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
Eric
the game ran fine until I updated to the latest patch. The patch I had before I upgraded was 1.32

(in reply to Erik Rutins)
Post #: 22
RE: Problem with both 1.3x updates - 3/1/2010 9:48:37 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
Eric
I sent an email to your tech support about this and have yet to hear back, and that was over two weeks ago.

(in reply to lion_of_judah)
Post #: 23
RE: Problem with both 1.3x updates - 3/10/2010 5:38:13 AM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
Still not able to play this game and still no answer from tech support. Now this is BS and i want an answer on wether I'm going to get some help or did I just waste my fracking money on this damn game!

(in reply to lion_of_judah)
Post #: 24
RE: Problem with both 1.3x updates - 3/11/2010 8:35:14 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
Eric - when i click on the game it opens fine but when i go and choose a scenario to play that is when i get the access violation trench error that i have been talking about. I hope you can help me resolve this, otherwise i might as well uninstall this game and move on. Thanks

< Message edited by lion_of_judah -- 3/11/2010 8:39:06 PM >

(in reply to lion_of_judah)
Post #: 25
RE: Problem with both 1.3x updates - 3/26/2010 9:58:11 PM   
lion_of_judah


Posts: 1237
Joined: 1/8/2007
Status: offline
It has been over a month now going into its second month with no fix for this issue. Matrix customer service and tech support are nothing but pure "****" I want a response and a fix for this issue and I'm tired of coming on this damn board and nothing being done or my reply being ignored!

(in reply to lion_of_judah)
Post #: 26
Page:   [1]
All Forums >> [Current Games From Matrix.] >> [World War I] >> Guns of August 1914 - 1918 >> Guns of August Support >> Problem with both 1.3x updates Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.086