Matrix Games Forums

To End All Wars: Mountain InfantryPandora: Eclipse of Nashira Announced! Deal of the Week: Command Ops goes half price!New Fronts are opening up for Commander: The Great WarCharacters of World War 1Sign of for the Pike and Shot Beta!More Games are Coming to Steam! Return to the Moon on October 31st! Commander: The Great War iPad Wallpapers Generals of the Great War
Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

cannot get game to start

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Current Games From Matrix.] >> [Napoleonics] >> Commander - Napoleon at War >> Tech Support >> cannot get game to start Page: [1] 2   next >   >>
Login
Message << Older Topic   Newer Topic >>
cannot get game to start - 10/30/2008 12:09:44 AM   
jon1doc

 

Posts: 14
Joined: 10/26/2008
Status: offline
Happy with download.no probs there.Now I click either the menu or quick start ,the cmd.exe window opens for a split sec,disappears and nothing else happens.any ideas what to do??please ....I would like to play the game since I have it now but how??JD
Post #: 1
RE: cannot get game to start - 10/30/2008 12:42:21 AM   
Erik Rutins

 

Posts: 32881
Joined: 3/28/2000
From: Vermont, USA
Status: offline
Hi,

Could you post a DxDiag file for us please (instructions at the top of this forum).

Regards,

- Erik

_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to jon1doc)
Post #: 2
RE: cannot get game to start - 10/30/2008 10:38:07 PM   
jon1doc

 

Posts: 14
Joined: 10/26/2008
Status: offline
hope this works the file upload I meanJD

Attachment (1)

(in reply to jon1doc)
Post #: 3
RE: cannot get game to start - 11/6/2008 10:45:27 PM   
jon1doc

 

Posts: 14
Joined: 10/26/2008
Status: offline
I know you must be busy ...but I feel like asking for my money back
DXdiag posted on the 30/10/08.
Happy New President
Regards JD

(in reply to Erik Rutins)
Post #: 4
RE: cannot get game to start - 11/20/2008 11:03:57 PM   
jon1doc

 

Posts: 14
Joined: 10/26/2008
Status: offline
Hi again.
can you tell me more about java runtime ,what I should have installed 1.5.10 or 1.6,and/or "exceptions" which I can just make out in cmd.exe box which appears for split second.Or do I need to do something with AVG firewall??
Best Regards and greetings from Scotland
JD

(in reply to jon1doc)
Post #: 5
RE: cannot get game to start - 11/20/2008 11:04:52 PM   
jon1doc

 

Posts: 14
Joined: 10/26/2008
Status: offline
Hi again.
can you tell me more about java runtime ,what I should have installed 1.5.10 or 1.6,and/or "exceptions" which I can just make out in cmd.exe box which appears for split second.Or do I need to do something with AVG firewall??
Best Regards and greetings from Scotland
JD

(in reply to Erik Rutins)
Post #: 6
RE: cannot get game to start - 11/21/2008 4:05:13 AM   
Erik Rutins

 

Posts: 32881
Joined: 3/28/2000
From: Vermont, USA
Status: offline
Hi JD,

Sorry I completely missed your reply. Unfortunately our forum coverage can sometimes have gaps. Feel free to use the e-mail button to contact me if I miss something.

Your DxDiag looks fine.

Have you tried reinstalling and running in the "Low" memory mode to see if that makes a difference? Have you tried the latest beta update?

All that is necessary Java-wise is included with the game, so you shouldn't have to change anything there. Are you playing with an Administrator-level account?

Regards,

- Erik

_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to jon1doc)
Post #: 7
RE: cannot get game to start - 11/21/2008 3:42:21 PM   
Bismarck


Posts: 747
Joined: 9/23/2000
Status: offline
I'm no techie but what anti-virus app arre you using? My Norman AV has taken to calling recent Matrix game exe files viruses. I've gotten around this by adding the directory to the scan exclusion list.

_____________________________

Jim Cobb

(in reply to Erik Rutins)
Post #: 8
RE: cannot get game to start - 11/21/2008 11:50:13 PM   
jon1doc

 

Posts: 14
Joined: 10/26/2008
Status: offline
Thank you for your reply .
I have un and re installed x 2 and each time the same result occurs.
I have not tried any update- Im sure Ill find it via the forum.
I did update java runtime to most recent.

In reply to Bismark <hiya>
AVG Internet Security Suite

(in reply to Erik Rutins)
Post #: 9
RE: cannot get game to start - 11/22/2008 1:47:29 PM   
ekaranik

 

Posts: 13
Joined: 2/2/2008
Status: offline
Im have exactly the same problem, just received my CD, installed ok, but get same error as mentioned here. Any help appreciated.

(in reply to jon1doc)
Post #: 10
RE: cannot get game to start - 11/23/2008 12:52:14 AM   
ekaranik

 

Posts: 13
Joined: 2/2/2008
Status: offline
I still cant get the game working. When you click on the PLAY link, a dos box flashs open with a message but shuts immediately. The message is

"Exception in thread "main" java.lang.NoClassDefFoundError: CNAW"

The OS is Windows XP and the version of java I have is

java version "1.6.0_07"
Java(TM) SE Runtime Environment (build 1.6.0_07-b06)

Please help. I will post this at Slitherine Software to see if they can help.

Thanks.


< Message edited by ekaranik -- 11/23/2008 1:03:12 AM >

(in reply to ekaranik)
Post #: 11
RE: cannot get game to start - 11/23/2008 3:04:28 AM   
ekaranik

 

Posts: 13
Joined: 2/2/2008
Status: offline
OK, I've got a work around that gets it going.

1. Instead of trying to run game from Menu, which would not work for me, open up a dos box and change directory to where you installed the game. eg C:\Matrix Games\Commander - Napoleon At War>

Then type at the command line

java -Xms256m -Xmx512m -classpath . CNAW

It then works fine.


(in reply to ekaranik)
Post #: 12
RE: cannot get game to start - 11/23/2008 1:20:14 PM   
firepowerjohan


Posts: 378
Joined: 4/7/2007
Status: offline
quote:

ORIGINAL: ekaranik

I still cant get the game working. When you click on the PLAY link, a dos box flashs open with a message but shuts immediately. The message is

"Exception in thread "main" java.lang.NoClassDefFoundError: CNAW"

The OS is Windows XP and the version of java I have is

java version "1.6.0_07"
Java(TM) SE Runtime Environment (build 1.6.0_07-b06)

Please help. I will post this at Slitherine Software to see if they can help.

Thanks.




"Exception in thread "main" java.lang.NoClassDefFoundError: CNAW"

- This is a path problem, where did you install the game?



< Message edited by firepowerjohan -- 11/23/2008 1:22:12 PM >


_____________________________

Johan Persson - Firepower Entertainment
Lead developer of:
World Empires Live http://www.worldempireslive.com/
CEAW http://www.slitherine.com/forum/viewforum.php?f=18
CNAW http://www.slitherine.com/forum/viewforum.php?f=52



(in reply to ekaranik)
Post #: 13
RE: cannot get game to start - 11/23/2008 1:23:50 PM   
firepowerjohan


Posts: 378
Joined: 4/7/2007
Status: offline
To everyone that cannot get game to start. Please check that there is a "CNAW.class" file in your folder where installing the game. If that file does not exist then installation has failed somehow.

_____________________________

Johan Persson - Firepower Entertainment
Lead developer of:
World Empires Live http://www.worldempireslive.com/
CEAW http://www.slitherine.com/forum/viewforum.php?f=18
CNAW http://www.slitherine.com/forum/viewforum.php?f=52



(in reply to firepowerjohan)
Post #: 14
RE: cannot get game to start - 11/23/2008 10:31:25 PM   
ekaranik

 

Posts: 13
Joined: 2/2/2008
Status: offline
The install complete successfully, I accepted all the default settings.

The problem was when I tried to run the program via the supplied icon / menu interface that was supplied with the game.

Thats when I got the "Exception in thread "main" java.lang.NoClassDefFoundError: CNAW" error.

The CNAW.class file existed in the installed directory so the install did not fail.

The problem I believe lies in the way the game was executed from the supplied icon / menu interface.

By bypassing it and running the games via the command line it ran ok.

Fortunately I know a little bit about java so I could fix it myself, but I must say that this should not of happened at all and the support boards didn't seem to provide an answer either.

(in reply to firepowerjohan)
Post #: 15
RE: cannot get game to start - 11/24/2008 11:59:33 AM   
Iain McNeil


Posts: 1935
Joined: 10/26/2004
From: London
Status: offline
That's really interesting ekaranik and we've no idea why this happens. Johan will look in to it. Your command lines are different to what we use so maybe we need to change our settings.

_____________________________

Iain McNeil
Director
Slitherine Software
Website http://www.slitherine.com

(in reply to ekaranik)
Post #: 16
RE: cannot get game to start - 11/24/2008 5:03:40 PM   
firepowerjohan


Posts: 378
Joined: 4/7/2007
Status: offline
Is there a jre folder included in the installation? That is the Java the game should use hence we use jre\bin\java to locally guarantee that the correct java version is used and that all users use the same Java. This should mean it does not matter what Java you have installed on your machine.

ekaranik, can you try jre\bin\java Xss30m -Xms300m -Xmx600m CNAW
from the installaton directory and see if also the local jre folder works?


< Message edited by firepowerjohan -- 11/24/2008 5:06:05 PM >


_____________________________

Johan Persson - Firepower Entertainment
Lead developer of:
World Empires Live http://www.worldempireslive.com/
CEAW http://www.slitherine.com/forum/viewforum.php?f=18
CNAW http://www.slitherine.com/forum/viewforum.php?f=52



(in reply to Iain McNeil)
Post #: 17
RE: cannot get game to start - 11/25/2008 9:40:42 AM   
ekaranik

 

Posts: 13
Joined: 2/2/2008
Status: offline
RE can you try jre\bin\java Xss30m -Xms300m -Xmx600m CNAW ? Results below.
C:\Matrix Games\Commander - Napoleon At War>jre\bin\java -Xss30m -Xms300m -Xmx600m CNAW
Exception in thread "main" java.lang.NoClassDefFoundError: CNAW

C:\Matrix Games\Commander - Napoleon At War>

(in reply to firepowerjohan)
Post #: 18
RE: cannot get game to start - 11/25/2008 7:51:41 PM   
firepowerjohan


Posts: 378
Joined: 4/7/2007
Status: offline
quote:

ORIGINAL: ekaranik

RE can you try jre\bin\java Xss30m -Xms300m -Xmx600m CNAW ? Results below.
C:\Matrix Games\Commander - Napoleon At War>jre\bin\java -Xss30m -Xms300m -Xmx600m CNAW
Exception in thread "main" java.lang.NoClassDefFoundError: CNAW

C:\Matrix Games\Commander - Napoleon At War>



On machines I seen so far, both the
case a) jre\bin\java -Xss30m -Xms300m -Xmx600m CNAW
and
case b) jre\bin\java -Xss30m -Xms300m -Xmx600m -classpath . CNAW

work, but do you imply that case b is better and that it would work for all machines?




_____________________________

Johan Persson - Firepower Entertainment
Lead developer of:
World Empires Live http://www.worldempireslive.com/
CEAW http://www.slitherine.com/forum/viewforum.php?f=18
CNAW http://www.slitherine.com/forum/viewforum.php?f=52



(in reply to ekaranik)
Post #: 19
RE: cannot get game to start - 11/26/2008 10:09:11 AM   
ekaranik

 

Posts: 13
Joined: 2/2/2008
Status: offline
Hi Johan,

Case A) jre\bin\java -Xss30m -Xms300m -Xmx600m -classpath . CNAW did not work, gave same error as mentioned before.

Case B) jre\bin\java -Xss30m -Xms300m -Xmx600m -classpath . CNAW worked and the game ran ok.

BTW, great game, I am enjoying it immensely, thankyou for producing it.

Best Regards Ellis.

(in reply to firepowerjohan)
Post #: 20
RE: cannot get game to start - 11/26/2008 10:13:48 AM   
Iain McNeil


Posts: 1935
Joined: 10/26/2004
From: London
Status: offline
Ekaranik - both A & B are the same above. Am I missing something or is it a typo?

_____________________________

Iain McNeil
Director
Slitherine Software
Website http://www.slitherine.com

(in reply to ekaranik)
Post #: 21
RE: cannot get game to start - 11/26/2008 12:18:25 PM   
ekaranik

 

Posts: 13
Joined: 2/2/2008
Status: offline
Apologies ... what I meant was ...

Case A) jre\bin\java -Xss30m -Xms300m -Xmx600m CNAW did not work, gave same error as mentioned before.

Case B) jre\bin\java -Xss30m -Xms300m -Xmx600m -classpath . CNAW worked and the game ran ok.

(in reply to Iain McNeil)
Post #: 22
RE: cannot get game to start - 11/26/2008 1:39:15 PM   
Treale


Posts: 1254
Joined: 8/10/2003
From: Central Florida
Status: offline
So if I buy this game, I have to type in all of these command lines to get the game to load!!!

_____________________________

Tony

(in reply to ekaranik)
Post #: 23
RE: cannot get game to start - 11/26/2008 1:55:54 PM   
Erik Rutins

 

Posts: 32881
Joined: 3/28/2000
From: Vermont, USA
Status: offline

quote:

ORIGINAL: Treale
So if I buy this game, I have to type in all of these command lines to get the game to load!!!


No, it's best not to make assumptions based on a single tech support thread. This works out of the box on the vast majority of systems without needing any tweaks or tech support.

_____________________________

Erik Rutins
Director of Product Development


For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to Treale)
Post #: 24
RE: cannot get game to start - 11/26/2008 2:02:51 PM   
Treale


Posts: 1254
Joined: 8/10/2003
From: Central Florida
Status: offline
Thanks for the reply. Can you tell me if the patches affect any of the smaller scenario's, or are they directed at the campaign game?

_____________________________

Tony

(in reply to Erik Rutins)
Post #: 25
RE: cannot get game to start - 11/26/2008 4:03:57 PM   
Bismarck


Posts: 747
Joined: 9/23/2000
Status: offline

quote:

ORIGINAL: Erik Rutins


quote:

ORIGINAL: Treale
So if I buy this game, I have to type in all of these command lines to get the game to load!!!


No, it's best not to make assumptions based on a single tech support thread. This works out of the box on the vast majority of systems without needing any tweaks or tech support.


I can verify that, although I had to have a long chat with my AVS before I found a solution. Morman AV doesn't like W32/W.B.

_____________________________

Jim Cobb

(in reply to Erik Rutins)
Post #: 26
RE: cannot get game to start - 11/26/2008 5:53:04 PM   
Iain McNeil


Posts: 1935
Joined: 10/26/2004
From: London
Status: offline
Some changes are scenario specific but many effect game rules or general behaviour so apply to all.

_____________________________

Iain McNeil
Director
Slitherine Software
Website http://www.slitherine.com

(in reply to Bismarck)
Post #: 27
RE: cannot get game to start - 11/27/2008 11:29:55 PM   
jon1doc

 

Posts: 14
Joined: 10/26/2008
Status: offline
well gentlemen and all
there seems to have been quite a flurry of activity on my original query.
I have all the relevent files in digi download puchase. I have not loaded any of the patch versions ,nor reinstalled XP but....
Can someone-anyone now advise me-please...

HOW do I start my game???
Can anyone spare the time to provide me with a  java friendly walkthrough  for the process.
Thank you in advance
Jon1doc

(in reply to Iain McNeil)
Post #: 28
RE: cannot get game to start - 11/27/2008 11:54:09 PM   
Bismarck


Posts: 747
Joined: 9/23/2000
Status: offline
You mean Ian and Firepowerjohan don't have all the answers? My.my,my.

Too bad you waited for my review, you wouldn't have bought the game. Ask Matrix for credit toward Napoleon's campaigns. My copy of CNAW started fine. Sorry I can't be more help.

_____________________________

Jim Cobb

(in reply to jon1doc)
Post #: 29
RE: cannot get game to start - 11/28/2008 9:56:57 AM   
Iain McNeil


Posts: 1935
Joined: 10/26/2004
From: London
Status: offline
Thanks for your valuable input Jim, but unfortunately it misses the point again.

Jon, there seems to be some problems with the certain machines running the Matrix version from some of the shortcuts. Erik is investigating but as they can't repeat it it's not that simple for them to locate. Can you try running the game from the start menu shortcut instead of the autorun pop up box and see if that helps. It seems to be related to the installer rather than the game. Ekaranik has found a potential work around, see above, but it requires you to type some commands in to a dos box. I understand if you're not comfortable doing that and as soon as it's resolved I'm sure Matrix will release a patch to fix it.

_____________________________

Iain McNeil
Director
Slitherine Software
Website http://www.slitherine.com

(in reply to Bismarck)
Post #: 30
Page:   [1] 2   next >   >>
All Forums >> [Current Games From Matrix.] >> [Napoleonics] >> Commander - Napoleon at War >> Tech Support >> cannot get game to start Page: [1] 2   next >   >>
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.117