Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

RE: WITP editor x and Win98

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Current Games From Matrix.] >> [World War II] >> War In The Pacific - Struggle Against Japan 1941 - 1945 >> Scenario Design >> RE: WITP editor x and Win98 Page: <<   < prev  1 2 3 [4]
Login
Message << Older Topic   Newer Topic >>
RE: WITP editor x and Win98 - 12/29/2006 5:40:11 AM   
Reg


Posts: 2738
Joined: 5/26/2000
From: Victoria, Australia
Status: offline
quote:


Hmm...runnin also on Win98SE and having no problems....


Bugger. I was hoping someone wasn't going to say that.......

(but good news to other users!!)

< Message edited by Reg -- 12/29/2006 6:00:39 AM >


_____________________________

Cheers,
Reg.

(One day I will learn to spell - or check before posting....)
Uh oh, Firefox has a spell checker!! What excuse can I use now!!!

(in reply to Sardaukar)
Post #: 91
RE: WITP editor x - 1/10/2007 1:37:15 AM   
jcjordan

 

Posts: 1904
Joined: 6/27/2001
Status: offline
Downloaded this program & have been using it exclusively for editing over the Matrix versions & find it's format much easier to show all the data as well as find any errors using the validate feature or whether the wrong art is being used, pwhex errors etc. Excellent job in designing it

< Message edited by jcjordan -- 1/10/2007 1:48:23 AM >

(in reply to CobraAus)
Post #: 92
RE: WITP editor x - 1/10/2007 2:10:41 AM   
BigJ62


Posts: 1800
Joined: 12/28/2002
From: Alpharetta, Georgia
Status: offline

quote:

ORIGINAL: jcjordan

Downloaded this program & have been using it exclusively for editing over the Matrix versions & find it's format much easier to show all the data as well as find any errors using the validate feature or whether the wrong art is being used, pwhex errors etc. Excellent job in designing it


Thanks, can't take credit for all the features some were user requested. Right now I'm working on a much improved version so, stay tuned.

_____________________________

Witp-AE
AeAi…AeAi …AeAi…Long live AeAi.

(in reply to jcjordan)
Post #: 93
RE: WITP editor x - 1/10/2007 7:03:30 AM   
Mifune


Posts: 776
Joined: 4/28/2005
From: Florida
Status: offline
I just tried to update to 0.9.6.9 and I had an error (program wont open). I went back to 0.9.6.8 with no issue.

_____________________________

Perennial Remedial Student of the Mike Solli School of Economics. One day I might graduate.

(in reply to BigJ62)
Post #: 94
RE: WITP editor x - 1/10/2007 10:24:25 AM   
BigJ62


Posts: 1800
Joined: 12/28/2002
From: Alpharetta, Georgia
Status: offline

quote:

ORIGINAL: Mifune

I just tried to update to 0.9.6.9 and I had an error (program wont open). I went back to 0.9.6.8 with no issue.


Did you try re-downloading?

What is the exact error message, not sure I have ever seen (program wont open)?

What OS are you using?

Thanks...

_____________________________

Witp-AE
AeAi…AeAi …AeAi…Long live AeAi.

(in reply to Mifune)
Post #: 95
RE: WITP editor x - 1/10/2007 5:01:07 PM   
R8J


Posts: 238
Joined: 10/12/2006
From: Shelby County, Tennessee
Status: offline
I have a problem with the new version. I do not recall what the eror was (I'm at work).

(in reply to BigJ62)
Post #: 96
RE: WITP editor x - 1/10/2007 5:06:18 PM   
BigJ62


Posts: 1800
Joined: 12/28/2002
From: Alpharetta, Georgia
Status: offline

quote:

ORIGINAL: R8J

I have a problem with the new version. I do not recall what the eror was (I'm at work).


What OS are you using?

_____________________________

Witp-AE
AeAi…AeAi …AeAi…Long live AeAi.

(in reply to R8J)
Post #: 97
RE: WITP editor x - 1/10/2007 6:51:02 PM   
BigJ62


Posts: 1800
Joined: 12/28/2002
From: Alpharetta, Georgia
Status: offline
Ok, I put up a new version for those who are having problems, hopefully it will give more information as to what the problem is.

Thanks...

_____________________________

Witp-AE
AeAi…AeAi …AeAi…Long live AeAi.

(in reply to BigJ62)
Post #: 98
RE: WITP editor x - 1/10/2007 10:10:19 PM   
VSWG


Posts: 3432
Joined: 5/31/2006
From: Germany
Status: offline
quote:

ORIGINAL: R8J

I have a problem with the new version. I do not recall what the eror was (I'm at work).

No offense, R8J, but that is probably the worst bug report in the history of software programming.

_____________________________


(in reply to R8J)
Post #: 99
RE: WITP editor x - 1/10/2007 10:54:20 PM   
Mifune


Posts: 776
Joined: 4/28/2005
From: Florida
Status: offline
I run XP and this is the first time I had an error report generated by EditorX. I did retry and downloaded 0.9.6.9a, but I still have an issue. I have no problem with 0.9.6.8. I PM'd you the error report that XP generated.

_____________________________

Perennial Remedial Student of the Mike Solli School of Economics. One day I might graduate.

(in reply to BigJ62)
Post #: 100
RE: WITP editor x - 1/10/2007 11:40:31 PM   
R8J


Posts: 238
Joined: 10/12/2006
From: Shelby County, Tennessee
Status: offline
Sorry. I was a trouble maker in school. Rather than hold me back, and deal with me for another year, I was passed to the next grade (I passed 9th grade English with a 52) (I did manage to pass French…I know what c’est means). My grasp of the English language is limited so I have a hard time communicating in polite society.

I meant to report that Mifune was not alone with the problem he was experiencing.

No offense taken.

(in reply to VSWG)
Post #: 101
RE: WITP editor x - 1/11/2007 1:01:04 AM   
VSWG


Posts: 3432
Joined: 5/31/2006
From: Germany
Status: offline
quote:

ORIGINAL: R8J

Sorry. I was a trouble maker in school. Rather than hold me back, and deal with me for another year, I was passed to the next grade (I passed 9th grade English with a 52) (I did manage to pass French…I know what c’est means). My grasp of the English language is limited so I have a hard time communicating in polite society.

I meant to report that Mifune was not alone with the problem he was experiencing.

No offense taken.

Now it's my turn to be sorry - it was a simple misunderstanding. By all means, continue to post on this forum.

_____________________________


(in reply to R8J)
Post #: 102
RE: WITP editor x - 1/11/2007 1:44:42 AM   
BigJ62


Posts: 1800
Joined: 12/28/2002
From: Alpharetta, Georgia
Status: offline

quote:

ORIGINAL: Mifune

I run XP and this is the first time I had an error report generated by EditorX. I did retry and downloaded 0.9.6.9a, but I still have an issue. I have no problem with 0.9.6.8. I PM'd you the error report that XP generated.


Ok, let's try it one more time, I put another version up with even more error checking.

This time backup 0.9.6.8 somewhere safe and unzip 0.9.6.9b version and copy all contents to where you have your current version and overwrite all.

Do not delete anything after copying.

Before starting the app right click on task bar select task manager and make sure WitpEditorX.exe is not running under the processes tab, even better reboot the computer.

If it still does not run try disabling any av, commercial or spyware apps just to see if that might be causing the problem, because there is not that much of a difference between 0.9.6.8 and 0.9.6.9. If none of this helps I'll keep trying to figure it out but right now it works fine on my machine so I don't know what the problem is.

_____________________________

Witp-AE
AeAi…AeAi …AeAi…Long live AeAi.

(in reply to Mifune)
Post #: 103
RE: WITP editor x - 1/11/2007 2:33:43 AM   
barnacle bob

 

Posts: 125
Joined: 10/24/2003
From: Southaven, Ms
Status: offline
I still can not get it to run. My OS is XP Home with all of the updates.

I rebooted the PC, checked the task manager, disabled Norton, I don't have Spyware. Still no luck.

The version is 0.9.6.9. Should it be 0.9.6.9b?

I do not remember the last version I had, I did not save a copy of it. I downloaded it in October if I recall correctly.

This is the dialogue box I get..."WITP Editor X" has encountered a problem and needs to close. We are sorry for the inconvenience.

This is a great tool. I'm lost with out it.

(in reply to BigJ62)
Post #: 104
RE: WITP editor x - 1/11/2007 3:23:42 AM   
BigJ62


Posts: 1800
Joined: 12/28/2002
From: Alpharetta, Georgia
Status: offline
I'm going to put 0.9.6.8 back up as well as the new version. Hmm very strange.

_____________________________

Witp-AE
AeAi…AeAi …AeAi…Long live AeAi.

(in reply to barnacle bob)
Post #: 105
RE: WITP editor x - 1/11/2007 4:06:43 AM   
jcjordan

 

Posts: 1904
Joined: 6/27/2001
Status: offline
Getting an error on 9.6.9 also - only says the encountered error & has to close popup. Click on the click here for more info & says error signature witpeditorx.exe appver 0.9.6.9 modname witpeditorx.exe modver 0.9.6.9 offset 000064fce. I can then click on the click here for the technical info but most of that is in hex format so couldn't tell much from that unless you give me something to look for. I have XP never patched due to it being on my laptop & not connected to internet. Will go back to old version.

Well I now have a problem on 0.9.6.8 ( I was using .7) When I try to validate locations on the location screen I get an invalid argument error popup. I guess I'll go back to .7

< Message edited by jcjordan -- 1/11/2007 4:42:41 AM >

(in reply to BigJ62)
Post #: 106
RE: WITP editor x - 1/11/2007 5:12:58 AM   
barnacle bob

 

Posts: 125
Joined: 10/24/2003
From: Southaven, Ms
Status: offline
I saw the same thing when I clicked "...her for more info...".

(in reply to jcjordan)
Post #: 107
RE: WITP editor x - 1/11/2007 10:21:17 AM   
CobraAus


Posts: 2322
Joined: 8/23/2004
From: Geelong Australia
Status: offline
just to let you know I am not having the slightest problem running the original 0.9.6.9
download cobra aus

(in reply to barnacle bob)
Post #: 108
RE: WITP editor x - 1/11/2007 4:11:22 PM   
BigJ62


Posts: 1800
Joined: 12/28/2002
From: Alpharetta, Georgia
Status: offline

quote:

ORIGINAL: CobraAus

just to let you know I am not having the slightest problem running the original 0.9.6.9
download cobra aus


I think I know what the problem is with the other guys, it would appear that after 0.9.6.8 I started experimenting with some of release build settings trying to optimize the code for faster execution which relies on certain hardware instructions. Antway doesn't matter the new Editor X is coming along quite nicely and will easily outperform the old one.

Later

_____________________________

Witp-AE
AeAi…AeAi …AeAi…Long live AeAi.

(in reply to CobraAus)
Post #: 109
RE: WITP editor x - 1/12/2007 3:13:15 AM   
barnacle bob

 

Posts: 125
Joined: 10/24/2003
From: Southaven, Ms
Status: offline
I downloaded *.8. It works fine.

Thanks.

(in reply to BigJ62)
Post #: 110
RE: WITP editor x - 1/12/2007 1:11:48 PM   
BigJ62


Posts: 1800
Joined: 12/28/2002
From: Alpharetta, Georgia
Status: offline
Put up a new version 0.9.7.0 hopefully those who had problems with 0.9.6.9 will have better luck with this one if not 0.9.6.8 is still available. 0.9.7.0 also contains some new fixes.

_____________________________

Witp-AE
AeAi…AeAi …AeAi…Long live AeAi.

(in reply to barnacle bob)
Post #: 111
RE: WITP editor x - 1/12/2007 2:22:02 PM   
Mifune


Posts: 776
Joined: 4/28/2005
From: Florida
Status: offline
I have no problems with 0.9.7.0, once again thanks for your effort.

_____________________________

Perennial Remedial Student of the Mike Solli School of Economics. One day I might graduate.

(in reply to BigJ62)
Post #: 112
RE: WITP editor x - 1/16/2007 1:42:18 AM   
jcjordan

 

Posts: 1904
Joined: 6/27/2001
Status: offline
This version works for me to & a request to be inclued in a future version if possible. On the View Scenario screen when you run the Production Summary Report, have resource/oil that are currently disabled included in the breakout of the report maybe within parenthesis to differentiate from those active at scenario start. Currently it shows only that which is active at start & not what will be come available. I think CHS or RHS has some oil/resource centers that start the game disabled but repair over time, this was done to simulate the gearing up of the US war economy for Allied bases but haven't played much on the IJ side so can't say there is the same situation there.

Thanks for excellent work done so far

(in reply to Mifune)
Post #: 113
RE: WITP editor x - 1/16/2007 6:38:02 AM   
el cid again

 

Posts: 16335
Joined: 10/10/2005
Status: offline
RHS has probably thousands of centers disabled at start - mostly in places like the USA - so production rises over time.

This has two effects:

a) The resource increases as it repairs up (as you might expect)

b) the cost in supply points to repair them goes down (aggregate over time) - meaning that more and more supplies become available for ops - a good model

This was suggested by someone - AKDreemer I think. And if my memory is right - it will be in his mod.

< Message edited by el cid again -- 1/16/2007 6:50:24 AM >

(in reply to jcjordan)
Post #: 114
RE: WITP editor x - 1/21/2007 5:59:29 AM   
BigJ62


Posts: 1800
Joined: 12/28/2002
From: Alpharetta, Georgia
Status: offline
Minor update to editor, unable to set suffix to zero - fixed.

_____________________________

Witp-AE
AeAi…AeAi …AeAi…Long live AeAi.

(in reply to el cid again)
Post #: 115
RE: WITP editor x - 1/21/2007 7:21:33 AM   
Mifune


Posts: 776
Joined: 4/28/2005
From: Florida
Status: offline
Once again thanks for your support and your EditorX.

_____________________________

Perennial Remedial Student of the Mike Solli School of Economics. One day I might graduate.

(in reply to BigJ62)
Post #: 116
RE: WITP editor x - 1/22/2007 4:59:03 PM   
Sardaukar


Posts: 6802
Joined: 11/28/2001
From: Finland/Israel/Bulgaria
Status: offline
Got some weird messages with latest version..."unable to create empty document" when opening some scenarios ? What is that? Trying to create error log when one already exists ? Didn't cause any problems with using editor though.

(in reply to Mifune)
Post #: 117
RE: WITP editor x - 1/22/2007 8:37:10 PM   
BigJ62


Posts: 1800
Joined: 12/28/2002
From: Alpharetta, Georgia
Status: offline

quote:

ORIGINAL: Sardaukar

Got some weird messages with latest version..."unable to create empty document" when opening some scenarios ? What is that? Trying to create error log when one already exists ? Didn't cause any problems with using editor though.


Is it some scenarios or all scenarios you try to open?

If some which scenarios?

I normally test against stock and I'm not getting any errors like that so there must be something different between your computer and mine which makes debugging a lot harder and also I usually print to a message box in the event of an error. Off the top of my head I don't know if that's a mfc or stl error your're getting I'll have to check.

Just a thought check the directory where you opened the scenario and look for any strange looking file(s) - misnamed or zero sized or something like that and make certain all files are present and no other program is currently using them.

Thanks

_____________________________

Witp-AE
AeAi…AeAi …AeAi…Long live AeAi.

(in reply to Sardaukar)
Post #: 118
RE: WITP editor x - 1/23/2007 3:11:15 PM   
Sardaukar


Posts: 6802
Joined: 11/28/2001
From: Finland/Israel/Bulgaria
Status: offline
quote:

ORIGINAL: BigJ62

Is it some scenarios or all scenarios you try to open?

If some which scenarios?

I normally test against stock and I'm not getting any errors like that so there must be something different between your computer and mine which makes debugging a lot harder and also I usually print to a message box in the event of an error. Off the top of my head I don't know if that's a mfc or stl error your're getting I'll have to check.

Just a thought check the directory where you opened the scenario and look for any strange looking file(s) - misnamed or zero sized or something like that and make certain all files are present and no other program is currently using them.

Thanks


Only some (one?) scenarios. I think it gave me that with either CHS2.08 Scen155 or RHSCVO6.61, don't remember just now which one. It doesn't affect functionality, just have to click those messages away.

Great editor, I use it exclusively nowadays.

< Message edited by Sardaukar -- 1/23/2007 3:24:16 PM >

(in reply to BigJ62)
Post #: 119
RE: WITP editor x - 7/20/2018 12:25:11 AM   
WWII44

 

Posts: 7
Joined: 12/2/2015
Status: offline
Link doesn't work any more

(in reply to CobraAus)
Post #: 120
Page:   <<   < prev  1 2 3 [4]
All Forums >> [Current Games From Matrix.] >> [World War II] >> War In The Pacific - Struggle Against Japan 1941 - 1945 >> Scenario Design >> RE: WITP editor x and Win98 Page: <<   < prev  1 2 3 [4]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.180