Problems with Starting the Game? (Full Version)

All Forums >> [Current Games From Matrix.] >> [World War II] >> Steel Panthers World At War & Mega Campaigns >> SP:WaW Training Center


KG Erwin -> Problems with Starting the Game? (8/15/2004 8:02:19 AM)

If the standard start does not work on your PC, here's the solution: either start the game from "Steel Panthers Quick Start" on your desktop program menu, or do this--right click your Steel Panthers desk icon and select "properties": in the "target" line, replace the line with this: "C:\Matrix Games\Steel Panthers World At War\MECH.EXE" . Now, if your hard disk has an ID of a different letter than "C", then replace it with the correct one.

This target path should be regarded as the standard way to open SPWaW.

Sherbert -> RE: Problems with Starting the Game? (8/19/2004 6:09:49 AM)

Hello, I am new to the forums, and trying to get my game to work. I tried the above advice but it didn't work.

I've looked at a few other threads, and have tried those suggestions as well. I tried clicking directly on the mech.exe file in the Steel Panthers folder, as well as trying to access quick start through the Start Menu, and neither of those worked either.

I recently re-formatted my computer, and previous to the re-format, the game worked fine. I can't think of anything that I am missing, but I just can't get the game to work.

Any suggestions, that any of you could give, would really be appreciated. I love this game and really want to play again.


JoeDodgy -> RE: Problems with Starting the Game? (9/23/2004 2:53:40 AM)

I'm also having the same problems, and have tried the above to no avail. I notice the other respondant seems to have got no further. Is there any more help out there? (Direct support maybe?) I'd really like to play this game!!


Goblin -> RE: Problems with Starting the Game? (9/23/2004 4:31:46 AM)

Make sure your Direct X is 9+.


Riun T -> RE: Problems with Starting the Game? (9/23/2004 8:53:13 PM)

I wanted to reply to Goblin about the E-mail u sent me on scinario testing,but I thought it might help these guys if I asked u to post the actual content of true files that Matrix says the game in its entirity,... was zipped on recieving from Mirror site U.S. west coast, that I got a 454megs in zipped files that opened to something like 721megs,and installed to around 830megs??? the reason I ask is that a friend I introduced this game to in the 7.1 ver. went to the exact same mirror site I got 8.2 form and he says his whouldn't play the opening movielet and starts with the selection screen for sollitare,PBEM,first gray screen anyway, He and I were wondering what the download #'s where given to the Mirrors??? His seemed smaller for the same download???? RT
In other words guys I would check the # of full files u have compared to the # goby posts for True files if they don't add up its time for full new REdownload and install, try it from the VERY beginning. RT

Goblin -> RE: Problems with Starting the Game? (9/24/2004 12:00:12 AM)

My install of 8.2 shows 1.03 GB. Dunno if thats right or not...


lynxcat -> RE: Problems with Starting the Game? (10/24/2004 1:35:20 AM)



If the standard start does not work on your PC, here's the solution: either start the game from "Steel Panthers Quick Start" on your desktop program menu, or do this--right click your Steel Panthers desk icon and select "properties": in the "target" line, replace the line with this: "C:\Matrix Games\Steel Panthers World At War\MECH.EXE" . Now, if your hard disk has an ID of a different letter than "C", then replace it with the correct one.

This target path should be regarded as the standard way to open SPWaW.

Thanks for the tip!! It worked and now I don't have to keep pulling my hair out thinking I just thru $80 away.... Only thing is I bought the Generals Edition and I found that the line should read "C:\Matrix Games\Steel Panthers World At War Generals Edition\MECH.EXE" for it to work with that.[8D]

omegaall -> RE: Problems with Starting the Game? (10/29/2004 11:04:17 AM)

I just thought this might be a good place to ask some silly questions on starting this.
When I first installed it, under XP pro I got some desktop icons, crossed riflies ? I have reloaded program and only get the 'Generals ed' menu short cut. Not useful as I am not running this verson. The "Minister of War" has huge objections to my spending time and money on serious persuits as war games.

Anyway to get to the point .. What happened to my crossed rifle icons? Or was that some thing else I have just wiped!![:@]

Also when I start teh standard game it wants a dll called 3d9d.dll. Ok so what is that and is it really necessary?

besides all that yes, the game works.

Also I noticed when 8.2 first come out there were issues with it reporting itself as 9.5 if you had an old version around. Novel.. This did happen with me initially but with this re installation it comes up as 8.2

I still have 7.1x loaded on my computer as well as 7.1x-H2H.
I also run 2000 Server as well as XP pro just to add to the confusion. Seperate drives through.



minefield -> RE: Problems with Starting the Game? (11/11/2004 5:57:52 PM)

Ok if you are having trouble be sure to list this information to assist us in helping you:
What operating system you are running
What version of the game you are trying to run
Any error messages you get.

Sherbert, make sure you have all the latest updates for your operating system. You might want to check for video card updates from its manufacturer's website. Make sure you have the latest version of DirectX. You can try to run mech.exe in different compatibility modes. Go to your spwaw folder and right click on mech.exe. Depending on your os there will be a tab and some options for different ways to run it.

Riun T, the installation file for 8.20 (the free one without megacampaigns) is reported as 429 MB (450,220,261 bytes). Right click on the file to get the bytes. That is the size not the size on disk if you are using XP. I went ahead and updated to 8.3 and the SPWAW folder itself is reporting 1.01 GB (1,091,887,525 bytes) but I have run the game at least once so it has already created some files like those for preferences. So mine may be a tad larger than the initial install. The file for updating 8.3 is 3.90 MB (4,097,185 bytes) in size. If you think your download is corrupt, use a program like Winzip to check the CRC of the file (if you downloaded it as a zip which I think most of these files are) to see if it is corrupt. Some programs can repair a download but that is a bit advanced for here.

Even if you are running the free version of the game I believe it still calls itself the general edition. What you really want to do is to create a shortcut to the game itself. You can open up your start menu -> programs -> steel panthers... folder and drag the quick start icon to the desktop or alternatively you can open up my computer and navigate to your steel panthers folder (default install is under matix games folder). Once inside the folder scroll down until you see mech.exe and right click, make shortcut. Drag this to the desktop and rename it to SPWAW or something. Right click and in the "shortcut" tab click on change icon. Navigate out of the default folder back to the Matrix games folder and click on Steel Panthers ... folder. Click open and it should give you the crossed bullets icon as a choice. Icons are superficial. It is just something Windows uses to make things pretty. You can actually use any icon you want for any shortcut you want. You just need the *.ico file. If you like the soldier icon better or another version's icon better, just show the shortcut where the old version is and it will give you the option to use the icon.
Someone might can upload the various icons to this thread if they want.

3d9d.dll appears to be a dynamic link library for directx. Try reinstallings directx9 and see if the error goes away. The file is supposed to reside in C:\WINDOWS\system32 .

The game reporting itself as 9.5 is a registry problem and should have no effect on gameplay.

wheeltapper -> RE: Problems with Starting the Game? (2/7/2005 2:57:30 PM)

Is there anyone out there sucessfully running SPWAW using an Asrock K7Upgrade-600 motherboard? I have in the past run (although with some initial difficulty) SPWAW under Windows 98 SE and Windows 2000Pro. I recently upgraded to an Athlon 3200+ on the above motherboard. When I run the program and "play the game" from the opening menu it goes through all the credits and then reverts to the opening menu. I have tried all the compatibility settings on XP pro (though it should run under XP) starting from mech.exe etc. - been there before, got the t-shirt etc. running under win 98 and 2000Pro.
I'm quite happy that all my hardware is well above minimum requirements. However I have seen somewhere suggestions that SPWAW has problems with Asus boards and Asrock is of course a cheaper brand of Asus although so far as I can see a well equiped m/b - raid enabled, upgradable to 747 pin processor with optional plug-in card etc. Maybe I will have to say goodbye to SPWAW as I don't want to change the motherboard only 2 weeks after I bought it

Any observations or suggestions particularly from those using Asus/Asrock motherboards would be appreciated

sztosz -> RE: Problems with Starting the Game? (2/7/2005 3:24:51 PM)

Well I having ASRock K7S41 with Athalon 2500XP+ and most recent BIOS had no problem running SPWAW 8.00 and 8.30, I advise reinstalling the program or OS (I don't think that could be hardware issue, maybe try different sound or video drivers).

wheeltapper -> RE: Problems with Starting the Game? (2/7/2005 7:14:21 PM)

Thanks for the advice.

I'm tearing my hair out - fortunately I've got plenty. About an hour or so ago I was downloading a file wwhen I suddenly realised a SPWAW autorun icon had appeared on my desk top. I opened it up and SPWAW loaded and played normally. After a while I re-booted. Result zilch - back to square one! Strange - but as I said previously I have had starting problems with earlier versions of SPWAW running undwer Win 98 and 2000 pro

chief -> RE: Problems with Starting the Game? (2/7/2005 10:55:17 PM)

Quick and dirty answer.....try starting SPwaw from the Mech.exe file in the game folder....and if that works then make a shortcut to same. You won't have the opening credits but WTH......

Good Luck

wheeltapper -> RE: Problems with Starting the Game? (2/8/2005 1:04:15 AM)

Thanks for the reply

As I said I've been there, got the t-shirt etc over several years of running SPWAW from version 4 onwards under Win95/98/2000 booting from mech.exe. I have to say that in my experience SPWAW has never run "out of the box" as I would expect a program to do. I have come to the conclusion that SPWAW users fall into two main categories - those for whom it works without any problem or with the minimum of effort and those who like me currently just can't get it to run despite having a set-up way over the minimum requirements

Why should it suddenly decide to run this pm without any intervention on my part and then go back to square one when I re-booted? Since I up-graded my computer a week or so ago I have been gradually re-loading my favoutite war-games - some of them dos/pre-windows and generally they have all worked without a problem. The fact that I have exactly the same problem with amother matrix game - Battles in Normandy- leads me to the conclusion that it is something peculiar to Matrix and possibly my setup. I have had no reason other than the present problem to believe that my setup is not running as it should.I downloaded a fresh copy of V8.2 today from a different source with exactly the same result. I must have un-installed and re-loaded at least 10 times and have more or less written SPWAW off so far as I am concerned

I am delighted with my Athlon 3200+/Winxp pro set up. It is a positive advance on my old Duron850 running running 2000 pro. It does everything I could wish except run SPWAW/Battles in Normandy!

wheeltapper -> RE: Problems with Starting the Game? (2/8/2005 2:14:41 AM)

Herewith the answer to my own problem in the hope that it may help others running under XP (Pro).

When I open up either SPWAW or Battles in Normandy the screen goes blank for a second or so and then reverts to the desktop. If I then open task manager (right click in taskbar) the program is shown as running. Double click on the entry in task manger and - lo and behold!- the program runs.

If anyone can enlighten me as to why this should workf when a normal start won't I should be interested to know. Something to do with my graphics card (128mb 9250 tv-out/dvi driving an analogue TFT monitor) maybe. In the meantime at least I can now run SPWAW and Battles in Normandy

RBWhite -> RE: Problems with Starting the Game? (2/8/2005 4:58:21 AM)


If you have any type of security manager running for internet protection try disabling it or them before playing SPWAW & BIN. I found my security manager to be using 50,000K of memmory when it is considered idle.

SPWAW is a resourses hog and between those two or three programs and all others running in the background, you just could be maxed out on resourses.

Check in task manager under processes to see what your total memory usage is on and off the internet.

Rick White

wheeltapper -> RE: Problems with Starting the Game? (2/8/2005 3:56:07 PM)

Hi Rick

I've checked the memory situation (I have 512mb of ddr 400) and it seems to be ok.

I'm pretty sure it is a graphics glitch. When I first booted this morning everything ran in the noraml way. I then re-started and I was back to the taskbar situation. I closed down and was out for a few hours. Came home - booted up - back to normal startup! Once I have started a session everything will work OK as long as I don't do a re-start. It's annoying and puzzling but I guess I can live with it.


RBWhite -> RE: Problems with Starting the Game? (2/8/2005 4:46:17 PM)

Hi Eric

Do you know the manufacturer of you Motherboard?
The Chipset provider & number?
Is your video card AGP or PCI?

Also, it appears something is grabbing memory and not releasing, but what?

Rick White

wheeltapper -> RE: Problems with Starting the Game? (2/8/2005 7:46:16 PM)

Hi again Rick

Motherboard: Asrock K7 Upgrade-600

Processor AMD Thunderbird 3200+ Xp

Graphics card: MSI Raedon 9250 128MB

Your further thoughts appreciated. I have now been booted up for about 4 hours and done various things - downloading e-mailing etc. and both SPWAW and Battles in Normandy are continuing to load normally ie without going through startup manager


RBWhite -> RE: Problems with Starting the Game? (2/8/2005 8:25:08 PM)

Hi Eric

Some people were having problems if they had an ASUS motherboard with a current intel chipset.

I went from 512 to 1 gig of memory and a lot of my problems went away not all of them.

Rick White

wheeltapper -> RE: Problems with Starting the Game? (2/8/2005 9:19:01 PM)

Hi again Rick

I was aware that problems were reported with Asus boards of which Asrock are of course a cheaper variety. I usually put my own set-ups together but found a company here in Manchester UK who could build me what I wanted for one hundred pounds sterling cheaper than I could source the componenents myself so I bought it! I queried with them the reliability of Asrock boards and they assured me (truthfully I trust) that they had built a lot of Asrock set-ups and were not aware of any reported problems. Time will tell. My own set-up would probably have used a Gigabyte m/b.

I will stick with 512mb of 400 DDR memory. My understanding is that after that the law of diminishing returns rapidly sets in. I would still like to find out why my particular problem has occured but at least I have a work-around. Computers just like human beings are prone to fault.

Regards and thanks again

RBWhite -> RE: Problems with Starting the Game? (2/8/2005 9:37:55 PM)


Another thing, with WinXP Professional make sure you have all the available updates. I found having both XP Professional & Home Edition, they are very much different programs and how they run games & programs, Professional is much better, as long as you are up to date.

Eric: I think your chipset might be VIA. Download the current 4 in 1 chipset upgrade from VIA. All the new INF updates.

Rick White

sztosz -> RE: Problems with Starting the Game? (2/9/2005 10:05:31 AM)

Your M/B is based on:
- Northbridge: VIA KT600
- Southbridge: VIA 8237

That's Via 4 in 1 is essential, I also suggest downloading newest drivers from: Here, you'll find there Via 4 in 1 also, and maybe Bios upgrade if you have Service Pack with your XP (it was essential for me). You can find Bios for your M/B there also. You can find more info about your M/B on: This site

wheeltapper -> RE: Problems with Starting the Game? (2/9/2005 1:47:03 PM)


I have downloaded and installed the 4 in 1 uopgrade. For sake of space and time please see my further observations to Sztosz


wheeltapper -> RE: Problems with Starting the Game? (2/9/2005 1:52:16 PM)

Thanks for the advice. I have downloaded and installed via 4 in 1 and also the Hyperion driver at the same site. I haven't yet flashed the bios on the principle stated on th Asrock website - basically - if it ain't broke don't fix it.

I have done a couple of re-boots and so far SPWAW and BIN have loaded and run normally. Early days yet but hopefully with help from yourself and others we have cracked it. At least if the worst come to the worst I have a fall-back to running from task manager.

Many thanks to yourself and others who have taken the time and trouble to help

deleeuw -> RE: Problems with Starting the Game? (1/27/2007 11:00:32 PM)

Hey all,
I'm having a similar problem:
When I click on Quick start, screen goes blank for a bit, then returns back to the desktop. When I check TaskManager, the program isn't there.

When I click on General start, the screen resolution goes to 640*480, then I get "DynaZip UnZIP error: ZIP file read error!" I click OK, then I get "Failure to get archive directory listing". After clicking OK on the second error, my screen resolution returns top 800*600

When I click on Standard start, the screen resolution goes to 640*480, and
I get a generic spwaw.exe error (the kind that says to send Microsoft an error report". After clickin OK, the error goes away and my screen returns to the normal resolution.

My OS is WinXP Pro and I installed DirectX 9; My system is 2.3Ghz w/ 256 MB DDRAM.  

Any additional assistance would be greatly appreciated.


vahauser -> RE: Problems with Starting the Game? (1/27/2007 11:07:50 PM)


Your system and mine seem very similar.  Try double clicking on the mech.exe in your SPWAW folder and see what happens.  I have a shortcut on my desktop to my mech.exe.  The mech.exe is the best way to start the game.  I never use the SPWAW icon to start the game, only the mech.exe.

deleeuw -> RE: Problems with Starting the Game? (1/27/2007 11:16:03 PM)

vahauser, Thanx for reply. Unfortunately, when I double-click on mech.exe, the screen goes blank for sec, then returns back to my desktop (and mech is not listed in TaskMan).
BTW, does it matter that I have the game installed on my d:\ drive?


vahauser -> RE: Problems with Starting the Game? (1/28/2007 12:53:32 AM)


Try uninstalling the game and re-installing.  You might have a bad directory path.  Maybe.  Re-install on your C drive.

deleeuw -> RE: Problems with Starting the Game? (1/28/2007 2:50:12 AM)

I uninstalled and reinstalled it onto my c:\ drive, into the default folder.
Same problem. Is there any issues with video card compatiities or graphics setup (such as hardware acceleration)?


Page: [1] 2   next >   >>

Valid CSS!

Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI