Windows 8 (Full Version)

All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support



Message


Dipluz -> Windows 8 (4/6/2013 4:43:11 PM)

Hey there,

anyone else also experiencing problems running Distant Worlds Legends on Windows 8?

It installs fine and patches all up to legends beta patch, but when I wanna run it nothing happens.
No process for distantworlds.exe is running or anything. Windows 8 tries it self troubleshoot feature but it dosen't help. I tried to look in even viewer but there is 0 log entries there either :S im getting really confused. Haven't managed to find any Distant Worlds logs yet.




Erik Rutins -> RE: Windows 8 (4/6/2013 5:51:36 PM)

It works fine on our Windows 8 test system. Are you using the latest Legends beta update installer? The first version of it was missing a dependency (.NET 4.0).

Regards,

- Erik




Dipluz -> RE: Windows 8 (4/6/2013 7:36:44 PM)

Yes my Windows 8 said it was already instaslled, so I did not have to install this version (since it had a newer).




turtlefang -> RE: Windows 8 (4/6/2013 7:38:28 PM)

I'm running Windows 8 with DW and not having any problems. Been running it for at least three or four week.




Dipluz -> RE: Windows 8 (4/6/2013 8:15:55 PM)

There was 1 small regedit error in the installation of DIstant worlds Original. im looking through my event viewer for it now.




Dipluz -> RE: Windows 8 (4/6/2013 8:44:26 PM)

I get a error after the installation of the original which says: Invalid RegKey: HKEY_LOCAL_MACHINE\Software\Wow6432nNode\Matrix Games\Distant Worlds.




Dipluz -> RE: Windows 8 (4/6/2013 9:00:30 PM)

Hi there again guys,

I think ive solved my issue, its not that I use a Windows 8 computer.
But that my computer is also a Enterprise domain computer. So for Distant Worlds to get access, you need to type in your enterprise username and the FQDN (Full qualified domain name) yes im a Windows Server guy ;). Might be some good info for the developers t o have in hand, incase their users has work laptops which are in "domains".
Reason why my computer is in a domain is because my gaming workstation died and my boss gave me a dell precision 6700 ;) since he is also a gamer he felt sorry for me :D

*EDIT*

Either the above or that I gave "everyone" full access to regedit.




sbatman -> RE: Windows 8 (4/27/2013 8:28:02 AM)

I think I'm having the same problem. I just bought a machine with Windows 8, installed the original game and the two expansions, but the game won't start. I got an error message during installation also.




sbatman -> RE: Windows 8 (4/29/2013 1:15:31 AM)

Dipluz, I'm getting the same error, but I'm embarrassed to say I don't understand how you fixed it. I have no programming or network administrator background. Would you mind explaining how you fixed the problem in simpler language, if possible?




Bingeling -> RE: Windows 8 (4/29/2013 8:52:01 AM)

I doubt you have the same problem as him. He had an old work computer set up with work network features that created problems. New computers bought by normal people should not have that.

Do you have windows media player installed? Also, getting hold of the error messages won't hurt at all.




sbatman -> RE: Windows 8 (4/30/2013 1:35:59 AM)

Just checked; I do have Media Player. Attached is a screenshot of an error I received while trying to start either the base game or the Shakturi expansion (I forget). I haven't received the error since I installed the Legends expansion. Now the game just loads for about 30 seconds before a notification appears saying "Distant Worlds crashed." A "More info" button appears below the notification, but nothing happens when I click on it. I played this game for a few days about a year ago, but dropped it because the computer I was using was way too slow. Hopefully it will work better on this brand new system, if I can get it to finally load. Wish I could have tested Distant Worlds on the computer before I bought it, lol.




Bingeling -> RE: Windows 8 (4/30/2013 9:59:05 AM)

It looks like a sound problem, apart from that? I guess you got sound on the system? :)

If it is a normal crash, DW will write a crash log (most of the time).

You may have to change your folder settings to see hidden folders, but I find mine (win 7) in:

C:\Users\XXXX\AppData\Roaming\Code Force Limited\Distant Worlds\1.7.0.20

Where XXXX is my login nme, and the very last folder is the version of distant worlds you run.

If it wrote a crash file, it will be named DWCrashLog or something similar. There are a max of two other files there (and the save game folder), so not a lot to get lost in).

The folder that may be hidden is "AppData".




sbatman -> RE: Windows 8 (5/1/2013 12:03:32 AM)

Actually, I don't have sound because my speakers are elsewhere at the moment. My device manager says I have AMD High Definition Audion Device and Realtek High Definition Audio.

I found the crash log! Here's what it says:

Distant Worlds - Crash Dump - 1.7.0.16

11:42:36 PM Sunday, April 28, 2013


System.ApplicationException: Error in the application.
at Microsoft.DirectX.DirectSound.Device..ctor()
at DistantWorlds.Main.reHpArt5St(Int32 , Int32 , Boolean )
at DistantWorlds.Main..ctor(Int32 width, Int32 height, Boolean windowedMode, Splash splashForm)
at DistantWorlds.Start.E7NXHUnuOX(Object , EventArgs )
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.SetVisibleCore(Boolean value)
at System.Windows.Forms.Control.set_Visible(Boolean value)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at QukXpC1BE3xoeTuXDY.oN3gf1JGSWkDKW2j5R.EjGuCuNXlMYH6bP87nV(Object )
at QukXpC1BE3xoeTuXDY.oN3gf1JGSWkDKW2j5R.wSBey0MGf()


Application info follows:

Error in the application.


--- COMPLETE ---





Bingeling -> RE: Windows 8 (5/1/2013 11:26:33 AM)

Try to install/reinstall driver for the realtek audio device. Google returns the realtek driver pages.




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.015625