"Unit ready to deploy" button not visible (Full Version)

All Forums >> [Current Games From Matrix.] >> [World War II] >> Strategic War in Europe



Message


Borsook -> "Unit ready to deploy" button not visible (1/27/2013 5:06:12 PM)

I started a game as Germany, when other countries join the Axis I added them as human controlled. When any of them build a unit the "unit ready to deploy" button is not visible, it is visible only for Germany.




Omnius -> I've Not Seen That Too (1/27/2013 5:37:36 PM)

Borsook,
Now that you mention it I've seen that little discrepancy about the units ready to deploy button not working for every country, mainly for major powers. It would be nice if it worked for every country.
Omnius




doomtrader -> RE: "Unit ready to deploy" button not visible (1/27/2013 6:17:56 PM)

Did you restared the game in the meantime?




Omnius -> I'll look at that (1/27/2013 6:20:29 PM)


quote:

ORIGINAL: doomtrader

Did you restared the game in the meantime?


doomtrader,
I'll check for that, didn't really think of it while noticing the lack of that warning button for many countries.
Omnius




doomtrader -> RE: I'll look at that (1/27/2013 8:50:18 PM)

I have made some quick test and it seems that the feature works properly. Could you please provide some more specific details about the situation?




Borsook -> RE: I'll look at that (1/28/2013 2:15:51 PM)


quote:

ORIGINAL: doomtrader

I have made some quick test and it seems that the feature works properly. Could you please provide some more specific details about the situation?

I restarted the game many times. Details... hmmm, basically like I said out of 4 countries set to human controlled only Germany can see the button. For Italy, Romania, Hungary etc. the button is not visible even though units are ready to be deployed.




Nimrod 9th -> RE: I'll look at that (1/28/2013 4:45:13 PM)

I too have had this happen. I rarely play as Germany. I like to play Allied. I seem to note it most for the USA. But I've never looked for a pattern. I've learned to always check for new units regardless if the icon is there or not.




Omnius -> My Test Results (1/28/2013 5:27:19 PM)


quote:

ORIGINAL: doomtrader

I have made some quick test and it seems that the feature works properly. Could you please provide some more specific details about the situation?


doomtrader,
I did some quick tests with the 1.06 unofficial beta you released just before Matrix gave it to us as 1.07 and Borsook is correct, the feature showing us when units are ready to deploy is broken. I did two tests, one from a saved game file and one from a fresh start, both of the 1941 scenario.

I had saved the 1941 start so I could figure out how to get Finland at war with the USSR and Allies and vice versa, see my corrections in the Tech Support section. I started on turn 1 building two infantry corps that take one turn to build. I did the same for Italy, Great Britain, Canada, the USSR and the USA. I played all countries on human for quicker resolution. On turn 2 only Germany got the new units to deploy feature visible. I didn't deploy any units, just left them in reserve. I ran through about 4 turns building units for Bulgaria and Hungary once they had enough PP's to build an infantry corp. Turn after turn only Germany showed me the new units to deploy sign.

So I decided to test out your theory about saved games maybe impacting that feature negatively. Once again I started the 1941 scenario with all countries set to human. This time I ran through about 4 turns with no saving whatsoever. Once again I built units with the same countries that I did in the first test and the results were exactly the same, only Germany showed me the new units to deploy sign turn after turn. As before I didn't deploy any units.

Something is definitely amiss. It's almost as if the first country we play shows us the sign but then none of the other ones do, that may be why when I played very country on human I only saw the sign for Germany and not any of the Allies, USSR or neutral USA. Almost as if the first country where the sign pops up triggers some kind of instruction to ignore the feature afterwards for the rest of the turn or isn't resetting it for the next country that turn.
Omnius




doomtrader -> RE: My Test Results (1/28/2013 11:25:18 PM)

I've just started new 1941 game as Germany and Hungary, bought units for both countries. Icons popups correctly.




Borsook -> RE: My Test Results (1/29/2013 1:49:22 PM)

Could you test it on 1939? Plus, I changed the human/AI setting when loading a save game (the game initially was started as Germany only.

quote:

ORIGINAL: doomtrader

I've just started new 1941 game as Germany and Hungary, bought units for both countries. Icons popups correctly.





doomtrader -> RE: My Test Results (1/29/2013 5:11:17 PM)

I've just started 1939 campaign (only German as humans), played till France has fallen and Axis minors joined.
Saved the game.
Load the game and set Hungary to Human (Germany still human).
Buy some troops as Germany and later in the same turn as Hungary.
Next turn the icon for Germany has popped up. I have deployed troops. Also for Hungary the icon popped up.




Omnius -> RE: My Test Results (1/29/2013 5:47:56 PM)


quote:

ORIGINAL: doomtrader

I've just started new 1941 game as Germany and Hungary, bought units for both countries. Icons popups correctly.


doomtrader,
I wonder if these interim "unofficial" patches are creating the problem, maybe something isn't going where it needs to and we're not seeing the new units popup. Of course when we take a malfunctioning car to the mechanic it sometimes seems to work nice for the mechanic.

I also wonder if the problem is the number of countries we humans want to play. It looks like you limit yourself to one major power, then add a minor. I had all countries on human and that could confuse it as all I ever saw was Germany show me the new unit popup.

One thing I like about Tof or SWiE is that we can play multiple countries or even all countries. I always hated the games that limited us to one major power and we had to endure watching our computer run AI minor allies run amok ruining our plans.
Omnius




Borsook -> RE: My Test Results (1/29/2013 6:50:17 PM)

Well, that's great, but it does not work for me... I can provide you savegames or screenshots? Btw I'm using gamersgate version patched to 1.07
quote:

ORIGINAL: Omnius


quote:

ORIGINAL: doomtrader

I've just started new 1941 game as Germany and Hungary, bought units for both countries. Icons popups correctly.


doomtrader,
I wonder if these interim "unofficial" patches are creating the problem, maybe something isn't going where it needs to and we're not seeing the new units popup. Of course when we take a malfunctioning car to the mechanic it sometimes seems to work nice for the mechanic.

I also wonder if the problem is the number of countries we humans want to play. It looks like you limit yourself to one major power, then add a minor. I had all countries on human and that could confuse it as all I ever saw was Germany show me the new unit popup.

One thing I like about Tof or SWiE is that we can play multiple countries or even all countries. I always hated the games that limited us to one major power and we had to endure watching our computer run AI minor allies run amok ruining our plans.
Omnius





doomtrader -> RE: My Test Results (1/30/2013 5:09:08 PM)

Borsook,
If you could send me your save game, that might ease the evaluation




Borsook -> RE: My Test Results (2/1/2013 2:07:15 AM)

Here you have the save files, Italy's turn, a corps ready to deploy but no icon... I still don't know what's causing this, as in the same game I have seen the icon before for Italy. Manual convoys maybe?

https://www.dropbox.com/sh/3qjlllyyegtfb0v/ctwMqlnAhv

quote:

ORIGINAL: doomtrader

Borsook,
If you could send me your save game, that might ease the evaluation





Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.0234375