Stuttering, not the zoom one ... and maybe low performance ? (Full Version)

All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support



Message


code99 -> Stuttering, not the zoom one ... and maybe low performance ? (1/23/2013 7:58:52 PM)

First of all, its not the stuttering at the zoom, that i know its normal for a 2D engine

I have some stuttering when panning around my camera, is this also due to the 2D engine ?

Also, i get various freezes, playing at normal speed and i have freezes from half a second to a whole second at times. Its quite annoying because when I get into combat i cant really enjoy combat since i get these feezes every couple of secs and its hard to control my ships ...

Playing at 4X is almost impossible to do anything but sit and wait for time to pass ... problem is that I remember that i used to play DW with the first expansion in the past on my older machine and I must say it was running better ... infact i usually played at 4x and VERY rarely switched to normal speeds, even when watching battles and such it worked well ...

I am running this game on a beast of a machine (a beast for this game).
AMD Phenom 2 x4 (3.4 Ghz x4)
8 GB DDR3 RAM from Corsair
GeForce GTX 660 2048MB GDDR5
Win7 Ultimate

I have latest video, audio and windows updates installed
I also am running the game with the last expansion (Legends) with the latest patch

I've tried disabling the nebula in the backround and also the stars and it still doesnt work.

Both CPU and GPU are bearly utilised ...




KAHUNA -> RE: Stuttering, not the zoom one ... and maybe low performance ? (1/24/2013 7:40:54 PM)

Have you tried to reset the frame rate to about half of the max allowed?It doesn't stop the stuttering but it's not as prevalent.When the game hits midstride in battle it almost becomes annoying to wait out the stutter to see what's happening and make adjustments in battles. Good luck!![:)]




code99 -> RE: Stuttering, not the zoom one ... and maybe low performance ? (1/25/2013 2:44:22 PM)

Oh yeah, thats what ive done after posting that message, feels little better now. Forgot to update my post tho :)

Still stutters but not as bad.




vince0018 -> RE: Stuttering, not the zoom one ... and maybe low performance ? (2/16/2013 12:49:30 PM)

For some reason whenever I try to set the fps limit on my pc it never works properly, and always makes the game worse.

I've tried setting it from 20-60, going up by 5's.
But what it always after setting a limit is go from running super smooth ~60fps to super stuttery ~5fps back and forth, every 5-10 seconds.

The only choice I have is to have it set to unlimited.
Does anyone know what might cause this?

And I know I've complained about performance issues several times in the past, but I still wonder why a couple ships or planets would cause the game to lag so badly.
Does it have to do with how much space an image takes up on the screen?
for example zooming in on a sun/star causes a massive framerate drop, just watching it without moving the camera.
It's fps drops like these that make it frustrating to watch battles, with all the lasers and things moving
with such a stutter.

I can deal with the zooming in/out problem, but these I can't.
Even with the new pc I've gotten a few months ago, I notice no improvement in performance.

Anyways, I didn't mean to start complaining again, been there done that.
But I am really wondering why setting the fps limit doesn't work for me.

Vince




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
1.367188E-02