Game Freezes during replay (Full Version)

All Forums >> [New Releases from Matrix Games] >> Commander - The Great War >> Tech Support



Message


Kuz -> Game Freezes during replay (1/20/2013 4:35:51 AM)

Running version 1.1.4 Replay is just about done when I get a blue circle and then a Windows error message "Commander: The Great War has stopped working. A problem caused the programs to stop working correctly Windows will close the program and notify you if a solution is available."

DXdiag is attached.

Thanks in advance.

Log date: 2013-01-19 22:29:44
[22:29:44][57c][3]Commander: The Great War(v 1.1.4)
[22:29:44][57c][8]Operating system: Windows 7 Service Pack 1
[22:29:44][57c][8]Number of processors: 2
[22:29:44][57c][3]Audio device used: Generic Software
[22:29:45][57c][8]OpenGL 1.5: OK
[22:29:45][57c][8]OpenGL Context version: 2.1
[22:29:45][57c][8]OpenGL Vendor: NVIDIA Corporation
[22:29:45][57c][8]OpenGL Renderer: GeForce GTX 570/PCIe/SSE2
[22:29:45][57c][3]Setting vsync
[22:29:45][57c][3]Initializing video player
[22:29:45][57c][8]Allocating new vertex buffer
[22:29:45][57c][3]Loading main script
[22:29:45][57c][3]Loading app script
[22:29:46][57c][3]Script init
[22:29:46][57c][3]App version:1.1.4
[22:29:46][57c][5]Today is: 20.1.2013
[22:29:46][57c][8]Starting track: main_menu
[22:29:50][57c][8]Creating new audio source. Count: 0
[22:30:01][57c][8]Starting PBEM game. Id: 136179 Kuz vs SgtSteve
[22:30:08][57c][8]Map loaded in 0.081sec
[22:30:09][57c][8]Maximum texture size: 16384
[22:30:16][57c][Warning]Scene initialized in: 7.772 seconds
[22:30:16][57c][Warning] Memory usage: 1860160 bytes
[22:30:16][57c][Warning] Memory allocation time: 0.031 sec
[22:30:16][57c][Warning] Memory deallocation time: 0.031 sec
[22:30:23][57c][8]Starting track: game4
[22:30:23][57c][Warning]Hud initialized in:6.551 seconds
[22:30:25][57c][8]UnitMoveCommand
[22:30:27][57c][8]UnitMoveCommand
[22:30:29][57c][8]UnitMoveCommand
[22:30:31][57c][8]UnitMoveCommand
[22:30:33][57c][8]UnitMoveCommand
[22:30:35][57c][8]UnitAttackCommand
[22:30:36][57c][8]Unit #42 killed
[22:30:36][57c][8]Creating new audio source. Count: 1
[22:30:36][57c][8]Removing gfx for unit #42
[22:30:37][57c][8]UnitAttackCommand
[22:30:39][57c][8]UnitAttackCommand
[22:30:39][57c][8]Creating new audio source. Count: 2
[22:30:41][57c][8]UnitAttackCommand
[22:30:43][57c][8]UnitAttackCommand
[22:30:45][57c][8]UnitAttackCommand
[22:30:47][57c][8]UnitAttackCommand
[22:30:49][57c][8]UnitMoveCommand
[22:30:51][57c][8]UnitAttackCommand
[22:30:51][57c][8]Unit #1041 killed
[22:30:51][57c][8]Removing gfx for unit #1041
[22:30:53][57c][8]UnitMoveCommand
[22:30:55][57c][8]UnitAttackCommand
[22:30:57][57c][8]UnitMoveCommand
[22:30:59][57c][8]UnitAttackCommand
[22:30:59][57c][8]Unit #1252 killed
[22:30:59][57c][8]Removing gfx for unit #1252
[22:31:01][57c][8]UnitAttackCommand
[22:31:03][57c][8]UnitAttackCommand
[22:31:05][57c][8]UnitMoveCommand
[22:31:07][57c][8]UnitAttackCommand
[22:31:09][57c][8]UnitAttackCommand
[22:31:11][57c][8]UnitAttackCommand
[22:31:13][57c][8]UnitAttackCommand
[22:31:15][57c][8]UnitMoveCommand
[22:31:17][57c][8]UnitMoveCommand
[22:31:19][57c][8]UnitAttackCommand
[22:31:19][57c][8]Unit #1263 killed
[22:31:19][57c][8]Removing gfx for unit #1263
[22:31:21][57c][8]UnitAttackCommand
[22:31:21][57c][Error]================================= C++ stack trace ==================================

[22:31:22][57c][Error] (0)
[22:31:22][57c][Error] (0)
[22:31:22][57c][Error] (0)
[22:31:22][57c][Error] (0)
[22:31:22][57c][Error] (0)
[22:31:22][57c][Error] (0)
[22:31:22][57c][Error] (0)
[22:31:22][57c][Error] (0)
[22:31:22][57c][Error] (0) type_info::before
[22:31:22][57c][Error] (0)
[22:31:22][57c][Error] (0)
[22:31:22][57c][Error] (0) HeapFree
[22:31:22][57c][Error] (0) QVectorData::free
[22:31:22][57c][Error] (0) QVectorData::free




Kuz -> RE: Game Freezes during replay (1/21/2013 3:47:47 PM)

Update: It suddenly worked again for approx. two turns now my opponet is getting the same symptoms as in previous post. Freezes during replay, then the exact Windows error as above.




johnnybravo -> RE: Game Freezes during replay (1/21/2013 4:58:21 PM)

Thanks for the report. Are you able to continue your game after game is restated?




Kuz -> RE: Game Freezes during replay (1/21/2013 5:19:27 PM)

No sir. We've tried restarting the game, restarting the computers. We have also checked drivers etc... We can load a single player game and play against the AI with no apparent difficulty. But when we load that particular turn it freezes at the same spot.




Kuz -> RE: Game Freezes during replay (1/21/2013 6:00:58 PM)

Update: We were suddenly able to get through the replay and are able to currently play the game.




Kuz -> RE: Game Freezes during replay (1/21/2013 8:32:53 PM)

update: We were able to play another 8 turns when the game froze on my opponent when he ended turn. I attempted to play my turn and get a Fatal Error: ZLib.

Log date: 2013-01-21 14:30:03
[14:30:03][cdc][3]Commander: The Great War(v 1.1.4)
[14:30:03][cdc][8]Operating system: Windows 7 Service Pack 1
[14:30:03][cdc][8]Number of processors: 2
[14:30:04][cdc][3]Audio device used: Generic Software
[14:30:05][cdc][8]OpenGL 1.5: OK
[14:30:05][cdc][8]OpenGL Context version: 2.1
[14:30:05][cdc][8]OpenGL Vendor: NVIDIA Corporation
[14:30:05][cdc][8]OpenGL Renderer: GeForce GTX 570/PCIe/SSE2
[14:30:05][cdc][3]Setting vsync
[14:30:05][cdc][3]Initializing video player
[14:30:05][cdc][8]Allocating new vertex buffer
[14:30:05][cdc][3]Loading main script
[14:30:05][cdc][3]Loading app script
[14:30:05][cdc][3]Script init
[14:30:05][cdc][3]App version:1.1.4
[14:30:05][cdc][5]Today is: 21.1.2013
[14:30:05][cdc][8]Starting track: main_menu
[14:30:10][cdc][8]Creating new audio source. Count: 0
[14:30:21][cdc][8]Starting PBEM game. Id: 136179 Kuz vs SgtSteve
[14:30:46][cdc][8]Track playback finished
[14:30:46][cdc][8]Starting track: main_menu
[14:31:21][cdc][Error]zlib error




Kuz -> RE: Game Freezes during replay (1/22/2013 3:03:01 AM)

Update: And again after a few hours we were able to load the turn and finish the game. This is maybe the 6th or 7th PBEM I've done through the server. There have been issues but prior to this game they were minimal. While I'm not judging your server administration on one game I think I'd be more interested in a true PBEM similar to Commander: Europe at War. I don't need to see my opponents replay nor does this server based PBEM prevent turn reloads so why have this feature in the first place? Especially since it appears to be a bit unstable.
v/r
Kuz




rjh1971 -> RE: Game Freezes during replay (3/6/2013 9:49:26 PM)

I'm getting the game frozen after the second attack in the replay.

I would appreciate if there is a workaround for this problem, this game has been going on for quite a while.

Version of the game is 1.14

Thanks.

Here's the error report:

Log date: 2013-03-06 22:27:14
[22:27:14][16cc][3]Commander: The Great War(v 1.1.4)
[22:27:15][16cc][8]Operating system: Windows 7 Service Pack 1
[22:27:15][16cc][8]Number of processors: 4
[22:27:15][16cc][3]Audio device used: Generic Software
[22:27:15][16cc][8]OpenGL 1.5: OK
[22:27:16][16cc][8]OpenGL Context version: 3.3
[22:27:16][16cc][8]OpenGL Vendor: ATI Technologies Inc.
[22:27:16][16cc][8]OpenGL Renderer: ATI Radeon HD 3870 X2
[22:27:16][16cc][3]Setting vsync
[22:27:16][16cc][3]Initializing video player
[22:27:16][16cc][8]Allocating new vertex buffer
[22:27:16][16cc][3]Loading main script
[22:27:16][16cc][3]Loading app script
[22:27:16][16cc][3]Script init
[22:27:16][16cc][3]App version:1.1.4
[22:27:16][16cc][5]Today is: 6.3.2013
[22:27:16][16cc][8]Starting track: main_menu
[22:27:19][16cc][8]Creating new audio source. Count: 0
[22:27:32][16cc][8]Starting PBEM game. Id: 125671 rjh1971 vs dshaw62197
[22:27:44][16cc][8]Map loaded in 0.052sec
[22:27:44][16cc][8]Maximum texture size: 8192
[22:27:50][16cc][Warning]Scene initialized in: 6.235 seconds
[22:27:50][16cc][Warning] Memory usage: 1541084 bytes
[22:27:50][16cc][Warning] Memory allocation time: 0.003 sec
[22:27:50][16cc][Warning] Memory deallocation time: 0.003 sec
[22:27:58][16cc][8]Starting track: game3
[22:27:59][16cc][Warning]Hud initialized in:8.044 seconds
[22:28:51][16cc][8]Track playback finished
[22:28:51][16cc][8]Starting track: game4
[22:31:56][16cc][8]Track playback finished
[22:31:56][16cc][8]Starting track: game1
[22:33:21][16cc][8]UnitMoveCommand
[22:33:23][16cc][8]UnitDeployCommand
[22:33:25][16cc][8]UnitDeployCommand
[22:33:27][16cc][8]UnitMoveCommand
[22:33:29][16cc][8]UnitAttackCommand
[22:33:29][16cc][8]Creating new audio source. Count: 1
[22:33:31][16cc][8]UnitMoveCommand
[22:33:31][16cc][8]Creating new audio source. Count: 2
[22:33:33][16cc][8]UnitAttackCommand
[22:33:33][16cc][8]Unit #125 killed
[22:33:33][16cc][8]Removing gfx for unit #125
[22:33:35][16cc][8]UnitAttackCommand
[22:33:35][16cc][Error]================================= C++ stack trace ==================================

[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0) type_info::before
[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0)
[22:33:36][16cc][Error] (0) BaseThreadInitThunk
[22:33:36][16cc][Error] (0) RtlInitializeExceptionChain
[22:33:36][16cc][Error] (0) RtlInitializeExceptionChain
[22:33:36][16cc][Error] (0) RtlInitializeExceptionChain




Lord Zimoa -> RE: Game Freezes during replay (4/15/2013 9:48:52 AM)

Is this now fixed with 1,30?




rjh1971 -> RE: Game Freezes during replay (4/15/2013 11:48:14 PM)

As Kuz pointed out in one of his posts, after a few hours I was able to go through the replay and play the turn. I hit the menu button where the replay froze and was able to get through it an d play the turn.
It hasn't happened again to me while playing v1.3.0 I will report if it does, hopefully not [:)]




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.1015625