Bug in LCU Equipment Upgrade? (Full Version)

All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support



Message


cfulbright -> Bug in LCU Equipment Upgrade? (1/4/2013 7:46:28 PM)

On March 29, 1944, my 24th US Inf. Div had 274 USA Rifle Squad 43. The next day it had 3 USA Rifle Squad 44, and it's AV had gone from 395 to 124. I'm attaching two screen shots of before and after in a DOC in a ZIP file. And there was no mention in the Operations report about the 24th Infantry Division upgrading any devices.

I've had another instance where two Australian divisions upgraded their infantry squads the same turn, and each only got half an allotment of the new squad type, thereby cutting their AV significantly.




michaelm -> RE: Bug in LCU Equipment Upgrade? (1/4/2013 11:15:12 PM)

Can't tell anything from the screen shot apart that the device was ready to upgrade.
You need same number of devices in the pool in order to upgrade a squad
Is there a save before the devices upgraded so I can trace what it thought the numbers were?




cfulbright -> RE: Bug in LCU Equipment Upgrade? (1/5/2013 12:26:35 AM)

Michael,

Here is the save game right before the 24th Infantry Div gets small.




michaelm -> RE: Bug in LCU Equipment Upgrade? (1/5/2013 1:24:50 AM)

Thanks. So far the first device (inf 43) didn't upgrade during the expected 'Upgrade' phase, so something else is kicking in here.

[edit]
1. No upgrade during upgrade phase as not enough in pool - needed 274 but only 196 in pool at the time. [ok]
2. During the device replacement phase, it is applying a multiplier which is 0, resulting in wiping out the device numbers. The chance to get the combination of events for this to happen is low which explains it not being obvious in earlier games. Need to determine what it is trying to do and adjust this 'multiplier' accordingly.
The multiplier is not really needed so it will be removed and replaced with a more simpler method. [1122]




PaxMondo -> RE: Bug in LCU Equipment Upgrade? (1/5/2013 1:22:51 PM)

Michael!

Thanks for the outstanding ongoing support!!!!

[&o][&o][&o]




cfulbright -> RE: Bug in LCU Equipment Upgrade? (1/5/2013 5:41:55 PM)

Michael,

Sounds like you found the problem. Thanks for doing that.

Though you mention likelihood of it happening, it sounds like I hit the jackpot at least twice in this game!




cfulbright -> RE: Bug in LCU Equipment Upgrade? (1/6/2013 1:38:39 AM)

Michael,

Just happened again with another US Inf Div on May 17, 1944. As I noticed it immediately, I'm just going to roll back to the prior turn and turn off Upgrade on that unit.




michaelm -> RE: Bug in LCU Equipment Upgrade? (1/6/2013 3:04:42 AM)

The main trigger seems to be if the unit has more than the normal TOE number of devices in the device being upgraded.
If the upgrade happens in the normal "Upgrade Phase" cycle (ie enough in the pool), it didn't experience this issue. It is only happening if while taking replacements, it decides it can upgrade the device. Which would probably happen if the devices in the pool were upgraded from a LCU upgrading in the previous "Upgrade Phase".




cfulbright -> RE: Bug in LCU Equipment Upgrade? (1/6/2013 3:30:53 AM)

Michael,

In the case of the 31st Inf Div that just went through the same thing, I have 345 USA Rifle 44 Squads, so more than enough for the upgrade.




cfulbright -> RE: Bug in LCU Equipment Upgrade? (1/6/2013 3:42:13 AM)

Michael,

In the case of the 31st Inf Div that just went through the same thing, I have 345 USA Rifle 44 Squads in the pool, so more than enough for the upgrade. Attached are a before file, and I'll put the after file in the next post.

By the way, thanks for going out of your way to track this down, particularly on a weekend.




cfulbright -> RE: Bug in LCU Equipment Upgrade? (1/6/2013 3:44:43 AM)

Michael,

Here is after file. 31st Inf Div now has 6 USA Rifle 44 Squads.




michaelm -> RE: Bug in LCU Equipment Upgrade? (1/6/2013 4:58:23 AM)

The first 2 devices in the LCU have more than the corresponding TOE entries and thus as eligible to be lost on earlier code.

Running the save on the new beta (1122) retained the correct device numbers.
It even puts message in Ops Report distinct from the usual device upgrade in the Upgrade Phase:
31st Infantry Division - some devices have been upgraded at Nagoya





michaelm -> RE: Bug in LCU Equipment Upgrade? (1/6/2013 5:00:03 AM)


quote:

ORIGINAL: cfulbright

Michael,

In the case of the 31st Inf Div that just went through the same thing, I have 345 USA Rifle 44 Squads in the pool, so more than enough for the upgrade. Attached are a before file, and I'll put the after file in the next post.

By the way, thanks for going out of your way to track this down, particularly on a weekend.


There may have been enough at start of turn, but other upgrades could have lowered the pool number before 31st got a look-in.




cfulbright -> RE: Bug in LCU Equipment Upgrade? (1/6/2013 7:11:46 PM)

Michael,

31st Inf Div successfully upgraded. Thank you!

Next question - I split the 8th Chinese Corps at some point months ago to garrison various cities. The A part upgraded to Chinese Rifle Squad 43, B and C did not. Now I can't get B and C to upgrade, no matter what I do, therefore I can't recombine the Corps. I've turned off both Replacement and Upgrade for all Chinese units except these two units, tried them in Rest and Reserve mode, nothing will get them to upgrade. And I have 1700 squads in the pool.

Any thoughts?




michaelm -> RE: Bug in LCU Equipment Upgrade? (1/7/2013 11:34:51 AM)

Not enough supply at base for upgrade.

Also, there is a defect in how missed upgrades are sometimes missed! due to thinking that the next upgrade is available.

fixed in beta 1122a.





Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.015625