Can someone explain the Opart 3.ini? (Full Version)

All Forums >> [Current Games From Matrix.] >> [World War II] >> Norm Koger's The Operational Art Of War III >> TOAW III Support



Message


BigDuke66 -> Can someone explain the Opart 3.ini? (9/5/2012 6:14:28 PM)

Well toying around with the font ini I looked also into the Operat3.ini and I see some thing where I don't have a clue what they are there for, can anyone explain them?

[Options]
MaxScreenY=0
MaxScreenX=0
ElmerHandicap=2
ElmerIntelligence=2
AllFormationLiness=N
OneFormationLine=N

ChangeScreenResolution=Y
ScreenY=1200
ScreenX=1920
PORandomSeed=0
allowMouseWheelZoom=Y
doubleClickComposition=N
doubleclickplanner=Y
contrast=0
brightness=0
menuDelay=5
toolTipHideDelay=3
toolTipShowDelay=500
effectsVolume=10
backgroundVolume=20
JPegQuality=100
movingSelectsNextUnit=N
showPOOptions=Y
PNGSupport=Y
autoSaveLargeMovies=Y
movies=Y
sitrepLogs=Y
airAssistant=N
combatReporting=Y
AllCropCircles=N
OneCropCircle=N
p4=N
p2=N
p1=N
p0=N

nextUsesOOBOrder=Y
hugeMapEnabled=Y
visibleAI=N
experimentalAIP2=Y
experimentalAIP1=Y
oldpathfinding=N
uberdude=N
nointro=Y
restart300=N
stringdump=N
toawlog=N
unitpolog=N
polog=N
norandom=N
autosave=N

nosound=N
multicpu=N
oldsound=N
noupdate=N
slowAnimation=N
nodelay=N


Especially the bold ones aren't clear to me, would also be nice to know if some options like multiCPU should be used at all.





Catch21 -> RE: Can someone explain the Opart 3.ini? (9/5/2012 10:11:42 PM)

I commented an 'Opart 3.ini' file- rather like I did for 'Opart 3 Fonts.ini' a while ago- with pretty much everything I could find lying around here, there and everywhere (by begging from others for example or deduced). Attached, but (as with the fonts ini file) it's actually called 'Opart 3 (Commented).ini' because that's what it does and to keep it separate from the 'real' 'Opart 3.ini' file used by the game. Again I had to rename it to a .txt file to get it to upload here, so the first thing you'll need to do is rename it back after download to give it an .ini extension.

As with the fonts ini file, you might want to compare your 'real' file to this one.

Hope this helps.

P.S. There are ? marks, where I'm not sure or have outstanding Qs. If anyone can fill in any of these 'blanks' or point to any errors, appreciated. If the shorthand isn't understood, just PM me- it's mainly for my own reference.




ichadwick -> RE: Can someone explain the Opart 3.ini? (1/14/2013 6:08:01 PM)

My ini file only has the following:
[Options]
 AllCropCircles=N
 OneCropCircle=N
 p4=N
 p2=N
 p1=N
 p0=N
 nextUsesOOBOrder=Y
 hugeMapEnabled=Y
 visibleAI=N
 experimentalAIP2=Y
 experimentalAIP1=Y
 oldpathfinding=N
 uberdude=N
 nointro=N
 restart300=N
 stringdump=N
 toawlog=N
 unitpolog=N
 polog=N
 norandom=N
 autosave=N
 nosound=N
 multicpu=N
 oldsound=N
 noupdate=N
 slowAnimation=N
 nodelay=N

Can I safely add anything? I want to increase the resolution to 1600x900 - can I add:
ChangeScreenResolution=Y 
ScreenY=1600 
ScreenX=900 




Oberst_Klink -> RE: Can someone explain the Opart 3.ini? (1/14/2013 6:14:57 PM)

The resolution settings in the .ini file should do the trick; I also use a wide-screen, 1440x900 and it works; also worked on a 62" telly.

Klink, Oberst




ichadwick -> RE: Can someone explain the Opart 3.ini? (1/14/2013 6:24:52 PM)

I added
ChangeScreenResolution=Y
ScreenY=1600
ScreenX=900
to the ini file, but it didn't make any difference. Am I missing a variable?




Oberst_Klink -> RE: Can someone explain the Opart 3.ini? (1/14/2013 6:38:52 PM)

Nein Kamerad; the .ini should look like this:

[Options]
AllFormationLines=N
MaxScreenY=900
MaxScreenX=1440
ElmerHandicap=2
ElmerIntelligence=2
AllFormationLiness=N
OneFormationLine=N
ChangeScreenResolution=y
ScreenY=900
ScreenX=1440
PORandomSeed=0

What TOAW version you got anyway?

Klink, Oberst




ichadwick -> RE: Can someone explain the Opart 3.ini? (1/14/2013 7:33:02 PM)

I tried screenx/maxscreenx = 1600
screeny/maxscreeny=900

and also reversed x/y.

Neither made any difference.
Tried ChangeScreenResolution=y and ChangeScreenResolution=n too.
Nada. Won't change resolution.

The above post shows my TOAW3 ini as it came from the DL here.

Thinking I should check the warranty and if I can get a refund, maybe find a more up-to-date game instead.




ichadwick -> RE: Can someone explain the Opart 3.ini? (1/14/2013 8:23:03 PM)

I have the latest version, BTW, just Dl'ed today (Jan 14).




Panama -> RE: Can someone explain the Opart 3.ini? (1/15/2013 2:50:26 PM)

@ichadwick

I don't understand why you can't play the game without a particular resolution. I can run any resolution and still play. Can you explain why you can't play unless you have a specific resolution? That might help with a solution.




ichadwick -> RE: Can someone explain the Opart 3.ini? (1/15/2013 3:42:10 PM)

The game screen opens only to a window at best about 2/3rd my screen size. The icon panel is so small that the icons appear as mere blurs, almost indistinguishable rather than icons. It's difficult to see any map or unit detail except at the highest zoom level (even then the text is grainy). Just want to be able to see everything clearly.

I have some problems with the text - the window goes black when I set it to maximum contrast. Pop-up info windows during gameplay (i.e. after a battle) often only appear in fragments or grey lines. That means I can't see them to click on the okay button, so the game waits while I try to minimize-maximize the window until enough of the box shows up I can see the check mark and click it. Or I try to blindly click where I think the exit button is and hope to find. kind of like playing whack-a-mole.

So it's been rather frustrating for me. Got two other games at the dame time (Unity of Command and Strategic War in Euope). They're fine. Only this one giving me any problems.




Oberst_Klink -> RE: Can someone explain the Opart 3.ini? (1/15/2013 3:48:12 PM)

OK, let's start from the beginning, shall we?

OS, maximum resolution, what screen ratio, 16:9, 4:3, etc.

Now I can attach my .INI, that is in case you monitor or video card supports 1440x900. We are trying our best; and normally the game picks up the desired resolution itself.

Klink, Oberst




ichadwick -> RE: Can someone explain the Opart 3.ini? (1/15/2013 4:14:04 PM)

Win 7, ATI Radeon 5650 card (1GB), Acer Aspire w/i5 processor, 8GB Ram, many GB hard drive space. Drivers & OS all up to date (this is the only problematic game I have had in years).

Also: No sound. I set background sounds on - nada. Sound options (i.e. music, battle, etc) remain greyed out regardless of setting. Normally don't play with music, but other sounds would be nice. There is a crunching (radio?) sound on the launch screen, but none after that.

Native res is 1600 x 900.




Catch21 -> RE: Can someone explain the Opart 3.ini? (1/15/2013 4:32:02 PM)

That seems a pretty solid spec, and should work (I wish I had one like it). Given what you mention I'd first try a re-install from scratch- get rid of the \TOAW folder too. Then start up and see if it works BEFORE any patches. Sort of step-by-step. I've never known of a screen res issue that couldn't get sorted here, real ancient H/W and OSes aside...




Oberst_Klink -> RE: Can someone explain the Opart 3.ini? (1/15/2013 5:23:18 PM)


quote:

ORIGINAL: ichadwick

Win 7, ATI Radeon 5650 card (1GB), Acer Aspire w/i5 processor, 8GB Ram, many GB hard drive space. Drivers & OS all up to date (this is the only problematic game I have had in years).

Also: No sound. I set background sounds on - nada. Sound options (i.e. music, battle, etc) remain greyed out regardless of setting. Normally don't play with music, but other sounds would be nice. There is a crunching (radio?) sound on the launch screen, but none after that.

Native res is 1600 x 900.

See my attachment; other than that a re-install in the default directory is recommended. 3.4 works even on an ancient PIII crap-top I have as a Fhr-Reserve :)

Klink, Oberst




Panama -> RE: Can someone explain the Opart 3.ini? (1/16/2013 2:08:17 AM)

@ichadwick,

It sounds like you are running pre 3.4 version. In pre 3.4 there was a problem as you explain yours. 3.4 fixed that. Maybe it's a driver or DirectX problem.

From What's New:

Also, ensure that you have the latest video and sound drivers available for your system and that you have upgraded to the latest version of DirectX from Microsoft. The vast majority of reported problems are resolved by upgrading all drivers and DirectX to the latest versions.

I can run this game on any number of machines without a problem. I know that doesn't help you except you can know that it is a machine specific problem for you.

Click on Help and then About. A small window will open. At the top of the small window should be version number 3.4.0.202 It might go by fast so you could have to do that a couple times.




ichadwick -> RE: Can someone explain the Opart 3.ini? (1/16/2013 6:25:24 PM)

Thanks, Panama. You are right: it's 3.2 something or other. Will update and see if that works. Other than that, all my drivers are up to date, hardware and software (I maintain them that way).
Will report back after update...




ichadwick -> RE: Can someone explain the Opart 3.ini? (1/16/2013 6:49:33 PM)

Tha worked! Thanks. I can actually see what's on the screen and the icons.




Panama -> RE: Can someone explain the Opart 3.ini? (1/16/2013 11:20:08 PM)

You are most welcome. [&o]




ichadwick -> RE: Can someone explain the Opart 3.ini? (1/20/2013 2:10:56 PM)

Do the ini variables all work with the latest update?




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
4.101563E-02