Empire policy changes not taking affect 1.7.0.16 (Full Version)

All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support



Message


MartialDoctor -> Empire policy changes not taking affect 1.7.0.16 (8/14/2012 6:29:38 PM)

Unfortunately, I am not at my home computer and won't be for a while. I'll supply a saved game and info when I get back in a few weeks.

The empire policy changes to things such as fleet sizes and what ships the AI builds does not seem to be having any effect (I checked in the editor to verify this). The AI seems to be ignoring these areas of the empire policy.

I had changed fleet sizes to a larger size, fleet percentages to a higher percentage, and reduced escort amounts while increasing other ship percentages. None of these seem to have done anything.

Anyways, I just wanted to get a notification out. I'll get save info and a copy of my policy files when I get access to them again.




ASHBERY76 -> RE: Empire policy changes not taking affect 1.7.0.16 (8/20/2012 2:23:18 PM)

Agreed.I changed fleet sizes but the A.I seemed to use the same 15 default.




ArchMike -> RE: Empire policy changes not taking affect 1.7.0.16 (8/25/2012 7:05:40 PM)

I concur. I started the game as Human and set everything to Automated (to learn how to play). The design fine tuning in the empire policy was inadequate for military ships (no weapon, no shield, no armor), even though the TXT policy file for Human had positive values for these settings. So my empire kept producing ships without weapons (only some nuclear bombs).

I tried loading other policy files and the same problem about design fine tuning appeared. It seems that the game does not read the good informations.




Theluin -> RE: Empire policy changes not taking affect 1.7.0.16 (8/25/2012 9:24:12 PM)

It's all caused by the same bug that makes almost all ships have no weapons on gamestart. From what I gather the 1.7.0.16 update introduced numbers with decimal places into the policy files. However those files use dots as the decimal separator (like in the UK I think) while in most other countries commas are used for that purpose. As someone mentioned in some other thread here there are 2 solutions to this problem:
a) get some program like Notepad++ and use the replace function to change dots into commas in all the policy files, or
b) go to control panel -> Clock, language & region (Or something similar) -> Change date. time, number formats -> Additional settings -> decimal separator and change it to a dot [:)]

Hope this helps,




ArchMike -> RE: Empire policy changes not taking affect 1.7.0.16 (8/25/2012 11:54:26 PM)

Thanks for the info !




ASHBERY76 -> RE: Empire policy changes not taking affect 1.7.0.16 (8/26/2012 4:48:28 PM)

Another area the policy files are not having an effect is using blockades.I set all the A.I polcies to use DiplomacyTradeSanctionsUseBlockades;N but they still do.





ASHBERY76 -> RE: Empire policy changes not taking affect 1.7.0.16 (9/2/2012 3:26:41 PM)

Atfer testing a bit more I think changing the A.I policies only take effect when you start a new game and not on the fly.The A.I is no longer using blockades and setting fleet sizes to what I choose for them in a new game.




ehsumrell1 -> RE: Empire policy changes not taking affect 1.7.0.16 (9/3/2012 1:23:44 AM)


quote:

ORIGINAL: ASHBERY76

Atfer testing a bit more I think changing the A.I policies only take effect when you start a new game and not on the fly.The A.I is no longer using blockades and setting fleet sizes to what I choose for them in a new game.


I agree Ashberry, I believe that the policy for a race is set (loaded) from the beginning of a
new game. Just like the shipset used, Home system setup, and the like.




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.03125