Another "game won't start" (Full Version)

All Forums >> [New Releases from Matrix Games] >> Conflict of Heroes Series >> Tech Support


theprofessor -> Another "game won't start" (5/11/2012 7:26:14 AM)

Hi, I just received my DVD copy today. The installation process says the .NET framework, the DirectX, and the XNA framework upgrades are all required but they all fail to install. The .NET framework fails half way though the process because "file is corrupt". The DirectX fails because "A Cabinet File necessary for installation could not be trusted. Please verify the Cryptographic Services are enabled and the cabinet file certificate is valid". The XNA fails because "This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package."

I have no idea what any of that means.

Windows 7. My Norton antivirus is turned completely off. My graphics card apparently has 512Mb of memory. (I checked these things after reading other installation-problem posts).

Any ideas? Help please!


theprofessor -> RE: Another "game won't start" (5/11/2012 7:29:20 AM)

Sorry: forgot to mention the basic problem: the game won't start beyond the PLAY screen. I just get an error message saying "Conflict of Heroes has stopped working." when I click the Play link (all resolutions fail) or the Scenario Editor. All the other links work.

MikeGER -> RE: Another "game won't start" (5/11/2012 7:32:08 AM)

Hi Professor

hmmm... "file is corrupt" ...maybe as a 'workaround' you can try to downlaod the digital version too (which you get also with the boxed version)
and try to install it, if that DVD dont work well with you drive, for whatever reasons.

ericbabe -> RE: Another "game won't start" (5/11/2012 2:15:05 PM)

That's a good suggestion; please try the download version to see whether there is a problem with the disk. Also try installing the game from an administrator account.

Erik Rutins -> RE: Another "game won't start" (5/11/2012 2:27:56 PM)

Hi Professor,

You can also try downloading the redistributable compoments, if the rest appeared to download correctly. They should be in the /redist sub-folder of your installation folder, so you can try running them manually there, but you can also try downloading them from these links:

DirectX 9.0c:

.NET 3.5:

XNA 3.1:

If your DVD is bad, we are also happy to replace that and send you a new copy. Please use our Help Desk to request that.


- Erik

theprofessor -> RE: Another "game won't start" (5/11/2012 5:30:40 PM)

Thanks very much for the help gents. I'm guessing the DVD is bad as I could find only the XNA resist file in the installation folder so I'll take Erik's advice and request a new one through the Help Desk.

I wasn't aware I could download the game as well as I ordered from the Academy Games website and I can't find where to download it from the Matrix website. I've registered the game on the Matrix site but can't find a link to download the full games (although I can download the updates).

So, I downloaded the redistributable components from Microsoft following Erik's links. The Direct X asks for the installation path I want--I have no idea what to enter for that. Any suggestions? The other two components seem to have loaded ok. Whether because of the still-missing Direct X or because of further problems with the DVD the game still won't run although it now gets beyond the opening Matrix Games PLAY menu to a CoH Awakening the Bear intro screen but then crashes because "CreateClassWithTypename: Error, class name" shows up on an error window labelled "Error creating piece."

If someone could advise where to install the DirectX components that would be greatly appreciated.


ericbabe -> RE: Another "game won't start" (5/11/2012 6:04:09 PM)

Maybe I'm missing something but it looks as though you want to choose a temporary location, then run DXSETUP from that location when the installer is done running. Perhaps Erik knows more about this.

theprofessor -> RE: Another "game won't start" (5/11/2012 8:48:52 PM)

No, you're not missing anything ericbabe--that's what I needed to do and it worked just fine. Thanks very much for your help. Unfortunately the game still doesn't run so I'm assuming my DVD is fried. I've asked for a replacement.

Thanks again!

Page: [1]

Valid CSS!

Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI