Error when starting the game (Full Version)

All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support


NybbleUK -> Error when starting the game (1/26/2012 10:57:40 PM)

I like 4x style strategy games so after reading reviews and watching some playthroughs I decided to by the game along with it's two expansions.

After installing the base game and both expansions plus the update I was most disappointed to get a "Distant Worlds has stopped working" error message when trying to run the game.

After checking the forums and finding where the crash dump file was located I took a look and found it to say (some of the class names are odd, unless it has obfuscated):

Distant Worlds - Crash Dump -

22:38:28 26 January 2012

System.ComponentModel.Win32Exception: The requested operation requires elevation
at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start()
at FCaSoqQcsKgB4PVvEI.H9DG7eOjws8ETMJKkP.BvR2hIH0h4BAADRumS9(Object )
at FCaSoqQcsKgB4PVvEI.H9DG7eOjws8ETMJKkP.fEdcU0VOS()
at FCaSoqQcsKgB4PVvEI.H9DG7eOjws8ETMJKkP.A8Q1BEH7hs0dOoKWphK()
at FCaSoqQcsKgB4PVvEI.H9DG7eOjws8ETMJKkP.BIwxV3VYN()

--- COMPLETE ---

Sure enough if I set the game to always run as administrator it works, so I have been happily playing. But I was just wondering if this is meant to happen? I installed the game to a separate partition (e drive) so as not to be on the windows system drive and made sure that permissions were set so I had full control of the Distant Worlds folder and all it contains.

I am running Windows 7 64 bit Home Premium

wnxpow -> RE: Error when starting the game (11/10/2012 4:26:59 PM)

I have licensed Windows 7 x64 Professional.
And I had the same error with DistantWorlds.exe when I tried to execute it as a non-admin user with reduced privileges.

This is a poor programming practice, when developers know nothing about UAC and execute every task on their OSes as administrators, without protection. And they make same applications which always need admin rights for ordinar tasks.

Though many modern (and even old) games already "know" about UAC and user profiles. And work fine with reduced privileges.

And there are many topics in the Internet, how to properly use the System.Diagnostics.Process.StartWithCreateProcess, and how to make same things entirely without the StartWithCreateProcess call.


In spite of this, there exists the solution how to run the "Distant Worlds" game with reduced privileges under a non-admin account.

The "DistantWorlds.exe" is somehow controlled by the "autorun.exe" located in the same game folder.
The only thing needed is to set the "RunAsInvoker" property of the "autorun.exe" application. After this the "autorun.exe" becomes running without admin privileges. And the "DistantWorlds.exe" becomes being launched via the "autorun.exe" also under ordinar user account.

Again, the "RunAsInvoker" property must be set for the "autorun.exe", not for the "DistantWorlds.exe".

To set the "RunAsInvoker" property you may use the "Microsoft Application Compatibility Toolkit".
Just google about the "RunAsInvoker" and the "Microsoft Application Compatibility Toolkit".


Nevertheless, I hope, developers of the "Distant Worlds" game would correct this ugly bug with UAC.

LutherBlissett -> RE: Error when starting the game (12/1/2012 2:36:53 PM)

Similar issue here with Win7 64.

The RunAsInvoker fix doesn't work for me. Neither does reinstalling all the packages multiple times, cleaning and reinstall .Net3.5 or C++ nor running as admin and with XP compatibility.
Pretty sure I've tried everything i've found in this forum and nothing has worked.
My error message is:

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: distantworlds.exe
Problem Signature 02:
Problem Signature 03: 50066b51
Problem Signature 04: System.Windows.Forms
Problem Signature 05:
Problem Signature 06: 4ca2baf7
Problem Signature 07: 199a
Problem Signature 08: 2
OS Version: 6.1.7601.
Locale ID: 1033

and the Crash Dump reads:

Distant Worlds - Crash Dump -

11:53:39 PM Saturday, December 01, 2012

System.Runtime.InteropServices.COMException (0x80040154): Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))
at System.Windows.Forms.UnsafeNativeMethods.CoCreateInstance(Guid& clsid, Object punkOuter, Int32 context, Guid& iid)
at System.Windows.Forms.AxHost.CreateWithoutLicense(Guid clsid)
at System.Windows.Forms.AxHost.CreateWithLicense(String license, Guid clsid)
at System.Windows.Forms.AxHost.CreateInstanceCore(Guid clsid)
at System.Windows.Forms.AxHost.CreateInstance()
at System.Windows.Forms.AxHost.GetOcxCreate()
at System.Windows.Forms.AxHost.TransitionUpTo(Int32 state)
at System.Windows.Forms.AxHost.CreateHandle()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.AxHost.EndInit()
at DistantWorlds.Start.lKZpUDDTKHLEILrduwc(Object )
at DistantWorlds.Start.S6yl31Vpln()
at DistantWorlds.Start..ctor()
at QukXpC1BE3xoeTuXDY.oN3gf1JGSWkDKW2j5R.wSBey0MGf()

Any advice?

Bingeling -> RE: Error when starting the game (12/1/2012 10:17:39 PM)

I have found it moody on my laptop. What I have made sure to do is:

1: Run as admin.
2: Install and try to start main game, rots, legends, patch. Verify that each step runs.
3: Accept when i wants to check that .net 3.5 and direxcx 9c or whatever is present.

I recognize the error from the above (top image) from the problems.

Oh, and if you find yourself with no weapons on default designs, you have a non-English environment and fail on the decimal separator in the policy files...

LutherBlissett -> RE: Error when starting the game (12/2/2012 2:08:26 AM)

Actually seems like my error was that I optimized my Win7 build too much. Re-enabling Internet Explorer and Windows Media Player did the trick. Thanks tech support!

VPaulus -> RE: Error when starting the game (12/2/2012 6:15:23 PM)


ORIGINAL: LutherBlissett

Actually seems like my error was that I optimized my Win7 build too much. Re-enabling Internet Explorer and Windows Media Player did the trick. Thanks tech support!


wnxpow -> RE: Error when starting the game (12/10/2012 9:05:52 AM)

Surely. Your problem was not somehow connected with the RunAsInvoker solution.
Because, looking at your log, it was caused by entirely another function.

As such as being caused by another function, it indicates that the execution has passed succesfully the problem with UAC, described above. And just have met entirelly another problem after it.

Page: [1]

Valid CSS!

Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI