Mouse issues (Full Version)

All Forums >> [Classic (Free) Games] >> Titans of Steel - Warring Suns >> Tech Support



Message


Jacu -> Mouse issues (2/2/2011 4:42:23 PM)

Hello,
I bought this game some years ago, and lately wanted to play again so I downloaded the frre version.
I am trying to make it run on a Win 7 x64 computer but the game can't find any mouse.
I am on a Acer 5750G laptop, and I patched to version 1.2.2

I tried also to start it as admin, and in xp or 98 compatibility mode but with no luck.
I think The game runs with no troubles since I can regularly exit from the menu module by alt-X.

Any hints?

Thanks




LarkinVB -> RE: Mouse issues (2/2/2011 8:39:22 PM)

Hmm, no idea yet. Will test on Win7 x64.




Jacu -> RE: Mouse issues (2/3/2011 10:36:43 AM)

Thanks[&o]




LarkinVB -> RE: Mouse issues (2/3/2011 12:04:01 PM)

Sorry, I could find a problem. Can you try with an USB mouse ?




Jacu -> RE: Mouse issues (2/3/2011 2:01:53 PM)

Yep, it is already with a usb mouse.
I tried connecting the mouse and disabling touchpad, or removing mouse and using touchpad.
Nothing worked...




LarkinVB -> RE: Mouse issues (2/3/2011 3:00:44 PM)

Since I use a premade library for graphics/sound/input there isn't much I can do. I will ask the devs. 




Jacu -> RE: Mouse issues (2/4/2011 10:19:40 AM)

If i remember correctly weren't the modules (HQ, factory, Battle) also loadable without going through the menu program? I think to remember it was separate programs but now I can only find the .dll
There is no way to make the hq module start without going through menu?

Thanks

BTW the Map editor works with no problems...




LarkinVB -> RE: Mouse issues (2/4/2011 10:35:05 AM)

Only the obsolete freeware from 1998 or so had seperate executables. I'm sorry but as it seems I can offer no help. I just can't reproduce the problem on all available platforms including Win7 x64.




Jacu -> RE: Mouse issues (2/4/2011 10:50:01 AM)

Thanks for your help.
I spent so many nights with friends on the Amiga to play Mechforce that it feels like urgent to make this work :)

I did some extra testing:
running it as emulation win xp Service pack 2, Aero interface disabled, Admin powers, I am able to see this error prompt:
TCC: Error loading Mouse pointer

Actully the mouse seems to work, I dont see the pointer move or screen updated but if i click randomly, then alt+tab to desktop and then alt+tab back to the game I find it moved to HQ screen. So it might more be a visual update issue.

Don't know if you have suggestions regarding this.

Thanks again for your help

kind regards




LarkinVB -> RE: Mouse issues (2/4/2011 2:20:24 PM)

Can you copy this file into your TOS main folder and execute. It should start a small window with mouse position displayed but without a cursor. After pressing space it should display a simple cursor and after pressing space again it should display another cursor.

I fear it will just say "No mouse detected, but you need one!"




Jacu -> RE: Mouse issues (2/4/2011 2:43:20 PM)

It worked perfectly fine with no errors.
I still think it is a videocard issue now, I installed on another pc at work and I noticed on the laptop i don't even see introductory video, it gets stuck at the very beginning with some 11 and 000.




LarkinVB -> RE: Mouse issues (2/4/2011 5:40:29 PM)

Set intro_at_all = no in data\configs\tcc.cfg at the bottom of the file.




Jacu -> RE: Mouse issues (2/7/2011 1:46:07 PM)

Hello Larkin,
thanks for the suggestion.
It didn't solve, but tweaking the onfig ile I forced the game to start in windowed mode and now it seems to work perfectly.

I always tried to force widnow mode with Alt+Enter but never worked.

now it does.

I AM HAPPY!

Thanks again




LarkinVB -> RE: Mouse issues (2/7/2011 4:43:11 PM)

You can switch between window and fullscreen with ALT-w !

Great that you found a solution.




AceHunter71 -> RE: Mouse issues (4/20/2011 5:50:41 AM)

Same problem but none of the above worked. Still running V.1.2.1, though. I don't know how to update it.




HitBDCman -> RE: Mouse issues (2/3/2013 1:30:12 AM)

I am having the exact same issue. Remembered TOS and wanted to play to feel nostalgic.

However, I do not see a way to change TOS to windowed mode in any of the config files. If there's anybody still out there on the forum any help would be appreciated.

Also, I did try doing alt-w while in the menu and it wont go to windowed mode. When I alt tab it the mouse does move around, and when I alt-x it the game closes for me.




Thorgrim -> RE: Mouse issues (2/7/2013 5:49:58 PM)

Did you try editing tcc.cfg? I can't check the game right now, but IIRC it's there that you can set it to windowed mode.




LarkinVB -> RE: Mouse issues (3/16/2013 2:52:32 PM)

Locate screen_mode in data\configs\tcc.cfg and set it to 0 for window mode.





Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.2734375