5.03Beta has been uploaded to the Members Club! (Full Version)

All Forums >> [Current Games From Matrix.] >> [Discontinued Games] >> Starshatter: The Gathering Storm



Message


Greg Wilcox -> 5.03Beta has been uploaded to the Members Club! (10/10/2008 3:31:58 PM)

We have uploaded Starshatter - The Gathering Storm 5.03 Beta to the Members Club for those Members who would like to help us with the testing of the new bug fixes for this patch release. We are asking for feedback not only for single player but multi-player feedback as well.

Again this is an early public beta so those who want to help out with the testing may. You can access this public beta as a Private Download as long as you have registered your Starshatter - The Gathering Storm serial number in our Members Club (Click on the MEMBERS link in the top nav bar).





Pastro -> RE: 5.03Beta has been uploaded to the Members Club! (10/12/2008 3:07:38 PM)

Will install the patches 5.01 and 5.02 first?
What are the changes?
if so, I still have problems with the Trackir.

thanks




tn_prvteye -> RE: 5.03Beta has been uploaded to the Members Club! (10/13/2008 7:49:11 AM)

Wow!  Great to hear it...testing now.

Is there a list of fixes/changes/additions/etc?




Greg Wilcox -> RE: 5.03Beta has been uploaded to the Members Club! (10/14/2008 8:56:16 PM)

I will try to get a list for everyone. The patch should be comprehensive.

-Greg




tn_prvteye -> RE: 5.03Beta has been uploaded to the Members Club! (10/15/2008 3:40:10 PM)

I've been testing the Highlands campaign, and haven't seen any show-stoppers so far.  TrackIR seems to work okay.  The missions seem a bit more varied now...and there also seems to be more opposition.  Although I haven't played in awhile, so I might just be remembering wrong.  I haven't seen the mission bug where you get odd letters for ships names, and I haven't had any CTDs yet.

Thanks again!

-Steve




wdboyd -> RE: 5.03Beta has been uploaded to the Members Club! (10/20/2008 8:10:05 PM)

Salutations,

Version 5.03 beta

After loading the beta.

Single Missions

A Matter of Focus

Starshatter encountered the following errors while trying to load this mission:

ERROR: unknown ship design 'Raider' in mission 08-Focus.def.
ERROR: unknown ship design 'Focus' in mission 08-Focus.def.
ERROR: unknown ship design 'Raider' in mission 08-Focus.def.
ERROR: unknown ship design 'Vagrant' in missoin 08-Focus.def.


[:(]

All other stock missions loaded correctly. [:)]

Error.log

Load Mission: '08-Focus.def'
Loading ShipDesign 'Berents'
Ship Design Radius = 1020.568115
ShipDesign: no catalog entry for design 'Raider', checking mods...
Loading ShipDesign 'Raider'
WARNING - DataLoader could not load buffer 'Mods/Ships/Raider/Raider.def'
ERROR: unknown ship design 'Raider' in mission '08-Focus.def'\nERROR: unknown ship design 'Focus' in mission '08-Focus.def'\nShipDesign: no catalog entry for design 'Raider', checking mods...
Loading ShipDesign 'Raider'
WARNING - DataLoader could not load buffer 'Mods/Ships/Raider/Raider.def'
ERROR: unknown ship design 'Raider' in mission '08-Focus.def'\nERROR: unknown ship design 'Vagrant' in mission '08-Focus.def'\nLoading ShipDesign 'Jackal'
Ship Design Radius = 100.880684
Mission Loaded.

The Raider.def has been replaced by the Marauder.def in this game version. The mission(08) needs to be updated to reflect the change.

Hopefully the same problem won't rear its ugly head in the games dynamic campaign missions since the Raider type has been replaced by the Maurauder type of ship.




tn_prvteye -> RE: 5.03Beta has been uploaded to the Members Club! (10/22/2008 4:19:12 PM)

I tried to load the same mission and got a CTD.  No error report, just crash.

Also, the Escort missions are acting odd.  When I get to the Escort Waypoint, nothing happens.  I'll fly over to the Ship I'm escorting, but he never acknowledges me.  It also never tells me the name of the ship I'm supposed to escort when I view the in-flight mission info.  It just says "Escort Escort"

Just to complete the mission, I followed the ship I was supposed to escort.  He entered a planet's atmos then stopped in mid-air.  Just kinda sat there and hovered.

I'm still in Highland, so I can't comment on any other campaigns yet.




wdboyd -> RE: 5.03Beta has been uploaded to the Members Club! (10/22/2008 8:11:13 PM)

Salutations,

Everybody, please report CTDs, play difficulties or malfunctions encountered. [:)]

If they don't know about them... they can't fix them.

Oh, if you play through the campaign and experiance NO problems... report that too.[:D]

Thanks. [:)]

Keep Em Flying Commanders.




Incendiary Lemon -> RE: 5.03Beta has been uploaded to the Members Club! (10/29/2008 11:18:07 PM)

CTD in Operation Highland


  TIME  1:01:00
Ship 'Tranor 1' farcast to 'Jalah'
   Belfast Killed Orlak 1 (01:38:34.726)
   [KIA] Killed Belfast (01:38:40.467)

*********************************************
FATAL EXCEPTION:

Registers:
EAX:    00000000
EBX:    344758c8
ECX:    0000001f
EDX:    77379a94
EDI:    344758b8
ESI:    00000000
EBP:    29e92c90

CS:EIP: 001b:00536fe0
SS:ESP: 0023:0012fab8
DS:     0023
ES:     0023
FS:     003b
GS:     0000
Flags:  00010216

Exception Code:  c0000005 ACCESS_VIOLATION
Exception Addr:  00536fe0
                Program attempted to READ from address 0x000001c4

Loaded IMAGEHLP.DLL

Stack Trace (Symbolic):
Address   Frame
00536fe0  29e92c90  0001:00135FE0 D:\Games\Starshatter The Gathering Storm\Starshatter-TheGatheringStorm.exe
0040003e  29e92c94  0000:00000000 D:\Games\Starshatter The Gathering Storm\Starshatter-TheGatheringStorm.exe

*********************************************
PROGRAM TERMINATED.


Also

The following blank screen appeared after finishing Operation Highlander

http://img247.imageshack.us/my.php?image=clipboard01wi4.jpg

Starshatter proceeded into the third campaign without issue.

No campaign completion medal was awarded however.

Finally

Having trouble docking. The carrier registers my landing attempt half the time the other half the camera goes into hangar view and the ship continues to move forward. Unless I use the reverse thrusters I just plow straight into the wall.




Incendiary Lemon -> RE: 5.03Beta has been uploaded to the Members Club! (10/30/2008 3:29:33 AM)

The AI is having trouble with carrier landings. In the first few minutes of Operation Shining Fortress I recorded 12 crashes as fighters collided with the docking bay on final approach.




tn_prvteye -> RE: 5.03Beta has been uploaded to the Members Club! (10/30/2008 3:25:48 PM)

I just finished Highland last night and had the same blank screen issue.

I haven't started Shining Fortress yet.




Incendiary Lemon -> RE: 5.03Beta has been uploaded to the Members Club! (11/1/2008 6:38:02 AM)

Finished Shining Fortress without incident.




Incendiary Lemon -> RE: 5.03Beta has been uploaded to the Members Club! (11/5/2008 10:09:17 PM)

Finished the single player campaign. One or two observations...

The AI has serious trouble docking with carriers. Massive casualties... you can see them listed in the after action reports by scrolling down the fighter wings and noting the number that say "Collision with Orion" or such.

I saw two carries die trying to use a farcaster. In each case they translated and collided with the farcaster. Also, the second farcaster model is untextured.

The black screen on campaign completion occurred again.

Campaign completion medals seem to lag showing up sometime after the start of the next campaign.

But no crashes beyond the one I reported earlier.




wdboyd -> RE: 5.03Beta has been uploaded to the Members Club! (11/6/2008 7:06:08 PM)

quote: "Finished the single player campaign."

Well, at least that is good news.

They need to fix these carrier landing problems.

There is mod fix for this, available for download at www.starshattermods.com .




milkweg -> RE: 5.03Beta has been uploaded to the Members Club! (12/10/2008 4:26:16 PM)

I registered the game and there is no beta patch listed to download, just a video file. 




wdboyd -> RE: 5.03Beta has been uploaded to the Members Club! (12/10/2008 5:14:17 PM)

quote:

ORIGINAL: milkweg

I registered the game and there is no beta patch listed to download, just a video file. 


I just checked, and the Beta file is there for download. Did you follow the simple instruction needed to obtain the file?

It's there, so the problem has to be on your end.

HINT: Members Club.... Members Club.... Members Club. [8|]




tn_prvteye -> RE: 5.03Beta has been uploaded to the Members Club! (12/10/2008 5:24:48 PM)

You need to sign in to the "Members Club".  It confused me at first as well.  It's there.




wdboyd -> RE: 5.03Beta has been uploaded to the Members Club! (12/10/2008 5:27:01 PM)

"You can access this public beta as a Private Download as long as you have registered your Starshatter - The Gathering Storm serial number in our Members Club (Click on the MEMBERS link in the top nav bar). "


Yes... I can see how confusing this can be. [8|]




tn_prvteye -> RE: 5.03Beta has been uploaded to the Members Club! (12/10/2008 5:32:31 PM)

Well, it's listed under "registered downloads" instead of "members downloads".  No, not a big deal, but if he's excited like I was when I saw the news, you get in a hurry.




wdboyd -> RE: 5.03Beta has been uploaded to the Members Club! (12/10/2008 5:34:16 PM)

Your are correct. If you're logged into the Members Club and Registered your Game, then click on "Registered Downloads".




milkweg -> RE: 5.03Beta has been uploaded to the Members Club! (12/11/2008 1:03:46 AM)

I know WTF I am doing and did register the game so no need for the eye rolls. At the same time I registered a few other games and downloaded a beta patch for Hired Guns just fine. There is no beta patch showing for Starshatter:TGS when I click on "Registered Downloads". All there is to download is a useless video file. Also, when registering my games most of them would take me to some internal error page for Matrixgames but after clicking to go back it turns out the games registered fine even with the error. I will try IE because I am using noscript in FF so that could be the cause but I am allowing all scripts for this website so don't think that is the issue. If it was then I wouldn't have been able to download the HG beta patch fine and also a manual for Carriers At War. Go take a look in the Hired Guns forum and youy will see that there are a few people complaing that they can't see the beta patch for Hired Guns and yet I could and did download it. I think it is obvious the issue is at your end and not mine. [8|]




wdboyd -> RE: 5.03Beta has been uploaded to the Members Club! (12/11/2008 7:04:34 AM)

"I think it is obvious the issue is at your end and not mine."

Milkweg,

LOL, I'm not the one having problems downloading anything. You are. [8|]

I just checked again... the beta file is there for download with NO video file. This problem has to be on your end... not mine, or Matrix's download page(s).

Did you resigister the game on the Members Club page? You seem to be repeatedly sent to the normal downloads page.

Regardless, I'm curious as to what the problem is and I hope you figure out what it is.




milkweg -> RE: 5.03Beta has been uploaded to the Members Club! (12/11/2008 5:00:19 PM)

If it's my end that is the issue then explain how I downloaded the beta patch for Hired Guns with no issues. Why are some other people having issues seeing the Hired Guns beta patch and not me if there is nothing wrong at your end? Tell you what I will do. I will boot up my Linux box and try it once more. If I get the same issue then I think it is safe to assume the problem is your end and not mine. Only thing I can think of that might cause an issue in Vista is some of the security software I have installed.

p.s. maybe the issue is with that matrixgames internal code error when I registered my games? Bet you didn't consider that, huh?




wdboyd -> RE: 5.03Beta has been uploaded to the Members Club! (12/11/2008 5:47:08 PM)


quote:

ORIGINAL: milkweg

p.s. maybe the issue is with that matrixgames internal code error when I registered my games? Bet you didn't consider that, huh?


Perhaps, all I know for sure is that I can download the beta with no problems.

Regardless, I hope things get straightened out for you. [;)]




Erik Rutins -> RE: 5.03Beta has been uploaded to the Members Club! (12/11/2008 6:05:20 PM)

I think the Members Club may have developed some issues. Our admin is working on it, hopefully we'll have it all fixed up within a day.




wdboyd -> RE: 5.03Beta has been uploaded to the Members Club! (12/11/2008 6:33:41 PM)

Erik,

I hope you are being paid very well for dealing with all the things you are confronted with.

Aspirin must be like candy to you. [:D]

[:)]




milkweg -> RE: 5.03Beta has been uploaded to the Members Club! (12/12/2008 2:36:02 AM)

That's what I figured, thanks. See, Mr. Boyd? I'm not so dumb after all. ;)




InfernO83 -> RE: 5.03Beta has been uploaded to the Members Club! (12/14/2008 12:36:30 PM)

Since there is no real activity in multiplayer, I couldn't test if the physic-flight bug in mp still exists.
So does it, or did 5.03 fixed it?

For those who did not remember the bug:
In multiplayer server games the fighter and battleships show strange flight phisics after a while of gameplay, such as flighing backwards and so on...

Regards




milkweg -> RE: 5.03Beta has been uploaded to the Members Club! (12/16/2008 3:32:37 PM)

No bet patch showing in my member download still. No, I don't want to download the video. Can you un-register the game so I can re-register it and that might fix the issue? I want to try this patch seeing as no official patch is coming any time soon. Perhaps I can get it some other way?




milkweg -> RE: 5.03Beta has been uploaded to the Members Club! (12/25/2008 6:37:13 PM)

2 weeks and not one bleeding reply. And don't try to tell me no mod has seen my above post. I want the 5.03b patch FFS!




Page: [1] 2   next >   >>

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
4.296875E-02